Closed Bug 1141813 Opened 5 years ago Closed Last year

crash in OOM | large | NS_ABORT_OOM(unsigned int) | nsACString_internal::SetCapacity(unsigned int) with 4K YouTube videos

Categories

(Core :: Audio/Video: Playback, defect, critical)

37 Branch
x86
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox48 --- affected
firefox49 --- affected
firefox-esr45 --- affected
firefox50 --- affected
firefox51 --- affected
firefox52 --- wontfix

People

(Reporter: stephend, Unassigned)

References

()

Details

(Keywords: crash, Whiteboard: [platform-rel-Youtube])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-dc5d5c4a-4183-4d88-b4b4-865a72150310.
=============================================================

Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0

System Specs: 
Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz
32.0 GB RAM
Display adapter type NVIDIA Quadro K600 
Total available graphics memory 17123 MB 
Dedicated graphics memory 1024 MB 
Dedicated system memory 0 MB 
Shared system memory 16099 MB 
Display adapter driver version 9.18.13.4752 
Primary monitor resolution 1920x1200 
DirectX version DirectX 10 


STR:

Sorry that I don't have good steps to reproduce, but I crashed twice while watching 4K YouTube videos, on Firefox 37 beta 4.

https://www.youtube.com/watch?v=toxDDERtvOY was one:

https://crash-stats.mozilla.com/report/index/dc5d5c4a-4183-4d88-b4b4-865a72150310

https://www.youtube.com/watch?v=FOLC-hLDeaI was the other:
https://crash-stats.mozilla.com/report/index/659801f9-5e11-4f0e-a04a-04d812150310

I know in both cases that I went from "(auto)" Quality -> 2160p 4K, and then crashes pretty quickly after (there might've been a seek and/or bitrate-downgrade change, as well).
With 4K videos, I've seen YouTube calling appendBuffer with 18MB segments. Hitting OOM won't take very long on 32 bits windows.
I've reproduced this crash on Windows 7 64bit using Firefox 38 Beta 5 (buildID: 20150416143048). I had several sites opened: Youtube (one video, but not with 4K), Facebook, 3 WebGL games (http://pioul.fr/lolgl/, http://www.omiod.com/games/FK2/, http://wgs-jmarine.rhcloud.com/webgl8x8boardgames/app.html?provider=&gid=), a page with all WebGL games (http://www.3dsitelinks.com/webgl-games) and I navigated on those sites -> crash occurs. I don't have proper STR.
Component: Audio/Video → Audio/Video: Playback
Crash Signature: [@ OOM | large | NS_ABORT_OOM(unsigned int) | nsACString_internal::SetCapacity(unsigned int)] → [@ OOM | large | NS_ABORT_OOM(unsigned int) | nsACString_internal::SetCapacity(unsigned int)] [@ OOM | large | NS_ABORT_OOM | nsACString_internal::SetCapacity]
platform-rel: --- → ?
Whiteboard: [platform-rel-Youtube]
Crash volume for signature 'OOM | large | NS_ABORT_OOM | nsACString_internal::SetCapacity':
 - nightly (version 51): 2 crashes from 2016-08-01.
 - aurora  (version 50): 3 crashes from 2016-08-01.
 - beta    (version 49): 86 crashes from 2016-08-02.
 - release (version 48): 145 crashes from 2016-07-25.
 - esr     (version 45): 273 crashes from 2016-05-02.

Crash volume on the last weeks (Week N is from 08-22 to 08-28):
            W. N-1  W. N-2  W. N-3
 - nightly       1       0       1
 - aurora        2       1       0
 - beta         31      29       6
 - release      58      42      14
 - esr          22      20      22

Affected platform: Windows

Crash rank on the last 7 days:
           Browser   Content     Plugin
 - nightly #539
 - aurora
 - beta    #540      #346
 - release #462      #159
 - esr     #284
Crash volume for signature 'OOM | large | NS_ABORT_OOM | nsACString_internal::SetCapacity':
 - nightly (version 52): 4 crashes from 2016-09-19.
 - aurora  (version 51): 2 crashes from 2016-09-19.
 - beta    (version 50): 26 crashes from 2016-09-20.
 - release (version 49): 327 crashes from 2016-09-05.
 - esr     (version 45): 396 crashes from 2016-06-01.

Crash volume on the last weeks (Week N is from 10-03 to 10-09):
            W. N-1  W. N-2
 - nightly       1       3
 - aurora        1       1
 - beta         21       5
 - release     254      73
 - esr          28      31

Affected platform: Windows

Crash rank on the last 7 days:
           Browser   Content     Plugin
 - nightly           #467
 - aurora            #644
 - beta    #663      #1143
 - release #265      #214
 - esr     #346
I looked at the last 10 crashes, and not once do we have anything related to media in there.

The last 10 crashes where on 32 bits machines, machines with between 148MB and 918MB of physical RAM (with one exception being a 32 bits machine with 6GB of RAM, esr 38). Most on win7 where the minimum amount of memory requires is 1GB.

Should this be filed under audio/video?
platform-rel: ? → ---
Too late for firefox 52, mass-wontfix.
only ~100 crashes per week for current versions - various crash signatures containing nsACString_internal::SetCapacity.  https://crash-stats.mozilla.com/signature/?product=Firefox&_sort=-date&signature=OOM%20%7C%20large%20%7C%20NS_ABORT_OOM%20%7C%20nsACString_internal%3A%3ASetCapacity%20%7C%20IPC%3A%3AParamTraits%3CnsACString_internal%3E%3A%3ARead&date=%3E%3D2018-01-24T14%3A33%3A35.000Z&date=%3C2018-02-07T14%3A33%3A35.000Z

Unclear which crash reports / signatures match to this bug report, because unfortunately the stack isn't listed in prior comments
Closing because no crashes reported for 12 weeks.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.