Closed Bug 114187 Opened 18 years ago Closed 18 years ago

File uploading seems to copy entire file into memory

Categories

(Core :: DOM: Core & HTML, defect)

x86
Linux
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 112973

People

(Reporter: matt, Assigned: alexsavulov)

Details

Build 2001120708, Linux 2.4.15 i686, RedHat 6.1

When I try to upload huge files using Mozilla, the Mozilla's memory usage
increases by the size of the file, so when I try to upload a 250 MB file,
I start getting swapping problems.  Mozilla should have to allocate that much
memory to upload a file.

Might be related to bug 112973
This is a duplicate.  We leak the entire file when we upload.  Go us.....

*** This bug has been marked as a duplicate of 112973 ***
Status: NEW → RESOLVED
Closed: 18 years ago
No longer depends on: 112973
Resolution: --- → DUPLICATE
Wow, that's huge.  vrfy dupe
Status: RESOLVED → VERIFIED
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.