Website: "Seamonkey deutsch" sidebar Tab shows XUL error message. Need to add "Remote XUL/XBL" permission for remote XUL page

VERIFIED INVALID

Status

SeaMonkey
Project Organization
VERIFIED INVALID
3 years ago
3 years ago

People

(Reporter: Rainer Bielefeld, Unassigned)

Tracking

SeaMonkey 2.34 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
With German Seamonkey 2.33.B1 Build 20150223174142 on German WIN7 64bit 
Sidebar Tab "SeaMoney German" does not show contents, but error message "Externes XUL - Diese Seite verwendet eine nicht unterstützte Technologie, die nicht mehr standardmäßig unterstützt wird. Bitte kontaktieren Sie die Inhaber der Website, um sie über dieses Problem zu informieren."

a) Website issue?
b) This problem (if it can be confirmed) does not cause bigger problems 
   for users, but may be mockery and ridicule: "... can't even show 
   their own website ..."
c) I still find <http://www.seamonkey.at/sidebar/addpanel.html> on Website,
   might be obsolete?
d) If Seamonkey will no longer support that sidebar, we would need a
   "How to" for removal of sidebar in existing SeaMonkey installations.
(Reporter)

Comment 1

3 years ago
Created attachment 8576165 [details]
Screenshot

Sometimes, if you get message “... currently not available,  it might be ecessary to minimize the Sidebar with a click on the riffled control handle  
and afterward to expand it again with a click on the riffled control handle to get the error message.
(Reporter)

Comment 2

3 years ago
An other way to get the XUL-error message visible is to switch to Bookmarks panel and then back to German Seamonkey.
(Reporter)

Updated

3 years ago
Summary: Webiste: "Seamonkey deutsch" sidebar Tab shows error message → Website: "Seamonkey deutsch" sidebar Tab shows error message

Comment 3

3 years ago
en-US message:
----------------------
Remote XUL

This page uses an unsupported technology that is no longer available by default.

    Please contact the website owners to inform them of this problem.
----------------------
> c) I still find <http://www.seamonkey.at/sidebar/addpanel.html> on Website,
>    might be obsolete?

Remote XUL has been deprecated.
1. You can use the Remote XUL manager to whitelist "www.seamonkey.at"
https://addons.mozilla.org/de/seamonkey/addon/remote-xul-manager/
2. Use the Tools -> Data Manager to add "Use XUL/XBL Markup" permission to "seamonkey.at" (not so convenient)

KaiRo: Can you add some text to http://www.seamonkey.at/sidebar/addpanel.html to inform the viewer how to whitelist "www.seamonkey.at" using the data manager?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(kairo)
Summary: Website: "Seamonkey deutsch" sidebar Tab shows error message → Website: "Seamonkey deutsch" sidebar Tab shows XUL error message. Need to add "Remote XUL/XBL" permission for remote XUL page
Whiteboard: [either INVALID or ENHANCEMENT]
(Reporter)

Comment 4

3 years ago
(In reply to Philip Chee from comment #3)
> 1. You can use the Remote XUL manager to whitelist "www.seamonkey.at"
> https://addons.mozilla.org/de/seamonkey/addon/remote-xul-manager/

That add-on currently is "not available for Seamonkey 2.33", but see "Bug 1138883 - (meta) Make SeaMonkey compatible Add-Ons more discoverable and convenient." / "Bug 1143276 - Repository with Add-Ons converted for SeaMonkey required"
(Reporter)

Comment 5

3 years ago
May be "seamonkey.at" should be whitelisted by default in SeaMonkey until we have a better solution?

Comment 6

3 years ago
I should actually remove this sidebar from seamonkey.at completely or convert it to HTML, but so far this has been very low priority for me.

Comment 7

3 years ago
(In reply to Rainer Bielefeld from comment #5)
> May be "seamonkey.at" should be whitelisted by default in SeaMonkey until we
> have a better solution?

No, this is an unmaintained and potentially insecure sidebar, we should not whitelist it.
Flags: needinfo?(kairo)

Comment 8

3 years ago
You can download the XUL and wrap it in an extension:
https://developer.mozilla.org/en-US/docs/Creating_a_Firefox_sidebar_extension

Comment 9

3 years ago
Closing as INVALID since there is nothing we can do on the SeaMonkey side of things.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Whiteboard: [either INVALID or ENHANCEMENT]
(Reporter)

Updated

3 years ago
Blocks: 1145509
(Reporter)

Comment 10

3 years ago
See "Bug 1145509 - Website: "Seamonkey deutsch" sidebar should be dropped if it can not be maintained"
Status: RESOLVED → VERIFIED

Updated

3 years ago
Component: General → Project Organization
You need to log in before you can comment on or make changes to this bug.