Cannot install test service due to HTTP connection (testServiceInstallDisableEnableRemove.js / testInstall)

RESOLVED WONTFIX

Status

Mozilla QA
Mozmill Tests
RESOLVED WONTFIX
3 years ago
a year ago

People

(Reporter: whimboo, Unassigned)

Tracking

({regression})

unspecified
regression

Firefox Tracking Flags

(firefox39 disabled)

Details

(Whiteboard: [mozmill-test-failure][mozmill-test-skipped], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
The given Mozmill test fails since yesterday across all platforms for Nightly builds. This clearly sounds like a regression in Firefox for installing the Service add-on.

TEST-START | testAddons\testServiceInstallDisableEnableRemove.js | testInstall
ERROR | Test Failure | {
  "exception": {
    "message": "Notification popup state has been opened", 
    "lineNumber": 27, 
    "name": "TimeoutError", 
    "fileName": "resource://mozmill/modules/errors.js"
  }
}

Pushlog for mozilla-central:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=eab4a81e4457&tochange=6686aacf006f

Given the massive failures I will have to skip this test for now.
(Reporter)

Comment 1

3 years ago
Created attachment 8575848 [details] [diff] [review]
Skip patch
(Reporter)

Comment 2

3 years ago
Skip patch landed on default branch as https://hg.mozilla.org/qa/mozmill-tests/rev/eb36dcfbb6a1.
status-firefox39: --- → disabled
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure][mozmill-test-skipped]
(Reporter)

Comment 3

3 years ago
I had a quick look through the pushlog and I'm fairly sure that bug 1137900 caused this regression given that our local HTTP server cannot serve data via HTTPS.

Shane and Jared, I wonder why we cannot make use of a pref to override the security policy and allow tests to install services via HTTP. Similar what it possible for add-ons with the "extensions.install.requireSecureOrigin" pref.

If you agree with that we should get a bug filed for implementation. Thanks.
Blocks: 1137900
Flags: needinfo?(mixedpuppy)
Flags: needinfo?(jaws)
Keywords: regressionwindow-wanted
(Reporter)

Updated

3 years ago
Summary: Test failure 'Notification popup state has been opened' in testInstall (testServiceInstallDisableEnableRemove.js) → Cannot install test service due to HTTP connection (testServiceInstallDisableEnableRemove.js / testInstall)
(In reply to Henrik Skupin (:whimboo) from comment #3)
> I had a quick look through the pushlog and I'm fairly sure that bug 1137900
> caused this regression given that our local HTTP server cannot serve data
> via HTTPS.

It cant be that hard to setup a cert to be used in tests and given the push to move more stuff to secure channels, our test systems should work that way as well.

> Shane and Jared, I wonder why we cannot make use of a pref to override the
> security policy and allow tests to install services via HTTP. Similar what
> it possible for add-ons with the "extensions.install.requireSecureOrigin"
> pref.
> 
> If you agree with that we should get a bug filed for implementation. Thanks.

I don't agree without understanding what is happening here.  

Why is mozmill any different than our current tests.  I cant find the file testServiceInstallDisableEnableRemove.js which seems like it should be living here:

https://mxr.mozilla.org/mozmill-tests/source/tests/functional/testAddons/
Flags: needinfo?(mixedpuppy)
ok, I found the tests under https://hg.mozilla.org/qa/mozmill-tests/

My primary concern is that bypassing the https restriction means we're not really testing the way it should work.  Is there a plan to add https support for mozmill tests?
Flags: needinfo?(hskupin)
(Reporter)

Comment 6

3 years ago
We have two type of tests. A case like that would fit into remote tests where we would install the service from mozqa.com. For that we have several SSL hosts and certificates. But what we want is to reduce the amount of external network similar to the buildbot rules for mochitests etc. Therefore we have the functional tests, which currently contains this test.

As of now the integrated HTTP server is not able to handle SSL. So if you are saying that there will be no fallback to HTTP, we would have to move this test into the remote testrun. Then we can get it installed via HTTPS.
Flags: needinfo?(hskupin) → needinfo?(mixedpuppy)
Yeah, then we should move it to the remote testrun until we can get a certificate installed on the local test server.
Flags: needinfo?(jaws)
we do have good mochitest coverage on this, so IMO disable this test until https can be used.
Flags: needinfo?(mixedpuppy)
(Reporter)

Comment 9

a year ago
Mozmill is dead and the tests are gone. So nothing we want do here.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.