If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Device Storage]There is no "Format Internal Storage" function in "Media Storage" option.

RESOLVED INVALID

Status

Firefox OS
Gaia::Settings
--
major
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Coler, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected)

Details

(Whiteboard: 2.2-nexus-5-l)

Attachments

(1 attachment)

131.32 KB, image/png
Details
(Reporter)

Description

3 years ago
Created attachment 8575860 [details]
ST.png

[1.Description]:[Nexus 5_v2.2&v3.0]There is no "Format Internal Storage" function in "Media Storage" option.

Attachment:ST.png

[2.Testing Steps]: 
1. Launch Settings.
2. Select "Media Storage" under Storage.
3. Check the list.


[3.Expected Result]: 
3. There should be  "Format Internal Storage" function in "Media Storage" option.

[4.Actual Result]: 
3. No "Format Internal Storage" function.

[5.Reproduction build]: 
N5_2.2:
Build ID               20150310002536
Gaia Revision          166491b92278dc9e648f8d49ab02d9ca00d74421
Gaia Date              2015-03-06 18:26:27
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1cda026f8996
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150310.042021
Firmware Date          Tue Mar 10 04:20:36 EDT 2015
Bootloader             HHZ12d

N5_3.0:
Gaia-Rev        943c8b4039f59b08ba100390e164a076a20c892e
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/a9aff724afc7
Build-ID        20150310160234
Version         39.0a1
Device-Name     hammerhead
FW-Release      5.0
FW-Incremental  eng.cltbld.20150310.191407
FW-Date         Tue Mar 10 19:14:23 EDT 2015
Bootloader      HHZ12d

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
1. This issue does NOT exist on Flame2.2.
2. It can be repro on Nexus 5_v3.0.
Is that a hardware limitation?
Flags: needinfo?(hcheng)
I am not sure, but I think it might be disabled when compiling. NI Askeing to clarify.
Flags: needinfo?(hcheng) → needinfo?(fyen)
The Nexus 5 doesn't have SDCard, so we use fuse for mounting the emulator SDCard.
Because we cannot format fuse on Nexus 5, the format button will be hidden on the UI.
Flags: needinfo?(fyen)
According to comment 3, close this bug due to hardware limitation.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.