Sidebar always opens new browser window

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: mail_john, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build 20011120603 (Windows ME)

When selecting a bookmark from the sidebar bookmarks, a new browser window is
opened (and the URL loaded) instead of the URL being loaded into the current
browser window.

Reproducable: Always

1. Open browser
2. Open sidebar bookmarks (if not already open)
3. Select bookmark

Results: New browser window is opened and URL loaded

Expected: Selected URL is loaded into current browser window (ie, the window on
which the sidebar bookmarks are located)

Notes:

This used to work correctly on previous builds. Currently this makes bookmarks
in the sidebar very annoying and users will stop using it. When you open a
browser window, select a bookmark, users are left with a new (empty) browser
window and a browser window with the contents. Any subsequent selection of
bookmarks fron any sidebar on any browser window opens yet another browser window. 

This is inconsistent behaviour as it is different from the use of the same
bookmarks from the bookmark menu or bookmarks from the quicklaunch bar and
should be reverted as soon as possible as it makes the sidebar unusable for
bookmark/sidebar web browsing.

Suggested fixes:

1. Revert sidebar booksmarks to previous behaviour (opens URL in current window)
with a right-click context menu giving the option to "open in new window".
(preferred as most flexible and consistent with browser).

2. Make behaviour definable in prefs (ie, choose if sidebar links open in same
browser or in new browser window).
(Reporter)

Comment 1

17 years ago
Additonal note, I belive this was a change made for
http://bugzilla.mozilla.org/show_bug.cgi?id=50748 where a sidebar URL used from
a MAIL window was changed in order to open a new browser window. Hoever this
seems to have affected sidebar behaviour on BROWSER windows too. 
(Reporter)

Comment 2

17 years ago
Doesn't happen in latest 2001120808 build - looks like its okay now.

Comment 3

17 years ago
Yep. This is(was) a dupe anyway. Mark as resolved/fixed ?
(Reporter)

Comment 4

17 years ago
yep, can do. 
(Assignee)

Comment 5

17 years ago
-> wfm based on comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.