If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[sv-SE] Ctrl+I / Cmd+I defined as location bar keyboard shortcut in Swedish locale, instead of Ctrl+L / Cmd+L

RESOLVED FIXED

Status

Mozilla Localizations
sv-SE / Swedish
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Dan Wolff, Assigned: Andreas Pettersson)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150310004228

Steps to reproduce:

- Open Firefox
- Go to any page, e.g. https://www.mozilla.org/
- Press Ctrl+L



Actual results:

Nothing. Focus stays where it was before pressing Ctrl+L.


Expected results:

The location bar should have been focused.


The keyboard shortcuts F6 and Alt+D still work.
(Reporter)

Updated

3 years ago
Component: Untriaged → Keyboard Navigation

Comment 1

3 years ago
This also affects Firefox 37 on 64-bit GNU/Linux and 32-bit Windows XP.

Comment 2

3 years ago
I get the same behaviour in Firefox 37.0.1 on windows 7 (32bit) and OSX - both with swedish locale.

Interestingly the location bar is focued when pressing Ctrl+I (Cmd+I on mac), so it might be a l/I mixup?

Comment 3

3 years ago
I experience the same on Windows 8.1 on both 37 and 38 on the BETA release channel. Swedish locale.
I can confirm what Arno wrote, that ctrl+i focues the location bar.

After "upgrading" to English (US) (still 38 on the beta channel) however, the behavior returns to normal.

I think Arno is correct. There is a mixup in the Swedish locale.

Comment 4

3 years ago
Yes, it looks like a problem with the Swedish locale. Ctrl+I does jump to the location bar instead of showing the page info. Kristoffer Melin, can you confirm this?
Flags: needinfo?(melin.kris)

Comment 5

3 years ago
I'm not familiar with the mozilla hg repos and build system, but it seems like the error is here:
https://hg.mozilla.org/releases/l10n/mozilla-release/sv-SE/annotate/be229b521967/browser/chrome/browser/browser.dtd#l391

Comment 6

3 years ago
Reporter, what's your browser locale?


These locales seem to have Ctrl/Cmd + I set as the location bar shortcut:

http://mxr.mozilla.org/l10n-mozilla-release/source/ach/browser/chrome/browser/browser.dtd#391
http://mxr.mozilla.org/l10n-mozilla-release/source/an/browser/chrome/browser/browser.dtd#391
http://mxr.mozilla.org/l10n-mozilla-release/source/bn-IN/browser/chrome/browser/browser.dtd#391
http://mxr.mozilla.org/l10n-mozilla-release/source/id/browser/chrome/browser/browser.dtd#391
http://mxr.mozilla.org/l10n-mozilla-release/source/sv-SE/browser/chrome/browser/browser.dtd#391
Flags: needinfo?(326374)

Comment 7

3 years ago
Confirmed in Firefox 37.0.1 sv-SE in Windows 7 x64.

(In reply to Gingerbread Man from comment #6)
> Reporter, what's your browser locale?

I just noticed the e-mail address TLD. That answers my question.
Status: UNCONFIRMED → NEW
Component: Keyboard Navigation → sv-SE / Swedish
Ever confirmed: true
Flags: needinfo?(326374)
OS: Windows 8.1 → All
Product: Firefox → Mozilla Localizations
QA Contact: slicedlime
Hardware: x86_64 → All
Summary: Ctrl+L does not focus the location bar → [sv-SE] Ctrl+I / Cmd+I defined as location bar keyboard shortcut in Swedish locale, instead of Ctrl+L / Cmd+L
Version: 38 Branch → unspecified

Updated

3 years ago
Duplicate of this bug: 1152297

Updated

3 years ago
Duplicate of this bug: 1152837
(Assignee)

Updated

3 years ago
Assignee: nobody → az
(Assignee)

Comment 10

3 years ago
I have pushed the following change set http://hg.mozilla.org/releases/l10n/mozilla-beta/sv-SE/rev/e4e7cee17722 to solve the mismatch with access keys. Don´t know why this strings were translated again?
I guess confusion between accesskey and commandkey, that's the usual reason.
Flags: needinfo?(melin.kris)

Comment 12

3 years ago
(In reply to az from comment #10)
> Don´t know why this strings were translated again?

I (uppercase i) and l (lowercase L) can look almost indistinguishable, depending on the font used.

https://en.wikipedia.org/wiki/I#Forms_and_variants

Comment 13

3 years ago
(In reply to Gingerbread Man from comment #6)
> These locales seem to have Ctrl/Cmd + I set as the location bar shortcut:

Filed
Bug 1153622 — [ach] Acholi
Bug 1153623 — [bn-IN] Bengali (India)
Bug 1153624 — [id] Indonesian

[an] Aragonese — no report filed because it's cleared up in Beta and doesn't turn up again.

Comment 14

3 years ago
 -<!ENTITY hideThisAppCmdMac2.label       "Göm &brandShorterName;">
 +<!ENTITY hideThisAppCmdMac2.label       "Dölj &brandShorterName;">

-<!ENTITY hideOtherAppsCmdMac.label      "Göm övriga">
+<!ENTITY hideOtherAppsCmdMac.label      "Dölj övriga">

You should revert this change since "Göm" is used in all other mac apps (I'll send an email to the list and explain more).

Updated

3 years ago
Duplicate of this bug: 1153208
(Assignee)

Comment 16

2 years ago
Changed translation of hide, change set http://hg.mozilla.org/releases/l10n/mozilla-beta/sv-SE/rev/fd25ba166802
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.