Apps are badly resize when toggling the orientation on b2g desktop

RESOLVED FIXED in Firefox 39, Firefox OS v2.2

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: ochameau, Assigned: ochameau)

Tracking

unspecified
2.2 S8 (20mar)

Firefox Tracking Flags

(firefox37 wontfix, firefox38 wontfix, firefox39 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

4 years ago
It looks like since bug 1107759, the apps are badly resized when going into landscape and the app doesn't support landscape. We only see half of the app and a black area.
(Assignee)

Comment 1

4 years ago
Created attachment 8576028 [details] [diff] [review]
patch v1

I don't know what happened in bug 1107759 and when we regressed so badly,
but here is a fix and I cleanup up the related code a bit.

It also fix support of default orientation different than portrait (cc:janx).
Attachment #8576028 - Flags: review?(fabrice)
(Assignee)

Updated

4 years ago
Blocks: 1116611
Comment on attachment 8576028 [details] [diff] [review]
patch v1

Review of attachment 8576028 [details] [diff] [review]:
-----------------------------------------------------------------

r=me

::: b2g/chrome/content/screen.js
@@ +198,1 @@
>      }

nit: let controlsHeight = controls ? controls.getBCR().height : 0

::: b2g/chrome/content/shell.css
@@ +20,3 @@
>    border: none;
> +  width: 100%;
> +  height: 100%;

that's a no-op change, right? if so, don't do it ;)
Attachment #8576028 - Flags: review?(fabrice) → review+
(Assignee)

Comment 4

4 years ago
Created attachment 8576530 [details] [diff] [review]
patch v2

Fixed the nits.
Attachment #8576028 - Attachment is obsolete: true
Attachment #8576530 - Flags: review+
(Assignee)

Comment 5

4 years ago
New try as the reftest failure looks suspicious...
https://treeherder.mozilla.org/#/jobs?repo=try&revision=bca9e5f39159
Comment on attachment 8576530 [details] [diff] [review]
patch v2

Review of attachment 8576530 [details] [diff] [review]:
-----------------------------------------------------------------

For OS X, there are no regressions as far as retina support, so seems good to me.
Attachment #8576530 - Flags: feedback+
(Assignee)

Comment 7

4 years ago
The new try is green.
Assignee: nobody → poirot.alex
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/5747865276f1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
(Assignee)

Comment 10

4 years ago
Comment on attachment 8576530 [details] [diff] [review]
patch v2

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
  bug 1107759

User impact if declined:
  2.2 FxOS simulator are buggy when trying to rotate the apps
Testing completed:
  Verified on 3.0 simulators on master.

Risk to taking this patch (and alternatives if risky):
  Patch only against screen.js that is only used on desktop.

String or UUID changes made by this patch:
  No.
Attachment #8576530 - Flags: approval-mozilla-b2g37?

Updated

4 years ago
Attachment #8576530 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Needs rebasing for b2g37 uplift.
status-b2g-v2.2: --- → affected
status-b2g-master: --- → fixed
status-firefox37: --- → wontfix
status-firefox38: --- → wontfix
Flags: needinfo?(poirot.alex)
Target Milestone: --- → 2.2 S8 (20mar)
(Assignee)

Comment 12

3 years ago
Created attachment 8582351 [details] [diff] [review]
b2g27-2.2 patch
(Assignee)

Updated

3 years ago
Flags: needinfo?(poirot.alex)
You need to log in before you can comment on or make changes to this bug.