Status

RESOLVED DUPLICATE of bug 1131087
4 years ago
a year ago

People

(Reporter: voylinux, Unassigned)

Tracking

39 Branch
ARM
Android

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150310004228

Steps to reproduce:

I selected DuckDuckGo as my search engine by default. I put the Firefox widget on my home.
Make a search using the widget.


Actual results:

I get search results list from Google instead of DDG.


Expected results:

A list of search results from DDG.
Component: Widget: Android → Search Activity
Product: Core → Firefox for Android
Version: 36 Branch → Firefox 36
I'm able to reproduce this issue when changing the default search engine for the first time. Changing it for the second time shows the correct behavior.   

If: 
1. Start Firefox with a clean profile. 
2. Add the Firefox search widget to the home screen 
3. Change the default search engine to anything else from list (e.g DDG)

Result: Firefox searches are conducted through DDG. Firefox widget searches are conducted through Google 
     
4. Change the default search engine again to anything else from list (e.g Amazon)

Result: Firefox searches are conducted through Amazon. Firefox widget searches are conducted through Amazon 

Tested on Galaxy Note 3 with Android 4.4.2
Status: UNCONFIRMED → NEW
status-firefox36: --- → affected
status-firefox37: --- → affected
status-firefox38: --- → affected
status-firefox39: --- → affected
Ever confirmed: true
OS: Linux → Android
Hardware: x86_64 → ARM
Version: Firefox 36 → Firefox 39
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1131087

Updated

a year ago
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.