[Bluetooth] Permanent black-screen encountered when enabling Bluetooth and then selecting 'turn on' from the 'Bluetooth is disabled' error message.

VERIFIED FIXED in Firefox OS v2.1

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: iliu)

Tracking

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 wontfix, b2g-v2.1 verified, b2g-v2.1S verified, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8576252 [details]
logcat_20150311_1335.txt

Description:
When selecting 'turn on' on the bluetooth confirmation screen after enabling bluetooth in another way (for example, the notification menu) a permanent black screen is encountered. 
This blackscreen replaces the app that was being used to do the bluetooth share activity. If you minimize it retains its label and icon and will continue to function (for example - if you are sharing with Music - and were playing the song being shared - it will continue to play - you are simply blocked from interacting with the app. To recover from this state you must kill the app and restart it.
This was tested on the following app/media scenarios: Music/Song, Gallery/Picture, Gallery/Video and Contacts/Single Contact

Notes: 
While the method of pulling down the notification menu while already on the bluetooth 'turn on' menu is very edge-case it can occur in other ways - for example:
 Scenario: User has Bluetooth enabled but phone is in Airplane mode. They go to gallery and attempt to share a pic via bluetooth and encounter the bluetooth is disabled screen. They might then realize they have airplane mode on and rather than address things 1 at a time opt to just turn 'all the things' back on at once - so they long-press the power button and tap 'Turn off airplane mode'. Then they realize they still need to address the bluetooth prompt so just offhandedly tap enable because it should not matter at that point.




Repro Steps: (example of BT share activity)
1) Update a Flame to 20150311010231 - do not active BT yet
2) Launch Gallery
3) Select a photo > Select Share > Select Blutetooth
4) On the 'Bluetooth is disabled' screen pull down the notification menu and enable Bluetooth
5) Dismiss the notification menu and select 'turn on'

Actual:
Permanent black screen is encountered


Expected:
Device will continue the share activity proceed to the Bluetooth selection screen (proceed to the Bluetooth selection screen)

Environmental Variables:
Device: Flame Master
Build ID: 20150311010231
Gaia: 943c8b4039f59b08ba100390e164a076a20c892e
Gecko: fd8e079d6335
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (Master)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0


Repro frequency: 9/9
See attached: logcat
(Reporter)

Comment 1

4 years ago
This issue also occurs in 2.2, 2.1 and 2.0

Device: Flame 2.2 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150311002522
Gaia: 3f032238a52f08e4c2f68a47ad065a96eb22d470
Gecko: 004fa1cb1dd4
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150309001219
Gaia: ea97a87048a4c1e2a479bbea1d75e0a182b2c4c9
Gecko: 0443f2e951dc
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150309000203
Gaia: 8463d1c9142f32c8ea175048dac52e41620443ce
Gecko: 9399de0723a0
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Ni on component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(twen)

Comment 3

4 years ago
Black screen is apparent and easily reproduced. Nominate for blocking.
blocking-b2g: --- → 2.2?
Flags: needinfo?(twen)
This looks gaia related bug.
Hi Ian,
This really looks like a gaia bug, because switch to Bluetooth Settings, function still work.
Flags: needinfo?(iliu)

Comment 6

4 years ago
mark as blocker
blocking-b2g: 2.2? → 2.2+

Comment 7

4 years ago
Created attachment 8577886 [details] [diff] [review]
bt-already-on.patch

Gaia bluetooth app doesn't handle BT is already on after confirmation screen shows. Attach a quick fix for reference.

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/bluetooth/js/transfer.js#L96

Ian, please help on this bug.

Comment 8

4 years ago
Set component to Gaia::Bluetooth File Transfer per comment 7.
Component: Bluetooth → Gaia::Bluetooth File Transfer

Comment 9

4 years ago
Hi Ian, I'll assign this to you. thanks.
Assignee: nobody → iliu
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
Flags: needinfo?(iliu)
Created attachment 8577957 [details] [review]
pull request 28887

Arthur, could you please help to review my pr? Thanks.
Attachment #8577957 - Flags: review?(arthur.chen)
Comment on attachment 8577957 [details] [review]
pull request 28887

The patch is looking good to me, thanks!
Attachment #8577957 - Flags: review?(arthur.chen) → review+
Sine the pr is landed, we can close the issue now.

Gaia/master: https://github.com/mozilla-b2g/gaia/commit/6d49c3e9fea44d9fcf477599001b5a431909d12a
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-master: affected → fixed
Resolution: --- → FIXED
Comment on attachment 8577957 [details] [review]
pull request 28887

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Since utility tray is able to display in full screen app in v2.0, Bluetooth app have to considerate the use case.
[User impact] if declined: A user might go into the edge case with block screen. Then he/she cannot leave share via Bluetooth beside of kill the requesting app(Gallry).
[Testing completed]: Unit test is passed on try-server.
[Risk to taking this patch] (and alternatives if risky): Low risk.
[String changes made]: Non.
Attachment #8577957 - Flags: approval-gaia-v2.2?
Comment on attachment 8577957 [details] [review]
pull request 28887

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Since utility tray is able to display in full screen app in v2.0, Bluetooth app have to considerate the use case.
[User impact] if declined: A user might go into the edge case with block screen. Then he/she cannot leave share via Bluetooth beside of kill the requesting app(Gallery).
[Testing completed]: Unit test is passed on try-server.
[Risk to taking this patch] (and alternatives if risky): Low risk.
[String changes made]: None.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Since utility tray is able to display in full screen app in v2.0, Bluetooth app have to considerate the use case.
[User impact] if declined: A user might go into the edge case with block screen. Then he/she cannot leave share via Bluetooth beside of kill the requesting app(Gallery).
[Testing completed]: Unit test is passed on try-server.
[Risk to taking this patch] (and alternatives if risky): Low risk.
[String changes made]: None.
Attachment #8577957 - Flags: approval-gaia-v2.1?
Attachment #8577957 - Flags: approval-gaia-v2.0?

Updated

4 years ago
Attachment #8577957 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed in the latest Night Flame 3.0 build.  Setting verifyme so that this issue gets checked when uplifted to 2.2 branch.

Actual Results: The "Bluetooth is disabled" prompt is dismissed when bluetooth is turned on in another way.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150318055750
Gaia: b8051d370ddf4e5bd8e7d8a19fb9eeb5fd6ffb39
Gecko: 41a61514461e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
v2.2: https://github.com/mozilla-b2g/gaia/commit/57a208cfd4e6567ae892cdb609856d165b80c260
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S8 (20mar)

Updated

4 years ago
blocking-b2g: 2.2+ → 2.1+
Comment on attachment 8577957 [details] [review]
pull request 28887

too late for 2.0, but I am approving this for 2.1 given the low risk here.
Attachment #8577957 - Flags: approval-gaia-v2.1?
Attachment #8577957 - Flags: approval-gaia-v2.1+
Attachment #8577957 - Flags: approval-gaia-v2.0?
Attachment #8577957 - Flags: approval-gaia-v2.0-
v2.1: https://github.com/mozilla-b2g/gaia/commit/b8ae0df34362420fe4a9c90effa5247a1f5c844d
status-b2g-v2.0: affected → wontfix
status-b2g-v2.1: affected → fixed
status-b2g-v2.1S: --- → fixed
According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v2.2&2.1 and v2.1S.

Actual Results: Device will continue the share activity proceed to the Bluetooth selection screen (proceed to the Bluetooth selection screen).

See attachment: verified_v2.2.mp4.
Reproduce rate: 0/5

Device: Flame 2.1 build(Pass)
Build ID               20150329001204
Gaia Revision          6f39e4e876152de1dcdcc0e7656197f22f105e4b
Gaia Date              2015-03-25 11:16:16
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/275ad18f587b
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150329.035632
Firmware Date          Sun Mar 29 03:56:41 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 build(Pass)
Build ID               20150329002502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4b13c4254e2f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150329.035453
Firmware Date          Sun Mar 29 03:55:05 EDT 2015
Bootloader             L1TC000118D0

Device: 2.1S_512mb (Pass)
Build ID               20150329001204
Gaia Revision          fa9fb90a3eaad9feff807249a925926626287908
Gaia Date              2015-03-25 15:44:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/2c2f17155e13
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015
status-b2g-v2.1: fixed → verified
status-b2g-v2.1S: fixed → verified
status-b2g-v2.2: fixed → verified
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.