If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

All accounts are listed in Account Settings as "invalid account"

RESOLVED DUPLICATE of bug 1121798

Status

Thunderbird
Account Manager
--
critical
RESOLVED DUPLICATE of bug 1121798
3 years ago
3 years ago

People

(Reporter: gerv, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
STR:

* Open Account Settings
* See all my mail accounts listed in the left hand list as "Invalid account foo@bar.com", with no UI on the right

Expected: normal account management.

Thunderbird 36.0 (beta channel). This doesn't happen on stable, so I use the stable version every time I want to make some changes to my account settings. I first saw this a few weeks ago; I assumed it would be a short-lived bug. But it's still there.

What additional diagnostics can I provide? In the Error Console I see several instances of:

Timestamp: 11/03/15 15:19:28
Error: Error accessing account gerv@gerv.net: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://messenger/content/AccountManager.js :: at_build :: line 1551"  data: no]
Source File: chrome://messenger/content/AccountManager.js
Line: 1566

I get one of these per account, both IMAP mail, news, Local Folders and IRC.

Gerv

Comment 1

3 years ago
Can you paste a bit of code around the line 1566? It may be different what I see on trunk now.

Comment 2

3 years ago
Please also check if this is the same as bug 1121798.
(Reporter)

Comment 3

3 years ago
Yes, it is. (Why did that bug not come up in a related bugs search for "invalid account"?)

Gerv
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1121798
You need to log in before you can comment on or make changes to this bug.