Closed Bug 1142316 Opened 5 years ago Closed 2 years ago

[Text Selection][Email] Unable to select or copy the body of HTML email

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:-, feature-b2g:3.0?, b2g-v2.2 affected, b2g-master affected)

RESOLVED WONTFIX
blocking-b2g -
feature-b2g 3.0?
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: ychung, Unassigned)

References

()

Details

(Keywords: feature, foxfood, Whiteboard: [3.0-Daily-Testing], permafail)

Attachments

(2 files)

Description:
When the user long-presses on the text of an email subject, the selected word gets highlighted and the copy/paste utility bubble appears. However, the utility bubble does not appear when the user long-presses on the text in the body of the email.

Pre-requiste: Have a wi-fi network or cell data connected. Email app is set up with an account that has at least 1 email in the inbox. 

Repro Steps:
1) Update a Flame to 20150311010231.
2) Open Email app.
3) Select any email that contains text in the body.
4) Long press on any word.

Actual:
The selected word is NOT highlighted, and the text selection utility bubble does NOT appear. Carets appear at each bottom corner of the screen.

Expected:
The selected word is highlighted, carets appear at the each end of the word, and the text selection utility bubble appears.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150311010231
Gaia: 943c8b4039f59b08ba100390e164a076a20c892e
Gecko: fd8e079d6335
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 5/5
See attached: video clip, logcat
https://youtu.be/_S5y4MKFf98
This issue also reproduces on Flame 2.2.

Result: The user is unable to select or copy the text in the body of an email.

Device: Flame 2.2 (KK, 319mb, full flash)
BuildID: 20150311002522
Gaia: 3f032238a52f08e4c2f68a47ad065a96eb22d470
Gecko: 004fa1cb1dd4
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][COM=Text Selection]
Flags: needinfo?(ktucker)
Gerry, can you take a look at this please and weigh in the severity of this issue?
QA Whiteboard: [QAnalyst-Triage?][COM=Text Selection] → [QAnalyst-Triage+][COM=Text Selection]
Flags: needinfo?(ktucker) → needinfo?(gchang)
blocking-b2g: --- → 2.2?
Flags: needinfo?(gchang)
Morris, please help to check this is related to gecko or not.
Flags: needinfo?(mtseng)
The email body is consist of iframe. And this iframe has a css attribute - pointer-event:none. See following code [1]. Remove this attribute I could select text inside email body.

[1]: http://mxr.mozilla.org/gaia/source/apps/email/js/iframe_shims.js#329
Flags: needinfo?(mtseng)
Component: Selection → Gaia::E-Mail
Product: Core → Firefox OS
Based on comment 4, move to email category.
this is a sounds like a recent regression, so blocking for now.
blocking-b2g: 2.2? → 2.2+
It was my impression that this was a known limitation for text selection for email until we can overhaul HTML body display.  But James has the authoritative answer for this.  I am bumping back down to 2.2? for now.
blocking-b2g: 2.2+ → 2.2?
Flags: needinfo?(jrburke)
Please verify that you are testing with a plain text email -- that is the scope of text selection we are supporting for v2.2. The enhancement needed to support text selection in HTML email is tracked in bug 1102469. 

Marking as not blocking for now as plain text appears to be working for me. Please re-nominate if you are seeing this in plain text.
blocking-b2g: 2.2? → -
Flags: needinfo?(ychung)
Depends on: 1102469
(In reply to Dylan Oliver [:doliver] from comment #8)
> Please verify that you are testing with a plain text email -- that is the
> scope of text selection we are supporting for v2.2. The enhancement needed
> to support text selection in HTML email is tracked in bug 1102469. 
> 
> Marking as not blocking for now as plain text appears to be working for me.
> Please re-nominate if you are seeing this in plain text.

This issue does not reproduce with plain text emails on Flame Master and 2.2. The plain text in the body is selectable.

Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150317073344
Gaia: 738987bd80b0ddb4ccf853855388c2627e19dcc1
Gecko: 008b3f65a7e0
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150317002504
Gaia: d0e09d5e6367e558824f9cbf691da99cedf63037
Gecko: 793d61bb0bd4
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(ychung)
feature-b2g: --- → 3.0?
Flags: needinfo?(jrburke)
Keywords: feature
Summary: [Text Selection][Email] Unable to select or copy the body of the email → [Text Selection][Email] Unable to select or copy the body of HTML email
:doliver found the right bug that we are using to track the pieces we would like in place to enable HTML email body selection. The set of caveats for text selection support are listed in bug 1092440 comment 10, namely this HTML body selection and contacts copy needing copy/paste API support.
Duplicate of this bug: 1180579
Duplicate of this bug: 1186179
Attached video Aries_v2.5.3GP
This issue also reproduces on latest build of Aries kk v2.5.
Result: The user is unable to select or copy the text in the html body of an email.
See attchment:Aries_v2.5.3gp
Device: Aries KK 2.5(Affected)
Build ID               20150810003528
Gaia Revision          09dea2d5ff21cdb56da35fe4aa5bf4c90cf1da7f
Gaia Date              2015-08-09 17:11:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0e269a1f1beb
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150810.000017
Firmware Date          Mon Aug 10 00:00:24 UTC 2015
Bootloader             s1
QA Whiteboard: [QAnalyst-Triage+][COM=Text Selection] → [QAnalyst-Triage+][COM=Text Selection][MGSEI-Triage+]
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing],[2.5-aries-test-run-1]
Whiteboard: [3.0-Daily-Testing],[2.5-aries-test-run-1] → [3.0-Daily-Testing],[2.5-aries-test-run-1],[2.5-aries-test-run-2]
Whiteboard: [3.0-Daily-Testing],[2.5-aries-test-run-1],[2.5-aries-test-run-2] → [3.0-Daily-Testing], permafail
Duplicate of this bug: 1229557
I still have this problem on 2.6 with my Flame running OTA 20160113030248.
Keywords: foxfood
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.