Bug 1142326 (gilligansisland)

Tour: once embarked on the tour, cannot escape

RESOLVED WONTFIX

Status

Firefox OS
Gaia::First Time Experience
RESOLVED WONTFIX
3 years ago
4 months ago

People

(Reporter: dietrich, Assigned: fxosux)

Tracking

({papercut, polish})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Master + mozilla-central, all devices

STR:

1. After first-run, start the tour
2. Try to escape the tour

Repeatedly clicking the back button never ever gets you a "skip" button. The home button doesn't work.
Bug 1036697 is to make the tutorial a separate app, which would enable this - home would work as expected, holdhome would let you close the tutorial like any other app with the task manager. While the setup screens in FTE are more complicated (mostly for the user experience) to make non-blocking, the tutorial neednt be. 

Of course if the user taps 'home' before having gone through the tutorial, they may struggle to get back to the tutorial. Not sure if we would need to deal with that - maybe just an interstitial of some kind showing/telling how to return to an app. Or we address it explicitly on the first screen of the tutorial (or last screen of the FTU) with something explaining where to find this tutorial if you want to view it later. 

OTOH, maybe this distinction between the tour and the setup screens that precede it is bogus. If we make the FTE more like a contextual, guided first-use, game-style experience the goal posts move quite a bit
Thoughts Jacqueline?
Flags: needinfo?(jsavory)
I'm going to dupe this against bug 1036697 - which will cover this use case.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1036697
Reopening as this isn't a dup. This is a separate issue about not being able to quit the tour after being started not splitting FTE and Tour into separate things.

We agree that there should be some way to "escape" the tour though a solution needs to be designed. Assigning to ourselves to take a look.

Thanks for pinging the UX team via Jacqueline!
Status: RESOLVED → REOPENED
Flags: needinfo?(jsavory)
Resolution: DUPLICATE → ---
Assignee: nobody → firefoxos-ux-bugzilla
> We agree that there should be some way to "escape" the tour though a
> solution needs to be designed. Assigning to ourselves to take a look.

Ok thanks for the clarification. Splitting off the tour into its own app would mean it would behave like any other app, so the home button would take you to the homescreen, long-tap on home would let you close the tour at any time. However, that is just one solution. 

I was just looking at the tutorial specs this morning and commented on the note:"*Soft home button will be displayed if available. If tapped, the homepage will display and the tutorial will quit." 

We haven't implemented this currently and I think it would also satisfy this bug?
The other thing we could do here is put a skip button on the first step of the tour. Right now there's no back button so the next button is full width.
Note to myself mostly: All the logic for blocking the home button, preventing closing from task manager, determining if the FTU has already run etc. - all that stuff hangs on the 'close' lifecycle state of the FTU. When we see the finish screen before the tutorial, the FTU is essentially finished for all these purposes, but because the tutorial is a part of the FTU app, it postpones closing until the user has completed the tour. So yes, lets build in some affordance for bailing out of the tour, but I still think splitting it out into its own app is an important part of a final solution.
Should this bug be marked as dependent on that other one (splitting FTE and Tour)? When they get split, then we can address the design issue?
Flags: needinfo?(sfoster)
If bug 1036697 happens (and its rising back to the top of my list) then this bug may be redundant. If it doesnt happen in the short-term, this bug is a good stop-gap. So I'm not sure it makes sense for one to block the other. I've added the tour-as-app bug in the see-also field.
Flags: needinfo?(sfoster)
See Also: → bug 1036697

Comment 9

4 months ago
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.