Browser + Address Book Editor: actual view of Navigation Toolbar does not match with preference shown in Context menu

REOPENED
Unassigned

Status

SeaMonkey
UI Design
--
minor
REOPENED
3 years ago
3 years ago

People

(Reporter: Rainer Bielefeld, Unassigned)

Tracking

SeaMonkey 2.33 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

108.57 KB, application/force-download
Details
(Reporter)

Description

3 years ago
Created attachment 8576454 [details]
^Screenshot with comments

Steps how to reproduce with Entlish Seamonkey 2.33 Build 20150308222025 (Default Theme) on German WIN7 64bit:

0. Launch Browser:
1. Rightclick Navigation bar  ► Settings for this toolbar ► 
   Compare preference with actual view
   Expected: should show actual view of toolbar
   Actual: often shows something different
2. Modify preference (for example "Icons and Text" to  "Icons"
   Expected: view should change
   Actual: often view of toolbar does not change, also not when you 
           open a new Browser Window
3. Gamble a little around, you should be able to reproduce
   inconsistencies after a short while

a) I also observe difference between preference and view in newly 
   launched Browser.
b) In Composer I observed that switching between "Icons" and "Ions and 
   Text" works reliably, but after I have slected "Text only", I can't 
   switch back to view with icons, also 'close  ► reopen' Composer does 
   not help
c) Until now I did not observe this problem in Email Client
(Reporter)

Comment 1

3 years ago
d) I also observe the problem with "Seamonkey Modern" Theme
e) Aso a problem in Safe Mode
Status: NEW → UNCONFIRMED
Ever confirmed: false

Comment 2

3 years ago
Cannot reproduce with SeaMonkey Nightly 2.36a. Can you try the en-US version of 2.33?
(Reporter)

Comment 3

3 years ago
e) No problem in Chstomize-Dialog: "Show: ..."

(In reply to Philip Chee from comment #2)
> Can you try the en-US version of 2.33?

My SeaMonkey is en-US with German Language Pack

Comment 4

3 years ago
(In reply to Rainer Bielefeld from comment #3)
> My SeaMonkey is en-US with German Language Pack

In that case try disabling the de language pack
(Reporter)

Comment 5

3 years ago
f) same problem with disabled language packs

Comment 6

3 years ago
I have tried to reproduce it, but with my 2.33 Win7 64Bit, all works well. Tried a view times, but no troubles. All changes how it should.

Comment 7

3 years ago
(In reply to Rainer Bielefeld from comment #0)
> b) In Composer I observed that switching between "Icons" and "Ions and 
>    Text" works reliably, but after I have slected "Text only", I can't 
>    switch back to view with icons, also 'close  ► reopen' Composer does 
>    not help

In the "Composer" for editing web pages no toolbars or menubars can be customized here.  Perhaps the "Compose" window for editing emails was meant.  

WorksForMe on all windows as expected with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33.1 Build identifier: 20150321194901 and on Linux

Please reopen if a way to reproduce this error is found.
Severity: normal → minor
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

3 years ago
(In reply to :Hb from comment #7)
> In the "Composer" for editing web pages no toolbars
b): Indeed, seems I was a little distrait. My comment was concerning Address book 
    Editor.

A general hint of an  experienced QA tester: Comments like "all works well" or similar count nothing, you need to tell how exactly you tested so that we can find out what little difference between your test and mine making the difference.
(Reporter)

Comment 9

3 years ago
Here
<http://www.bielefeldundbuss.de//PRIVATRuM/SeaMonkey/Bug_1142395_Movie.mp4>
a short movie showing how I tested.
Summary: Browser + Composer: actual view of Navigation Toolbar does not match with preference shown in Context menu → Browser + Address Book Editor: actual view of Navigation Toolbar does not match with preference shown in Context menu

Comment 10

3 years ago
The target point of the right click is decisive.  In both the movie and attachment 8576454 [details] the context menu is invoked from the Menu Bar.  Its content from "Settings for this toolbar" is then compared with the current state of the Toolbar.  This will give distractive results of course.

Please invoke the context menu from each single the toolbar in question.

It gets more complicated because the settings from the Customize Toolbar dialog box seem to affect all bars.  Therefore it should be named as "Customize Toolbars" or similar.  Current wording is indeed not optimal.
(Reporter)

Comment 11

3 years ago
Yeah, it seems I did some heedlessness in my tests. 
Indeed, strictly following step by step instruction of my original report for browser and clicking on the Navigation bar, context menu worked fine for some tests I did. But now the "Customize Toolbar" initial view does not match reliably with the latest selection done in the context menu.

And due to Comment 10 also "Bug 1143109 - Context menu for Toolbar settings with wrong reference" might be a real bug, it's at least unclear what context menu or dialog is for what toolbar?

And it might be that order of using dialog and / or context menu for various toolbars has an influence, currently I do not understand all details of my tests.
The only thing really clear here seems to be "something wrong".
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.