Ask for www.claro.com, and return desktop contect instead of mobile content.

RESOLVED WORKSFORME

Status

Tech Evangelism
Mobile
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Norry.L.F(Leave from Mozilla), Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
Other
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.1S affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [mobile-compat-form], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Site: http://www.claro.com
Ask for www.claro.com, and return desktop contect instead of mobile content.

:: Steps To Reproduce

1.Launch browser
2.Go to www.claro.com
3.Select one area, such as Argentina

:: Expected Result

Step2&3: received mobile content, not desktop content

:: Actual Result

Step2&3: received desktop content.

:: Additional Information

Software Version: 2.0M
Device Information: Woodduck 2.0M
Reporter's User Agent: Mozilla/5.0 (Windows NT 6.1; rv:36.0) Gecko/20100101 Firefox/36.0
(Reporter)

Comment 1

3 years ago
Created attachment 8576466 [details]
Video.mp4

Attach: Video.mp4&logcat1.txt
Found at: 2:55am.
Rate: 100%

Woodduck 2.0M
Build ID               20150312050313
Gaia Revision          0e0a84a03f7253d1544e6e8ecbadac9d0f325a64
Gaia Date              2015-03-11 05:43:46
Gecko Revision         4dd211ecc070564dea1af8fc5125cfc748f24a23
Gecko Version          32.0
Device Name            jrdhz72_w_ff
Firmware(Release)      4.4.2
Firmware(Incremental)  1426107908
Firmware Date          Thu Mar 12 05:05:26 CST 2015
------------------
Flame 2.0:
Build ID               20150311000206
Gaia Revision          896803174633fc6acd3fd105f81c349b8e9b9633
Gaia Date              2015-03-10 06:32:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/78df3174fb10
Gecko Version          32.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150311.034723
Firmware Date          Wed Mar 11 03:47:34 EDT 2015
Bootloader             L1TC000118D0
------------------
Flame 2.1:
Build ID               20150311001232
Gaia Revision          04623ffbdc1e9c53de5a9a522bc9d8d93020a56d
Gaia Date              2015-03-10 18:12:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/421ee858039c
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150311.040426
Firmware Date          Wed Mar 11 04:04:37 EDT 2015
Bootloader             L1TC000118D0
------------------
Flame 2.1s_256mb:
Build ID               20150311001238
Gaia Revision          a66813e488374b8ba9d8aa187b00f84ad5bd1bb9
Gaia Date              2015-03-10 06:56:29
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/ee8a2d1b86a5
Gecko Version          34.0
Device Name            scx15_sp7715ga
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150311.040335
Firmware Date          Wed Mar 11 04:03:48 EDT 2015
------------------
Flame 2.2:
Build ID               20150311002522
Gaia Revision          3f032238a52f08e4c2f68a47ad065a96eb22d470
Gaia Date              2015-03-11 00:28:07
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/004fa1cb1dd4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150311.040546
Firmware Date          Wed Mar 11 04:05:57 EDT 2015
Bootloader             L1TC000118D0
----------------
N5_2.2
Build ID               20150311002522
Gaia Revision          3f032238a52f08e4c2f68a47ad065a96eb22d470
Gaia Date              2015-03-11 00:28:07
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/004fa1cb1dd4
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150311.040337
Firmware Date          Wed Mar 11 04:03:52 EDT 2015
Bootloader             HHZ12d
----------------
Flame 3.0:
Build ID               20150311010231
Gaia Revision          943c8b4039f59b08ba100390e164a076a20c892e
Gaia Date              2015-03-10 20:35:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/fd8e079d6335
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150311.043838
Firmware Date          Wed Mar 11 04:38:50 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Comment 2

3 years ago
Created attachment 8576468 [details]
logcat1.txt
(Reporter)

Comment 3

3 years ago
Note: if you are in step 3 to select some other area, such as Brasil and tap enter button, page will show as mobile content.
Blocks: 1054172, 1080481
Status: UNCONFIRMED → NEW
status-b2g-v2.0: --- → affected
status-b2g-v2.0M: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.1S: --- → affected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Ever confirmed: true
The site's content is currently in a somewhat odd mixedtate - some pages are well adapted to mobile, some aren't. Entering claro.com first takes me to a country selector which is not mobile. On Firefox OS we then get a region-specific page which *is* mobile-adapted, but clicking through to products and sub-pages we find desktop content again. On Android we seem to get more pages that are mobile-adapted..
Will mark WFM because the country-specific pages seem responsively designed. The main landing/select country page still isn't, but it's usable.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.