[RTL][Settings]The date is shown as year, month, day from right to left at Date & Time view.

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: arthurcc)

Tracking

({late-l10n})

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(5 attachments)

Posted image date.png
[1.Description]:
[RTL][v2.2 & v3.0[Settings]The date is shown as year, month, day from right to left at Date & Time view but it is shown correctly as day, month, year from right to left at date value selector.
See attachment:date.png

[2.Testing Steps]: 
1. Set system language as Arabic.
2. Launch Settings -> Date & Time.
3. Observe the date.

[3.Expected Result]: 
3. The date should be shown as day, month, year from right to left.

[4.Actual Result]: 
3. The date is shown as year, month, day from right to left.

[5.Reproduction build]: 
Flame 2.2 build: affected
Build ID               20150311002522
Gaia Revision          3f032238a52f08e4c2f68a47ad065a96eb22d470
Gaia Date              2015-03-11 00:28:07
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/004fa1cb1dd4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150311.040546
Firmware Date          Wed Mar 11 04:05:57 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build: affected
Build ID               20150311010231
Gaia Revision          943c8b4039f59b08ba100390e164a076a20c892e
Gaia Date              2015-03-10 20:35:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/fd8e079d6335
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150311.043838
Firmware Date          Wed Mar 11 04:38:50 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
15717
QA Whiteboard: [rtl-impact]
Inconsistency with RTL behavior so putting as P2 and nominating.
blocking-b2g: --- → 2.2?
Priority: -- → P2
Assignee: nobody → arthur.chen
Status: NEW → ASSIGNED
Triage: blocking
blocking-b2g: 2.2? → 2.2+
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15717/
Flags: in-moztrap+
Comment on attachment 8579143 [details] [review]
[gaia] crh0716:1142448 > mozilla-b2g:master

The patch uses the format string that the date selector is using. I also removed the redundant update to the span because the DateTime module already takes care of it. EJ, could you help review the patch? Thanks.
Attachment #8579143 - Flags: review?(ejchen)
Comment on attachment 8579143 [details] [review]
[gaia] crh0716:1142448 > mozilla-b2g:master

Based on our offline discussion, let me take off the review flag first and see how to continue this work. (We may need some UX input for this case to decide which way to go).
Attachment #8579143 - Flags: review?(ejchen)
The inconsistency comes from date formats used in the date selector and settings app. In the language file the date format for ar is "%d/%m/%Y"[1] and which is completely numeric, so in settings app a date string is displayed in LTR. That's why we see "12/03/2015" currently.

On the other hand, the date selector used text for displaying the month, so it is displayed as "2015 March 12". The only way to make them consistent would be also displaying month using text. Jenny, any concerns if we make this change?

[1]: https://hg.mozilla.org/gaia-l10n/ar/file/f0d48551f366/shared/date/date.properties#l198
Flags: needinfo?(jelee)
Flags: needinfo?(jelee)
Hi Arthur,

I'm fine with changing the value to text-based, but as spec attachment 8581424 [details] specifies, time format change only applies to non-text based content. If we make this change as you suggested in comment 7, can we make sure this part is covered ? Thanks!
Sure, the text-based value will not be affected by the date format setting.
Comment on attachment 8579143 [details] [review]
[gaia] crh0716:1142448 > mozilla-b2g:master

EJ, I've added a new string "shortDateFormat" as what we've discussed. Could you help check the patch? Thanks.
Attachment #8579143 - Flags: review?(ejchen)
Comment on attachment 8579143 [details] [review]
[gaia] crh0716:1142448 > mozilla-b2g:master

r+ thanks Arthur, remember to add late-l10n flag for this patch.
Attachment #8579143 - Flags: review?(ejchen) → review+
http://docs.taskcluster.net/tools/task-graph-inspector/#ow0LjYL4T7qXAM-K-OSbqQ

The pull request failed to pass integration tests. It could not be landed, please try again.
http://docs.taskcluster.net/tools/task-graph-inspector/#TRKKL8uaQhuEDq8xd7qkVA

The pull request failed to pass integration tests. It could not be landed, please try again.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8579143 [details] [review]
[gaia] crh0716:1142448 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: The date formats are inconsistent between the settings panel and the date selector.
[Testing completed]: Testing on the device.
[Risk to taking this patch] (and alternatives if risky): Low as it simply changes the date format.
[String changes made]: Yes, `shortDateFormat` is added.
Attachment #8579143 - Flags: approval-gaia-v2.2?
Attachment #8579143 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Hi Josh,
This issue is verified fail on latest build of Flame 2.2 and Flame 3.0, the date is shown as month, day, year from right to left in "Date&Time" view. According to comment 0, the expected Result is the date should be shown as day, month, year from right to left.
Could you help with this bug?
Thank you.

See attachment:Verify1_Flame2.2&3.0_Fail.png
Reproducing rate:10/10

Flame 2.2 build (Affected):
Build ID               20150327162502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b358619def45
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.194944
Firmware Date          Fri Mar 27 19:49:53 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
Build ID               20150327160203
Gaia Revision          9cc496cecc37d7a29f9279827cdf6e4891211f67
Gaia Date              2015-03-27 13:55:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/44e454b5e93b
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.192632
Firmware Date          Fri Mar 27 19:26:42 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(jocheng)
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Hi Delphine,
Could you help to confirm the correct date-time display per comment 18 from Lancy?
Thanks!
Flags: needinfo?(jocheng) → needinfo?(lebedel.delphine)
Hey Josh, Lancy is correct. As per UX specs, "Time display may vary depending on locale and user preference. Default display is in military format; dates appear in the following order: Year > Month > Date > Time." 
So comment 18 is correct, from right to left, it should be read as date, month, year
If the patch did not fix this, please file a new bug and block on it. Also let's make sure if the patch submitted in the new bug has late-l10n, that that keyword is used. thanks
Flags: needinfo?(lebedel.delphine)
It seems the newly added string has not been localized yet[1]. Once it is localized, the order should be the same as the sepc. 

[1]: http://hg.mozilla.org/gaia-l10n/ar/file/09ff85e33808/apps/settings/settings.properties#l672
Flagging Rami so he can localize this and we can check everything is OK after that. Thanks!
Flags: needinfo?(rami223)
Whiteboard: MGSEI-RTL-3F
Text is localized
Flags: needinfo?(rami223)
This issue has been verified passed on latest build of Flame 2.2/3.0 with the same steps in comment 0. The date is shown as day, month, year from right to left.
See attachment:date_in_date&time_settings.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150414162502
Gaia Revision          16e948bfaaa15dbc0200135d52f16257b4eab193
Gaia Date              2015-04-14 21:08:25
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0eec28e78eb1
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.201515
Firmware Date          Tue Apr 14 20:15:24 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (pass)
Build ID               20150414160204
Gaia Revision          8e28588496f82f8f069c171c65842d622b9d8d7d
Gaia Date              2015-04-14 18:43:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/de27ac2ab94f
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.194002
Firmware Date          Tue Apr 14 19:40:12 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
See Also: → 1153765
QA Whiteboard: [rtl-impact][MGSEI-Triage+] → [rtl-impact][MGSEI-Triage+][MGSEI-RTL-3F]
Whiteboard: MGSEI-RTL-3F
You need to log in before you can comment on or make changes to this bug.