Spell check problem still present in version TH 31.xx

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
RESOLVED WORKSFORME
3 years ago
6 months ago

People

(Reporter: toni, Unassigned)

Tracking

31 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.89 Safari/537.36

Steps to reproduce:

tried with TH 31.xx and earlier versions until 15.xx
Any language (EN_US, IT and so on)
1) Open a new email message.
2) Type 'In the middle of the day'
3) Backspace until you only have 'In the mi'
4) Then retype the rest so you end up with 'In the middle of the day' again.



Actual results:

I end up with the red wavy line under the 'ddle' in the word middle.


Expected results:

Nothing to correct !!!!
I use Italian and I have continuously this issue !
No matter the language you are using the problem is still present
(Reporter)

Updated

3 years ago
Severity: normal → major
Priority: -- → P5
(Reporter)

Comment 1

3 years ago
Created attachment 8576605 [details]
2015-03-12_11-42-36-156.png
(Reporter)

Updated

3 years ago
Component: Untriaged → Message Compose Window

Comment 2

3 years ago
Thanks for reporting this. Annoying, but on our scale of severity this is characterized as "normal" breakage [1], for example, "major" would be if all spellcheck functionality is broken.  

[1] https://bugzilla.mozilla.org/page.cgi?id=fields.html#bug_severity
Severity: major → normal
Priority: P5 → --
Can't reproduce in TB 36 beta 1. I've seen words half underlined in the past, but I can't reproduce it following your steps.

Please download an "Early Bird" or Beta version and try again:
https://www.mozilla.org/en-US/thunderbird/channel/
(Reporter)

Comment 4

3 years ago
In my WIN OS it happens always ! It seems on Linux it doesn't apper.
Ok it is not only annoying ... is messy according to me ! And I can't understand where it comes from !
(Reporter)

Comment 5

3 years ago
In my WIN OS it happens always ! It seems on Linux it doesn't apper.
Ok it is not only annoying ... is messy according to me ! And I can't understand where it comes from !
Tried on 24 and 31 final versions. Found from version definitive 16 !
Which OS do you use ?
Windows 7.

The spell check is actually not part of TB, it's part of the underlying Mozilla Gecko code. Recently there has been a lot of work invested into fixing the last issue known to me, bug 1100966.

If you can deliver a *reproducible* case on TB 36 or onwards, we can look into it.
(Reporter)

Comment 7

3 years ago
Let me try your version as you said TB 36 Beta 1
I tried your test case in TB 24.8.1, TB 31.5, TB 36, TB 37 and TB 38 on Windows 7.
I could never reproduce it.
If you don't supply a reproducible case, I will close this bug.
(Reporter)

Comment 9

3 years ago
Dear Jorg,
it seems you have the same configuration I have.
I suppose you have Office too. I have 2007 Office.
I experienced the error, I described above, with all PC with XP and Win7 no matter of the version I use.
You say that the steps suggested above doesn't reproduce the mistake in your computer. Therefore I can't understand what's happen: why my WIN7's show the mistake and your's not ?

Here the video of the error you can't reproduce BUT for me is routine !!
If you close the bug it will remain unresolved forever 
http://www.4shared.com/zip/_5ncmxTHce/Spellcheck_Error_3.html
Flags: needinfo?(tonicuea)
Created attachment 8578563 [details]
Video showing the the problem can't be reproduced

I don't want to download whatever you posted on http://www.4shared.com.
Please take a look at the attached video.
I can't reproduce the bug, sorry. In the video I was using the current version 31.5.0.

I suggest you run TB will all add-ons disabled and see what that does. I saw in the PNG you attached, that you are using "Quicktext".

As for:
> If you close the bug it will remain unresolved forever 

It will be unresolved forever in any case, because we cannot reproduce it. How do you want us to fix a bug we don't see?
Flags: needinfo?(tonicuea)
(Reporter)

Comment 11

3 years ago
Created attachment 8578602 [details]
2015-03-17_13-21-01-441.png
(Reporter)

Comment 12

3 years ago
I tried with all components disable and , for sure, also the spell checker doesn't work at all ! 
Then I disable everything except the dictionary and the spellcecker represent the same error. The only difference between my 3 computer with OS WIN7 and OS WinXP and yours could be office. 
I am running MS Office 2007. As regard the rest I can't understand why can't you reproduce. 
I hope somebody else has the same issue !
I put the new screenshot
I ran TB in "safe mode" without add-ons. Since I have the US-English version installed, the US English dictionary is still available and the spellcheck *does* work. Your problem is not reproducible.

So I suggest this:
Install the US-English version, run it without add-ons and see whether you can still cause the problem.

In any case, let me know which language version you have installed and which additional dictionaries you are using.

As for the attachment you mentioned in comment #9: If it's still relevant, attach it to the bug in a compressed form (zip, 7zip) or upload it to a "neutral" file transfer site, like www.wetransfer.com. Then post the download link here.
I tried with the Italian version of TB 31.5.0 and an English GB dictionary.
I cannot reproduce your problem.
(Reporter)

Comment 15

3 years ago
Already done. Therefore all my WIN7 and XP show the problems (with Italian and English version even in safe mode). Yours not ! I can't understand what's going on ! I try on a completely different machine today ! It is WIN7 original US
Do you use Chrome ? Adobe IX etc ?
Which office do you use ?
Win 7, original US version, Chrome is installed (need to use it when debugging Firefox). OpenOffice, no Adobe.

I've tried five different machines (1x 64bit Win7, 2x 32bit Win7, 1x 32bit Vista, 1x 32bit XP).
I've tried various versions of TB from 24 to 38, 31 also in Italian.
I cannot reproduce the problem you describe: Type a line, backspace into a word at the beginning, complete the word again, newly re-typed part of the word is marked as spelling mistake.
Maybe your description is incomplete.

I believe that I have seen parts of words marked as spelling mistakes at some stage in the past, but I can't remember when and what the circumstances were.
(Reporter)

Comment 17

3 years ago
Maybe the key is open office ???
Have you got chance to try TH on a computer with MSOffice, Win7 and Chrome installed ?
I check for a computer without MSoffice but it is not easy at all !
Maybe the incompatibility key is here ! Isn't it ?
(Reporter)

Comment 18

3 years ago
No I tried in a laptop with WIN7 For US and without office. The error on spell check appears as usual following the described steps. I tried US version 24.6-31.5-36b ... all of them !!!
Dear Jorg we are one to one ... should somebody else be able to replicate this error ?


1) Open a new email message.
2) Type 'In the middle of the day'
3) Backspace until you only have 'In the mi'
4) Then retype the rest so you end up with 'In the middle of the day' again.
(Reporter)

Comment 19

3 years ago
No I tried in a laptop with WIN7 For US and without office. The error on spell check appears as usual following the described steps. I tried US version 24.6-31.5-36b ... all of them !!!
Dear Jorg we are one to one ... should somebody else be able to replicate this error ?


1) Open a new email message.
2) Type 'In the middle of the day'
3) Backspace until you only have 'In the mi'
4) Then retype the rest so you end up with 'In the middle of the day' again.
(Reporter)

Comment 20

3 years ago
No solution at all !
We can't reproduce your problem. Try in TB38 beta or when the official TB38 is released.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
In bug 1384193 someone claimed to be able to reproduce the problem by setting the default composition font to Arial. The reporter there also pointed out that are extra tags fracturing a word, so:
<font face="Arial">Yo<font face="Arial">ur check arrived today.

Toni, have you been able to solve the problem or figure out what was causing it?
Flags: needinfo?(tonicuea)
(Reporter)

Comment 23

6 months ago
The issue is still present even in new TH versions !
Flags: needinfo?(tonicuea)
Yes, but a developer needs to reproduce it. So far nobody has been able to tell us which configuration exactly makes it fail.

As I said, someone in bug 1384193 said that it had to do with font settings, so perhaps you can see what composition font you have set and try "Variable Width" instead.
(Reporter)

Comment 25

6 months ago
already tried, it doesn't work
You need to log in before you can comment on or make changes to this bug.