MailNews destroys newsgroup messages locally

VERIFIED WORKSFORME

Status

MailNews Core
Database
--
blocker
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: mail_john, Assigned: Bienvenu)

Tracking

({dataloss, regression})

Trunk
x86
Windows ME
dataloss, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
WindowsME, build 2001120808

When moving between newsgroups, headers/messages are destroyed! This destroys
data and was previously working correctly.

Reproducable: Always

1. Open Mailnews
2. Select a newsgroup with headers/new messages/old messages (ideally with "view
all messages" selected, though this is not necessary - just shows the problem
better).
3. select a second newsgroup
4. Select the first newsgroup again

Results: About 50 percent of the messages will be gone (old or unread). Repeat
steps 2-4 again and it happens again, until all messages are gone.

Expected: All news messages should remain, they should not be deleted until
times out by standard "news & diskspace" settings

Updated

17 years ago
Keywords: dataloss, regression
(Assignee)

Comment 1

17 years ago
works fine for me - I can't think of anything that would make newsgroup messages
disappear. Unless, perhaps, you got bit by that horrible prefs bug that screwed
up everyone's preferences, and your offline purging preferences got messed up.
You can look in your prefs.js and see if the purging prefs got written out with
""'s around the numbers, in which case you should remove the quotes. 
(Reporter)

Comment 2

17 years ago
I am having lots of prefs issues at the moment, and I was involved in the
mentioned prefs bug (was testing for it), but I am also having issues with
completely new user prefs. I am waiting for the prefs fix to go in (hopefully
with today's build) and then I will test again.

It is possible this could be related as I am unable to change or stick prefs for
newsgroup deletion.

I have tried removing all speech marks around newsgroup deletion as suggested,
but this has made no difference. Can you be more specific as to what lines I
need to change?

(Reporter)

Comment 3

17 years ago
I've also tried reverting to build 2001120108 and fixing the prefs file, but the
problem still occurrs. It could be an older problem as I've been seeing weird
news numbers, ie News says there's 50 new messages, but when I click into that
group there might only be 35.

(Reporter)

Comment 4

17 years ago
I have reverted to build 2001120108, deleted all the newsgroups and news server
accounts, re-created them and they appear to be okay now. I will test again with
tomorrows new build which (should) have all the prefs fixes that were not
checked in yesterday.

(Reporter)

Comment 5

17 years ago
I think you can close this. I think this was caused by the scrambling of my
prefs file by a recent bug, combined with me not understanding some of the mail
deletion options correctly.
(Assignee)

Comment 6

17 years ago
wfm, based on report's comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
verified, thanks for reporting back, john.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.