Closed Bug 1142558 Opened 5 years ago Closed 2 years ago

Intermittent failing test, TEST-UNEXPECTED-FAIL | /builds/slave/test/gaia/apps/communications/contacts/test/marionette/ice_test.js | Contacts > ICE contacts ICE settings Check ICE settings transition

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
macOS
defect
Not set

Tracking

(b2g-master affected)

RESOLVED WONTFIX
2.2 S9 (3apr)
Tracking Status
b2g-master --- affected

People

(Reporter: apastor, Assigned: hola)

References

Details

(Keywords: intermittent-failure, leave-open)

Attachments

(1 file)

1) Contacts > ICE contacts ICE settings Check ICE settings transition:
11:35:30     INFO -    Error: timeout exceeded!
11:35:30     INFO -        at Object.Client.waitForSync (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:693:16)
11:35:30     INFO -        at Object.Client.waitFor (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:661:60)
11:35:30     INFO -        at Object.MarionetteHelper.waitForElement (/builds/slave/test/gaia/node_modules/marionette-helper/index.js:142:12)
11:35:30     INFO -        at clickBackArrow (/builds/slave/test/gaia/apps/communications/contacts/test/marionette/ice_test.js:69:23)
11:35:30     INFO -        at Context.<anonymous> (/builds/slave/test/gaia/apps/communications/contacts/test/marionette/ice_test.js:159:7)
11:35:30     INFO -        at callFn (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:223:21)
11:35:30     INFO -        at Test.Runnable.run (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:216:7)
11:35:30     INFO -        at Runner.runTest (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:373:10)
11:35:30     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runner.js:451:12
11:35:30     INFO -        at next (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:298:14)
11:35:30     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runner.js:308:7
11:35:30     INFO -        at next (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:246:23)
11:35:30     INFO -        at Object._onImmediate (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:275:5)
11:35:30     INFO -        at processImmediate [as _immediateCallback] (timers.js:330:15)
Assignee: nobody → hola
I think the problems with this test suite have to do with the fact that the ICE Contacts a re set through the UI and not through the data layer. We need to change the way ICE Contacts are set by creating a method that updates the datastore of ICE Contacts directly, instead of doing it through the UI. 

Assigning it to Adrian
Flags: needinfo?(francisco)
Note that the test is only failing in 2.2 branch
Comment on attachment 8579223 [details] [review]
[gaia] ADLR-es:intermittent-ice > mozilla-b2g:master

The error was because the code to close ICE settings was being used to close the contact list when picking an ICE contact. I fixed that, used contacts_data.js to avoid errors when creating contacts and fixed some code duplication.
Attachment #8579223 - Flags: review?(jmcf)
Comment on attachment 8579223 [details] [review]
[gaia] ADLR-es:intermittent-ice > mozilla-b2g:master

thanks Adrian,

please check the comments on GH. Once you have the tests passing consider the possibility of asking for an approval as those tests were failing on 2.2
Attachment #8579223 - Flags: review?(jmcf) → review+
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S9 (3apr)
Gaia-try is looking good, but unfortunately we're having trouble on b2g-inbound. We are currently transitioning b-i to use the same runner as gaia-try (currently using TC). It is a bit painful right now having two different systems, but we hope to fix this soon. Maybe see if the below logs are helpful at all.

Revert: https://github.com/mozilla-b2g/gaia/commit/d4f10cd33bb222b38e32c16d86ae98bfe3bbbbcb

Log: https://treeherder.mozilla.org/logviewer.html#?job_id=1570995&repo=b2g-inbound
Status: RESOLVED → REOPENED
Flags: needinfo?(hola)
Resolution: FIXED → ---
The error is from a different file than the one I edited in this patch. Also, I haven't been able to reproduce it in v2.2, with or without my patch. Maybe this is another intermittent test that should be fixed in a new bug, because I don't think it is related to this patch. If possible, running tests again might give us some clues.

Thanks.
Flags: needinfo?(hola) → needinfo?(kgrandon)
Well we can fix it in a new bug, but the problem IIRC is that this patch made it more intermittent on b-i? This may no longer be an issue now that we're running TC everywhere. Now that things are more stable it may be worth submitting a new pull request with the patch again to see where we stand.
Flags: needinfo?(kgrandon)
Closing all intermittent test failures for Firefox OS (since we're not focusing on it anymore).

Please reopen if my search included your bug by mistake.
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 5 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.