[RTL] [Lockscreen] The carrier name overlaps the SIM slot text when recieiving a call on the lockscreen

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Dialer
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: JMercado, Assigned: steveck)

Tracking

(Blocks: 1 bug)

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][planned-sprint c=1])

Attachments

(4 attachments)

Created attachment 8576762 [details]
lockscreen.png

Description:
When the user recieves a call on the lockscreen, the carrier and the SIM slot information overlap.  This does not occur when the phone is not locked.

Prerequisites:
1) The phone is set to Arabic under Settings > Languages.

Repro Steps:
1) Update a Flame to 20150311110236
2) Lock the phone
3) From another device, place a call to the device in step 2
4) Carrier and SIM Slot information is displayed above the current time


Actual:
The carrier name and SIM slot information overlap each other.

Expected:
The text does not overlap.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150311110236
Gaia: 2b87ee8e7e2ec30a9851b6b59a899006a98767ab
Gecko: bc6aeea72290
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 10/10
See attached: screenshot
This issue also occurs on Flame 2.2.

Actual Results: SIM slot information and carrier name overlap.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150311002522
Gaia: 3f032238a52f08e4c2f68a47ad065a96eb22d470
Gecko: 004fa1cb1dd4
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

This issue does not occur on Flame 2.1 because the string had not yet been translated.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150311001232
Gaia: 04623ffbdc1e9c53de5a9a522bc9d8d93020a56d
Gecko: 421ee858039c
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [3.0-Daily-Testing]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+][rtl-impact]
Component: ar / Arabic → Gaia::System::Lockscreen
Flags: needinfo?(ktucker)
Product: Mozilla Localizations → Firefox OS
OS: Linux → Gonk (Firefox OS)
Hardware: x86 → ARM
Summary: [l10n][Arabic]The carrier name overlaps the SIM slot text when recieiving a call on the lockscreen → [RTL] [Lockscreen] The carrier name overlaps the SIM slot text when recieiving a call on the lockscreen
RTL triage: P2 - unsure if this should block, so nominating for triage to decide.
blocking-b2g: --- → 2.2?
Priority: -- → P2

Updated

3 years ago
Component: Gaia::System::Lockscreen → Gaia::Dialer
triage: major issue on new feature
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → dsherk
Target Milestone: --- → 2.2 S8 (20mar)
Duplicate of this bug: 1142923
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][planned-sprint c=?]
Target Milestone: 2.2 S8 (20mar) → 2.2 S9 (3apr)
Whiteboard: [3.0-Daily-Testing][planned-sprint c=?] → [3.0-Daily-Testing][planned-sprint c=1]
Steve, could you take this one? It should be fairly trivial.
Flags: needinfo?(schung)
(Assignee)

Comment 6

3 years ago
(In reply to Doug Sherk (:drs) (use needinfo?) from comment #5)
> Steve, could you take this one? It should be fairly trivial.

Sure, I'll take a look tomorrow
Assignee: drs → schung
Flags: needinfo?(schung)
Created attachment 8584339 [details] [review]
[gaia] steveck-chung:callscreen-sim-id > mozilla-b2g:master
(Assignee)

Comment 8

3 years ago
Comment on attachment 8584339 [details] [review]
[gaia] steveck-chung:callscreen-sim-id > mozilla-b2g:master

Hi Doug, the root cause is we still set fixed width in callscreen for sim id field, and it's an issue apparently if id will be translated into longer string. So I sync with system lockscreen that set the margin in this patch.
Attachment #8584339 - Flags: review?(drs)
Comment on attachment 8584339 [details] [review]
[gaia] steveck-chung:callscreen-sim-id > mozilla-b2g:master

Looks good. Thanks for taking this.
Attachment #8584339 - Flags: review?(drs) → review+
needinfo for uplift request.
Flags: needinfo?(schung)
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

3 years ago
Comment on attachment 8584339 [details] [review]
[gaia] steveck-chung:callscreen-sim-id > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Original behavior
[User impact] if declined: sim information misaligned in certain language
[Testing completed]: N/A (CSS change only)
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: N/A
Flags: needinfo?(schung)
Attachment #8584339 - Flags: approval-gaia-v2.2?(bbajaj)
(Assignee)

Updated

3 years ago
status-b2g-master: affected → fixed

Comment 13

3 years ago
Created attachment 8585311 [details]
incoming_call_at_lockscreen.png

This issue has been verified successfully on latest build of Flame 3.0 with the same steps in comment 0. The text does not overlap.
See attachment:incoming_call_at_lockscreen.png
Rate:0/5

Device: Flame 3.0 (pass)
Build ID               20150329010203
Gaia Revision          67ad91f3f660b1f16b354ee4c5159ddc5a74d149
Gaia Date              2015-03-28 10:02:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/385840329d91
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150329.042104
Firmware Date          Sun Mar 29 04:21:16 EDT 2015
Bootloader             L1TC000118D0

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
status-b2g-master: fixed → verified

Updated

3 years ago
Attachment #8584339 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Created attachment 8587123 [details]
Verify2_Flame2.2_Pass.png

This issue has been verified pass on latest build of Flame 2.2 with the same steps in comment 0. The text does not overlap.
See attachment:Verify2_Flame2.2_Pass.png
Reproducing Rate:0/10

Flame 2.2 build (Unaffected):
Build ID               20150401002624
Gaia Revision          8b3086ad3963f1707e2bee9094baccafffe161c4
Gaia Date              2015-03-31 21:48:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20b67213a047
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.042225
Firmware Date          Wed Apr  1 04:22:36 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.