Tape.tv videos are not playing in Shumway

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
4 years ago
3 years ago

People

(Reporter: karana, Unassigned)

Tracking

33 Branch
x86_64
Windows 7

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20150312030248

Steps to reproduce:

I opened http://www.tape.tv/taylor-swift/videos/shake-it-off in my Firefox Nightly with Shumway 0.10.266.


Actual results:

The loading circle never finished spinning, no video was played.
No obvious error in the console:

Load Shared Dependencies: 10.36ms
Load GFX Dependencies: 2.85ms
TypeError: asm.js type error: Disabled by debugger
Load Shared Dependencies: 10.37ms
Load AVM2 Dependencies: 213.97ms
Load SWF Parser: 0.50ms
Load Flash TS Dependencies: 12.75ms
Load AVM1 Dependencies: 12.15ms
Load Player Dependencies: 253.82ms
url=http://www.tape.tv/tapePlayer.swf;params=({})
viewerWrapper.js (line 54)
Compiler settings: {"appCompiler":true,"sysCompiler":false,"verifier":true}
Parsing http://www.tape.tv/tapePlayer.swf...
Execute builtin.abc: 36.27ms
Session #1: loading http://www.tape.tv/tapePlayer.swf
mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create
	

this.__proto__ = E.prototype;

	
shumway.player.js (line 11015, col 10)
<System>
Session #1: loaded 124052/124052
ShumwayCom.jsm (line 201)
SWF load time: 0.0120sec
ShumwayCom.jsm (line 201)
Session #1: closed



Expected results:

 the music video should have started to play
(Reporter)

Updated

4 years ago
Component: Untriaged → Shumway
Blocks: 1142562
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.