[Messages][RTL] Images for RTL contacts are misaligned in Participants panel

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: azasypkin, Assigned: steveck)

Tracking

({regression})

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

Posted image issue.png
STR:

* Open Messages app;
* Open group MMS thread with RTL contacts that have images;
* Tap on thread header to open Participants panel;
* Observe contact list.

Expected result: all contact images are left(right)most aligned in RTL(LTR).

Actual result: contact images for RTL contacts are misaligned (see attached screenshot).

Looks like it's caused by patch for bug 1130305.
Hey Steve,

Could you please look into this?

Thanks!
Flags: needinfo?(schung)
blocking-b2g: --- → 2.2?
Priority: -- → P2
blocking-b2g: 2.2? → 2.2+
Assignee

Comment 2

4 years ago
(In reply to Oleg Zasypkin [:azasypkin] from comment #1)
> Hey Steve,
> 
> Could you please look into this?
> 
> Thanks!

It seems a conflict with negtive margin with float issue. Removing the negtive margin could fix this issue.
Flags: needinfo?(schung)
Assignee

Updated

4 years ago
Assignee: nobody → schung
Assignee

Comment 4

4 years ago
Comment on attachment 8577856 [details] [review]
[gaia] steveck-chung:message-RTL > mozilla-b2g:master

Hi Julien, it's a regression from bug 1130305 that we're attempting to address the Arabic text bottom cut issue. The original idea is to extend the line-height with negtive margin-top to keep the name text to original position. But the negtive margin-top with float element seems leading some unexpected result and I'm not ure why it's related to direcction. Anyway we can replacing with padding-top adjustment instead, but this means the name title layout overrides lots of original list layout. Hi Julien, maybe we can land this patch for 2.2 and create another one that modify the list.css instead of in message app, wdyt?
Attachment #8577856 - Flags: review?(felash)
Comment on attachment 8577856 [details] [review]
[gaia] steveck-chung:message-RTL > mozilla-b2g:master

r=me but I'd rather see the line-height change in lists.css, in master.

Can you file a separate bug and add the bug number in the comment in sms.css so that we can track this correctly?
Attachment #8577856 - Flags: review?(felash) → review+
Assignee

Comment 6

4 years ago
Thanks! I filed Bug 1144588 for moving this fix into shared list.
In master: https://github.com/mozilla-b2g/gaia/commit/cd02a2e48f454c7b51257d2ce0f13add3c23c851
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 7

4 years ago
Comment on attachment 8577856 [details] [review]
[gaia] steveck-chung:message-RTL > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):bug 1130305
[User impact] if declined: Contact photo will be misaligned
[Testing completed]: N/A
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: N/A
Attachment #8577856 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8577856 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+

Comment 9

4 years ago
Posted image Verify_Pass.png
This problem is verified pass on latest build of Flame 2.2, Flame 3.0, N5 2.2 and N5 3.0 by the STR in comment 0.
Actual result: All contacts images are left aligned in RTL.
See attachment: Verify_Pass.png
Rate: 0/5

Device: Flame 2.2 (Pass)
Build ID               20150525162504
Gaia Revision          144673a413586f98b5e2c27b781c1a539611f754
Gaia Date              2015-05-25 02:01:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/115112d51e08
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150525.202102
Firmware Date          Mon May 25 20:21:12 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (Pass)
Build ID               20150525160205
Gaia Revision          5bcc08a732163087999251b523e3643db397412c
Gaia Date              2015-05-24 14:44:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b6623a27fa64
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150525.192755
Firmware Date          Mon May 25 19:28:07 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (Pass)
Build ID               20150525002504
Gaia Revision          144673a413586f98b5e2c27b781c1a539611f754
Gaia Date              2015-05-25 02:01:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c4db2af40b1b
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150525.041303
Firmware Date          Mon May 25 04:13:19 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (Pass)
Build ID               20150525160205
Gaia Revision          5bcc08a732163087999251b523e3643db397412c
Gaia Date              2015-05-24 14:44:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b6623a27fa64
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150525.192207
Firmware Date          Mon May 25 19:22:24 EDT 2015
Bootloader             HHZ12f

Thanks!

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.