bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Check for updates no longer works



3 years ago
2 years ago


(Reporter: masinick, Unassigned, NeedInfo)


SeaMonkey 2.33 Branch

Firefox Tracking Flags

(Not tracked)




3 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33
Build ID: 20150308222504

Steps to reproduce:

In Seamonkey 2.32.1, also in the new Seamonkey 2.33 (and recently in Seamonkey Nightly, not verified today) Check for updates results in the message "Update XML file malformed (200)". 

Actual results:

 Check for updates results in the message "Update XML file malformed (200)". 

Expected results:

Either report that there are no updates or update the next incremental software build.

Comment 1

3 years ago
I've seen this the past few days on Seamonkey Nightly; I'll check there and update this later.

Comment 2

3 years ago
Seamonkey Nightly 20150304003001 has this issue; I will try to snag a newer nightly build and try this again.

Comment 3

3 years ago
Seamonkey Nightly 20150312003001 still has the issue so it's being carried in Nightly Builds in the x86 Linux branch.

Comment 4

3 years ago
Anything helpful in http://kb.mozillazine.org/Software_Update#AUS_Update_XML_File_Malformed_200 ?
Are you using the same profile for all versions? That may screw up things.

Comment 5

3 years ago
CC Callek. Are we serving an invalid update XML file?
I think ewong was toying with updates on nightly. ...
Flags: needinfo?(ewong)

Comment 7

3 years ago
I managed to get my hands on a Linux box (x86), downloaded 2.33, 2.32.1,
and 2.36a1 nightly.

They all managed to check for updates with no errors.

Though not being familiar with getting it running, perhaps I did it wrong?

1) d/l 2.33, 2.32.1 and 2.36a1 nightly.
2) tar xvjf <tarball>
3) ./seamonkey/seamonkey -P test2 -no-remote -console
4) Help->Check for updates

masinick, can you clarify if you've tried it with a different profile?
Flags: needinfo?(ewong) → needinfo?(masinick)

Comment 8

3 years ago
Yes, I was able to download a nightly, though the update had an unusual way of confirmation that the download worked
Flags: needinfo?(masinick)

Comment 9

2 years ago
Still a problem for you? I did at least 1 (more or less) successful check for update with following update on a Linux UBUNTU 64 bit Virtual Machine, see "Bug 1228572 - Localized German Version updates with en-US next version"
Flags: needinfo?(masinick)

Comment 10

2 years ago
Never confirmed by a second user, no response, so I close this one for now.
@Reporter: Please feel free to reopen this Bug if you still can reproduce the problem with a current SeaMonkey version and a current OS and if you can contribute a step by step instruction how to reproduce the problem due to <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines>  (containing every key press and every mouse click) how to reproduce the problem reliably.
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.