Contacts sidebar doesn't remember the last selected address book after Bug 170270 checked in

RESOLVED FIXED in Thunderbird 45.0

Status

RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: u382332, Assigned: sshagarwal)

Tracking

(Depends on: 3 bugs, {regression})

Trunk
Thunderbird 45.0
regression
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird38 wontfix, thunderbird39 wontfix, thunderbird40 wontfix, thunderbird41 wontfix, thunderbird43 wontfix, thunderbird44 fixed, thunderbird45 fixed, thunderbird_esr3843+ fixed)

Details

(Whiteboard: [Not fixed for "All Address Books": See Bug 1236553.][Pls read comment 95 before commenting.][internal redesign of "All Address books" entry per comment 10 in Bug 1153840][regression:TB38], URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33
Build ID: 20150308222025

Steps to reproduce:

After Bug 170270 checked in, the Contacts sidebar no longer remembers the last selected address book when opening a new Compose window.


Actual results:

The Contacts side bar now reverts to All Address Books


Expected results:

Should remember last selected address book
(Reporter)

Updated

4 years ago
Summary: Contacts sidebar doesn't remember the last selected address book → Contacts sidebar doesn't remember the last selected address book after Bug 170270 checked in
(Reporter)

Updated

4 years ago
tracking-thunderbird39: --- → ?

Updated

4 years ago
Blocks: 170270
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows 7 → All
Hardware: x86_64 → All
Posted patch patch, v1 (obsolete) — Splinter Review
Assignee: nobody → archaeopteryx
Status: NEW → ASSIGNED
Attachment #8577676 - Flags: review?(mkmelin+mozilla)
(Assignee)

Comment 2

4 years ago
(In reply to Archaeopteryx [:aryx] from comment #1)
> Created attachment 8577676 [details] [diff] [review]
> patch, v1

I didn't add it to the xml file 'coz it had side-effects. Try looking in the Advanced AB search window, you'll see two "All ABs" entry.
Maybe, you'd like to just modify this here:
http://mxr.mozilla.org/comm-central/source/mail/components/addrbook/content/abCommon.js#276

Thanks.
Posted patch patch, v2 (obsolete) — Splinter Review
Hi Neil, you wrote most of the code in the widget. I removed the code which selects the first item from the widget and haven't seen issues.
Attachment #8577676 - Attachment is obsolete: true
Attachment #8577676 - Flags: review?(mkmelin+mozilla)
Attachment #8578616 - Flags: review?(neil)
Comment on attachment 8578616 [details] [diff] [review]
patch, v2

What happens when you add, remove or rename address books while the contacts sidebar is open?
(In reply to neil@parkwaycc.co.uk from comment #4)
> Comment on attachment 8578616 [details] [diff] [review]
> patch, v2
> 
> What happens when you add, remove or rename address books while the contacts
> sidebar is open?
They get added, removed and renamed.
(Reporter)

Comment 6

4 years ago
I know this one isn't a major bug but could we possibly get this one in before the next merge... please?
Bozz, at this late point tracking is for blocking, and we will not block on this bug. But when the patch is landed in trunk, feel free to set approval-comm- ? to request that it be added to Thunderbird 38.
tracking-thunderbird39: ? → ---

Comment 8

4 years ago
Neil, this 3-line-patch looks like it could do the right thing and might be quick to review. If you could spare the time, this would be nice to have for TB 38 (regression by new feature: "All ABs"). Tia.
status-thunderbird38: --- → affected
Flags: needinfo?(neil)

Comment 9

4 years ago
(In reply to Archaeopteryx [:aryx] from comment #5)
> (In reply to neil@parkwaycc.co.uk from comment #4)
> > Comment on attachment 8578616 [details] [diff] [review]
> > patch, v2
> > 
> > What happens when you add, remove or rename address books while the contacts
> > sidebar is open?
> They get added, removed and renamed.

Have you tried this?

1) in contacts side bar, select "AB3" (and keep composition open)
2) from main AB, delete "AB3"
3) verify selection in contacts side bar (should be "all abs")

1) in contacts side bar, select "AB3" (then save and close composition)
2) from main AB, delete "AB3"
3) edit composition again and verify selection in contacts side bar (should be "all abs")

will it correctly remember different books if different books are selected in different compositions (after saving, closing, reopening them)?

will it remember things when I close and restart TB?

These are some tests I could think of.
Comment on attachment 8578616 [details] [diff] [review]
patch, v2

Sorry, my review queue is basically a disaster area; if you're lucky you can bump with needinfo but that of course depends on not getting lost in the noise.

>   // Make an entry for "All Address Books".
>   if (abList) {
>     abList.insertItemAt(0, gAddressBookBundle.getString("allAddressBooks"),
>                         kAllDirectoryRoot + "?");
>-    // Select the newly added entry.
>-    abList.selectedIndex = 0;
>+    // Select the newly added entry if no other entry has been selected.
>+    if (abList.hasChildNodes() && abList.selectedIndex == -1)
>+      abList.selectedIndex = 0;
>   }
> }
The problem here is that you're subverting the creation of the address book menulist. You need to create the "All" entry in the widget constructor so that everything will work automatically. (Also your list must have child nodes because you inserted an item.)

The neatest approach would be to add an attribute to the menulist that specifies the label of the "All" entry, which you would then set as an entity in all appropriate XUL documents. You would then add code to the constructor to create the menuitem if the attribute exists. (Sadly adding content doesn't work.)

However if you want something that will work on the branch then the problem is that the constructor runs very early in document creation but you can always manually retrieve the string bundle and attempt to retrieve the label (but do nothing if the label does not exist).

Another manual approach that might work would be to hit the XUL store in top-level code, and then restore the value in InitCommonJS.

>+          let lastSelectedAb = Components.classes["@mozilla.org/xul/xulstore;1"]
>+            .getService(Components.interfaces.nsIXULStore);
>+            .getValue(document.location, "addressbookList", "value");
This is the wrong way to get the value in the constructor, and by the time this code runs, the value should have been set anyway. However using the manual approach you could add this as top-level code in abCommon.js and then InitCommonJS would try to reset the menulist.

>-          if (!menulist.selectedItem && this.hasChildNodes())
>-            menulist.selectedIndex = 0;
[This breaks SeaMonkey.]
Flags: needinfo?(neil)
Attachment #8578616 - Flags: review?(neil) → review-
Or another manual workaround would be to remove the persist="value" from the XUL documents, which would allow you to retrieve the saved persist state from within InitCommonJS and only then would you set the persist attribute.

Comment 12

4 years ago
Thank you Neil! :) Hope Archaeopteryx will be able to pick that up.

Comment 13

4 years ago
(In reply to neil@parkwaycc.co.uk from comment #10)
> The problem here is that you're subverting the creation of the address book
> menulist. You need to create the "All" entry in the widget constructor so
> that everything will work automatically. (Also your list must have child
> nodes because you inserted an item.)
> 
> The neatest approach would be to add an attribute to the menulist that
> specifies the label of the "All" entry, which you would then set as an
> entity in all appropriate XUL documents. You would then add code to the
> constructor to create the menuitem if the attribute exists. (Sadly adding
> content doesn't work.)
This is the plan in bug 1153840. Aryx, you can take it if you wish. Patch v1 was almost implementing it, just add the All ABs conditionally on the existence of an attribute.
(Reporter)

Comment 14

4 years ago
Just an FYI. Since v38 release other users are commenting about this bug now.

TB Address Book Issue
https://groups.google.com/forum/#!topic/mozilla.support.thunderbird/HEHXnmhukOQ

Compose window always defaults to "all address books"
https://groups.google.com/forum/#!topic/mozilla.support.thunderbird/ewKwmCTVfT0
(Reporter)

Comment 15

4 years ago
^ ...and here's another one.

why does the address book in 'Write' default to all addresses?
https://support.mozilla.org/en-US/questions/1068116

Updated

4 years ago
Duplicate of this bug: 1152912

Comment 17

4 years ago
Actual results:

The Contacts side bar now reverts to All Address Books


Expected results:

Should remember last selected address book

Updated

4 years ago
tracking-thunderbird_esr38: --- → +

Comment 18

4 years ago
(In reply to jakes from comment #17)
> Actual results:
> 
> The Contacts side bar now reverts to All Address Books
> 
> 
> Expected results:
> 
> Should remember last selected address book


1) Does it remember the selection even after TB has been fully quit and relaunched (hope so!), or does the selection persist only in subsequent composition windows, but need to be made anew for each session?

2) Does the selection apply to the address book window itself (hope so!), or only to the contacts sidebar? (This is less crucial, but would still be desirable).

3) Assuming the fix is in, any idea when it will be implemented? (Currently running v38.0 on the Beta channel)

Comment 19

4 years ago
(In reply to jakes from comment #17)

> Actual results: 
> The Contacts side bar now reverts to All Address Books
> 
> Expected results:
> Should remember last selected address book

My above questions (comment 18) were intended to apply to the expected results.

Does comment #17 indicate that a working fix has yet to be developed?

Comment 20

4 years ago
(In reply to Mitch in Oakland from comment #18)
> (In reply to jakes from comment #17)
> > Actual results:
> > 
> > The Contacts side bar now reverts to All Address Books
> > 
> > 
> > Expected results:
> > 
> > Should remember last selected address book
> 
> 
> 1) Does it remember the selection even after TB has been fully quit and
> relaunched (hope so!), or does the selection persist only in subsequent
> composition windows, but need to be made anew for each session?
> 
> 2) Does the selection apply to the address book window itself (hope so!), or
> only to the contacts sidebar? (This is less crucial, but would still be
> desirable).
> 
> 3) Assuming the fix is in, any idea when it will be implemented? (Currently
> running v38.0 on the Beta channel)

1)	It remembers the selection even after TB has been fully quit and relaunched
2)	the both but priority processing to selection applies to the address book window itself is 
3)	I hope it w’ll become again what he was before v.38

Comment 21

4 years ago
Excellent! Thank you! I'll be keeping an eye out for this on the next beta update!

Comment 22

4 years ago
Thank you !!

Updated

4 years ago
See Also: → bug 1177706

Updated

4 years ago
status-thunderbird38: affected → wontfix
status-thunderbird39: --- → affected
status-thunderbird40: --- → affected
status-thunderbird41: --- → affected
status-thunderbird_esr38: --- → affected

Comment 23

4 years ago
As per bug 1142705, if the choice of address books is made in the contacts sidebar of a composition window, it will persist in subsequent composition windows during that session, but will be lost (defaulting to "All Addresses") if TB is quit and relaunched. Thus, the initial selection must be made in the contacts bar for each session.

As per this bug, however, if a selection is made in the "Address Book" window, it doesn't persist at all. Each time the address book window is opened (even during the same session), it will default to "All Addresses."

Comment 24

4 years ago
CORRECTION -- COMMENT 23 SHOULD READ:

As per bug 1142705, if the choice of address books is made in the contacts sidebar of a composition window, it will persist in subsequent composition windows during that session, but will be lost (defaulting to "All Addresses") if TB is quit and relaunched. Thus, the initial selection must be made in the contacts bar for each session.

As per bug 1177706, however, if a selection is made in the "Address Book" window, it doesn't persist at all. Each time the address book window is opened (even during the same session), it will default to "All Addresses."

Thus, these two problems are parallel, but the one in the address book, while perhaps less likely to be encountered, is even more stubborn.

Comment 25

4 years ago
Why is this marked as wontfix for 38?

This is a major bug in a new feature that will cause a lot of grief for people, and it should be fixed in the current release.

Comment 26

4 years ago
(In reply to Charles from comment #25)
> Why is this marked as wontfix for 38?
> 
> This is a major bug in a new feature that will cause a lot of grief for
> people, and it should be fixed in the current release.

I agree with you.
(In reply to Charles from comment #25)
> Why is this marked as wontfix for 38?

Because after the release, we track using status-thunderbird_esr38 and the state of status-thunderbird38 is no longer meaningful.

Comment 28

4 years ago
Oh... ok, thanks...

That is a bit confusing though...

Maybe there shouldn't be a non ESR flag for what will become an ESR release?

Anyway, question answered, and thanks again!
Yes it is confusing, and to make it worse I keep changing what I am doing. It's still a learning process to manage these releases.

Comment 30

4 years ago
Am I right to assume that the last used AB will be remembered *per composition window*? Changing the selected AB for composition 1 does not imply needing the same AB for composition 2? Or the other way round, after picking the right AB for composing message 2, it would be very confusing if that AB changes to something unrelated becauses I'm using another AB in composition 1?

Comment 31

4 years ago
Just a thought to consider another possible solution:
Prior to the creation of 'All Address Books', TB opened Write window defaulting to 'Personal Address Book' as selected in the Contacts Sidebar and I do not recall anyone asking to change that to a remembered address book, so assume it worked ok for people. But I'm willing to accept I could be wrong.

The objections arose when the 'All address Books' option was set as default and this lead to the request to remember a selected address book because 'All Address Books' was not a useful default.

So, would it be easier and quicker to apply, from a coding point of view, to just set the default to the first address book in other words 'Personal Address Book' as before?

Comment 32

4 years ago
(In reply to Anje from comment #31)
> Just a thought to consider another possible solution:
> Prior to the creation of 'All Address Books', TB opened Write window
> defaulting to 'Personal Address Book' as selected in the Contacts Sidebar

No it didn't. I just tested on TB 31.

Old & useless behaviour of TB 31:

1 compose msg1 with contacts side bar
-> defaults to "personal AB" unless you've changed it before
2 save msg1, don't close
2a compose new msg
-> "personal ab"
3 compose msg2
4 change to "collected addresses" in msg2
4a compose new msg
-> "collected addresses" (whichever ab was last chosen in any composition will be used for new compositions)
5 tab to msg1
-> msg 1 still has "personal AB" (at least we get that right as long as windows aren't closed we don't mess around with selected ab in contacts side bar)
6 close both msgs
7 open msg1 (last seen with personal ab)
-> "collected addresses" now selected

So, TB 31 had a confusing mix that while windows are open, you can set a different AB in contacts side bar according to the needs of each composition, but reopening same msg from draft will end up with a random Ab whichever was last used on some other composition.

Imo we should be more preservative for existing compositions, and give users a choice for new compositions.

A) contacts side bar is not an independent AB, it serves a purpose for composing that particular message next to it. So if I choose "custom AB" for msg1, then TB should respect that choice even after reopening the same msg1 from drafts folder, because it's a deliberate choice and we have no reason to assume that a random ab last used on some other msg2 is the right one for msg1. Iow, we must preserve the exact status of the composition exactly as before closing it, including the AB which user selected for that msg. I conclude the selected AB in contacts side bar should be saved in the x-mozilla-draft header with the draft.

B) For new messages, we don't know what's best for user, but it's safe to assume different users -> different needs. Depending on your tasks and workflows, there can be two types of users:
- for some users, composing new messages and show the AB last used in some other composition might make sense if they are sequentially composing similar messages. When composing messages to 100 individual clients, they'll curse if we default them back to "All abs" or "Personal AB" each time.
- for other users, composing new messages with the last used AB will be completely annoying, say my msg1 was private so I chose "personal AB", but now I'm composing business client for which I need "business clients AB", and then I'll compose to business partner for which I need "business partners AB". For such scenarios, we should allow the user to define a default AB which he prefers for new messages to have a clean start with the same default AB each time.
That default AB could be "all abs" or any other specific AB (which user deems right for a clean and habitual start and/or most cases).
In support of that, defaulting to "All ABs" can make perfect sense if the database is not too large or it's large but entries are clearly differentiated somehow, I can find any contact from any AB using that.

> and I do not recall anyone asking to change that to a remembered address
> book, so assume it worked ok for people. But I'm willing to accept I could
> be wrong.

Indeed that's likely wrong because the assumed old behaviour was wrongly described.

> The objections arose when the 'All address Books' option was set as default
> and this lead to the request to remember a selected address book because
> 'All Address Books' was not a useful default.

It really depends on each user's AB structurual setup and use patterns if "All ABs" is a useful start or not, or if "last used AB" or any other specific AB like "personal AB" is better.

> So, would it be easier and quicker to apply, from a coding point of view, to
> just set the default to the first address book in other words 'Personal
> Address Book' as before?

First book doesn't make much sense, more so as we don't allow customization of order.

PROPOSAL

a) For contacts side bar, as shown in this comment, we should implement the following dropdown select option:

Tools > Options > Composition > Addressing > 

For contacts side bar, initially show:
[All Address Books | v]
|Last used address book |
|Personal AB            |
|Custom AB              |
|Collected Addresses    |

b) Same for the main AB, we'll only get it right for all if we give users a choice by implementing this option: (from Bug 1177706 Comment 2):

When opening Address book, show:
[All Address Books | v]
|Last used address book |
|Personal AB            |
|Custom AB              |
|Collected Addresses    |

We don't have a category for AB options yet, perhaps another sub-tab on Tools > Options > Advanced.

c) We might get away with conflating the two options into the same for contacts side bar and main AB, but I'd recommend against that. The AB users want to see for new compositions is not necessarily related to what they expect for the main AB, e.g. if they only use main AB for managing addresses but not for composing. So we'll be on the safe side if we allow different preference between Main AB and contacts side bar. UI costs are low, this is essential for everyday workflow efficiency.

d) For draft compositions, the last selected AB in contacts side bar should be always be saved in the x-mozilla-draft header, and restored when reopening the draft. Showing another random or default AB does not make sense after user deliberately chose a particular AB in the contacts side bar of a particular draft.

Comment 33

4 years ago
So, maybe just a new pref, tied to the Identity, that allows you to set a default Address Book per identity, but defaults to 'Personal Address Book, if you haven't manually changed it?

Comment 34

4 years ago
(In reply to Charles from comment #33)
> So, maybe just a new pref, tied to the Identity, that allows you to set a
> default Address Book per identity, but defaults to 'Personal Address Book,
> if you haven't manually changed it?

I think this is also doable. Would you think about any other places where this setting could be used?
Aceman, are you planning to try to fix this?
Flags: needinfo?(acelists)

Comment 36

4 years ago
INTERFACE SUGGESTION:

Wouldn't it make sense for the user to be able to choose the respective default ABs -- one for the Address Book, one for the Contacts sidebar -- with respective pop-ups located on the "Addressing" sub-pane of the main "Composition" Preference pane? 

At least on my Mac (running v38.0 beta), the entire lower half of that pane is currently empty -- and that seems like a logical interface location (sharing the panel with "address autocompletion" and "automatic address book addition" settings).
(In reply to :aceman from comment #34)
> (In reply to Charles from comment #33)
> > So, maybe just a new pref, tied to the Identity, that allows you to set a
> > default Address Book per identity, but defaults to 'Personal Address Book,
> > if you haven't manually changed it?
> 
> I think this is also doable. Would you think about any other places where
> this setting could be used?

I suspect this idea deserves a new bug. Plus, if it needs strings it can't be done for version 38.

Comment 38

4 years ago
(In reply to Kent James (:rkent) from comment #35)
> Aceman, are you planning to try to fix this?
Somehow I thought Aryx is working on this.
Flags: needinfo?(acelists)

Comment 39

4 years ago
Hi,
> 
> the Contacts sidebar no longer remembers the
> last selected address book when opening a new Compose window.
> 
> The Contacts side bar now reverts to All Address Books
> 

This regression is very annoying!

Bernard
Aryx, are you still up for finishing this?
Twould be cool to get soonish so it can make an ESR point release.
Flags: needinfo?(aryx.bugmail)

Updated

4 years ago
Duplicate of this bug: 1199642
Last update was over a month ago, users are still experiencing this particular issue. Any updates on this?

Cheers!

Comment 43

4 years ago
For what I can see I did not see any modification in official TB 38.3.0 and I have some problems when I have to send mail to different mailing lists. In fact the sidebar "resets" to all addessbooks after any  posting :-(
Topoldo

Comment 44

4 years ago
Bug still present in TB 38.3.0

Bernard

Comment 45

4 years ago
TB 38.3.0 linux.  This annoying AB bug still here after many updates.  Like the idea of adding a selection choice to Identities.

Comment 46

4 years ago
Can´t believe a bug of this importance is still not solved in the official release. What´s up, TB coders??? ;-))

Comment 47

4 years ago
Früher ging es doch, warum kann man eine so kleine Änderung nicht einbauen? Das zuletzt geöffnete Adressbuch (wie früher) automatisch bei jedem Start wieder öffnen?
Wofür habe ich mir (weil Thunderbird das konnte) so viele adress-books eingerichtet, wenn ich jetzt mehrmals täglich immer wieder von "alle Adressbücher" in mein "Privat"-Adress-Book wechseln muss?

It worked before - why can Thunderbird not correct it?
It can not be difficult to open the last used adress-book when I start my pc / Thunderbird.
Because Thunderbird has had this function(some times ago) I made a lot of different adress-books and it was easy to use. And now I have to change the adress-book (from all Adressbooks to privat-adressbook) many times a day!
(Assignee)

Comment 48

4 years ago
So, before we fix it properly and implement all the feature requests, can we revert it back to the way it was before All ABs was introduced?

This patch brings it back to the same state. The composition window will remember the last chosen entry. With nothing fancy and expected behaviours apart from that.
Can we have it in so that the users can be happy with the old behaviour?

Thanks.
Attachment #8672268 - Flags: feedback?(neil)
Attachment #8672268 - Flags: feedback?(acelists)

Comment 49

4 years ago
(In reply to Thomas D. (currently busy elsewhere; needinfo?me) from comment #32)
> Old & useless behaviour of TB 31:
> ...
> PROPOSAL
> ...

Please. If anybody wants anything implemented for TB38, it must be simple. Maybe we can just make it behave the same as before bug 170270 (with all its deficiencies described here), as that is what this bug wants (as filed). So no per compose window stuff, no saving in drafts no fancies.

For the technical part that Neil proposes in comment 10, we already have bug 1153840 (which may not be needed for the bug here to be fixed).

All the changes in behaviour you guys propose should have their own bugs filed separately. Thomas, please file those.

Suyash, can you see some quick fix here to restore the selection to pre-170270? Of course preserving the "All ABs" item in the list.
(Assignee)

Comment 50

4 years ago
(In reply to :aceman from comment #49)
> Suyash, can you see some quick fix here to restore the selection to
> pre-170270? Of course preserving the "All ABs" item in the list.

I've attached my proposed patch.

Thanks.

Comment 51

4 years ago
(In reply to Suyash Agarwal (:sshagarwal) away till 21st Sept from comment #50)
>> 
> I've attached my proposed patch.
> 
> Thanks.

When will this be in an official TB update then? (soon, please, shouldn´t be such a prob, should it?) 
If not in the next, soon-to-come release, how do I (normal user, no coder etc.) attach the patch? Noob-how-to? ;)
Attachment #8672268 - Flags: feedback?(neil) → feedback+

Comment 52

4 years ago
Somehow I can't reproduce this in TB38.3. I do this:
1. open compose
2. open sidebar (F9)
3. select Personal AB
4. close compose
5. reopen compose
6. sidebar is open with Personal AB selected.

How can I see the bug?

Comment 53

4 years ago
Hi, :aceman.
Just close TB. 
If you reopen it and compose a new message, the last AB isn't selected anymore, yet it was before this bug appeared.
(Reporter)

Comment 54

4 years ago
(In reply to :aceman from comment #52)
> Somehow I can't reproduce this in TB38.3. I do this:
> 1. open compose
> 2. open sidebar (F9)
> 3. select Personal AB
> 4. close compose
> 5. reopen compose
> 6. sidebar is open with Personal AB selected.
> 
> How can I see the bug?
It's been this way since before TB38.0. I've been using trunk builds forever and I'm currently using trunk 44.0a1 and the bug is still in there. I don't have to close TB to see it. It happens with each new compose window.

Comment 55

4 years ago
Comment on attachment 8672268 [details] [diff] [review]
Minimal patch (revert to remembering last used AB; fails for "All ABs" entry) [checked in]

Review of attachment 8672268 [details] [diff] [review]:
-----------------------------------------------------------------

OK, I can see the problem across restarts. And this patch fixes it.
Attachment #8672268 - Flags: feedback?(acelists) → feedback+

Comment 56

4 years ago
Comment on attachment 8672268 [details] [diff] [review]
Minimal patch (revert to remembering last used AB; fails for "All ABs" entry) [checked in]

Review of attachment 8672268 [details] [diff] [review]:
-----------------------------------------------------------------

Hi, thanks for your patch (the error appears on my PC only if I close TB and open it again).
But I do not know, how I have to install (I never did it before), I only used the updates.
Please give me an instruction, what have I to do?
Thank you very much!

Comment 57

4 years ago
Thanks aceman!

Question: is this a global thing, or per account/identity?

I don't know how it worked before either, so this might be a new feature request, but it would be great if it could remember the last selected AB per Account/Identity...

Comment 58

4 years ago
(In reply to Charles from comment #57)
> Thanks aceman!
> 
> Question: is this a global thing, or per account/identity?
Global.

> I don't know how it worked before either, so this might be a new feature
> request, but it would be great if it could remember the last selected AB per
> Account/Identity...
What you say is a new feature request, we think it didn't work before. Please file it as a new enhancement.

In this bug we try to fix the regression, to have a chance to go into TB38.

Comment 59

4 years ago
Yeah, that's what I thought, thanks...

Bug 1213941 created.

Thanks again for working on this!

Comment 60

4 years ago
Can someone go dupe bug 1177706 to this one?

Comment 61

4 years ago
(In reply to Charles from comment #59)
> Thanks again for working on this!
It is Aryx and Suyash working on this.
Flags: needinfo?(aryx.bugmail)
Whiteboard: [regression:TB38]

Updated

4 years ago
Attachment #8672268 - Flags: review?(mkmelin+mozilla)

Updated

4 years ago
Blocks: 1177706
Duplicate of this bug: 1177706

Comment 63

4 years ago
(In reply to :aceman from comment #61)
> (In reply to Charles from comment #59)
> > Thanks again for working on this!
> It is Aryx and Suyash working on this.

Ooops, you're right, sorry Aryx and Suyash - thanks to both of you for working on this!

Comment 64

4 years ago
So, as no-one would like to explain to me how to use the patch, simple question: When will this be working again in official Thunderbird?
(Assignee)

Updated

4 years ago
Attachment #8672268 - Flags: feedback?(aryx.bugmail)
(In reply to marco from comment #64)
> So, as no-one would like to explain to me how to use the patch, 

Presumably if you know how to build from source code then you wouldn't be asking this question :)
And if that presumption is incorrect then google "build thunderbird" 

> question: When will this be working again in official Thunderbird?

in version 38?  probably 1-3 months depending on various factors.
Comment on attachment 8672268 [details] [diff] [review]
Minimal patch (revert to remembering last used AB; fails for "All ABs" entry) [checked in]

Review of attachment 8672268 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, r=mkmelin
Attachment #8672268 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Whiteboard: [regression:TB38] → [regression:TB38][Checkin proposal.patch, keep the bug open for a ground0-up fix by the assignee]

Comment 67

3 years ago
https://hg.mozilla.org/comm-central/rev/2e8ee22712e13f32f180f8889492927c2af9e390
Bug 1142705 - Contacts sidebar doesn't remember the last selected address book after Bug 170270 checked in. r=mkmelin

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 45.0

Updated

3 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 68

3 years ago
does this need uplifts?
Why was it reopened? Is that for possible uplifts? Yes it needs uplifting (per tracking and affected flags), but that is normally done in the FIXED state.

Comment 70

3 years ago
(In reply to Kent James (:rkent) from comment #69)
> Why was it reopened? Is that for possible uplifts? Yes it needs uplifting
> (per tracking and affected flags), but that is normally done in the FIXED
> state.

I (and you) failed to notice the author's request in the whiteboard ;)

Comment 71

3 years ago
(In reply to aleth [:aleth] from comment #70)
> (In reply to Kent James (:rkent) from comment #69)
> > Why was it reopened? Is that for possible uplifts? Yes it needs uplifting
> > (per tracking and affected flags), but that is normally done in the FIXED
> > state.
> 
> I (and you) failed to notice the author's request in the whiteboard ;)

Having said that, I think it would be far less confusing to do any ground-up reworkings in a separate followup bug. This one already has 70 comments.

Comment 72

3 years ago
(In reply to marco from comment #64)
> So, as no-one would like to explain to me how to use the patch, simple
> question: When will this be working again in official Thunderbird?

(In reply to Hans-Werner from comment #56)
> Comment on attachment 8672268 [details] [diff] [review]
> Proposal
> 
> Review of attachment 8672268 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Hi, thanks for your patch (the error appears on my PC only if I close TB and
> open it again).
> But I do not know, how I have to install (I never did it before), I only
> used the updates.
> Please give me an instruction, what have I to do?
> Thank you very much!

Hello Hans-Werner, thanks for the appreciation.
Unfortunately, you cannot "install" the patch into your release version, and there's no other safe or viable way for normal users to enjoy the patch before it gets released (hello Marco, that's what Wayne was trying to say...).
We'll land the patch into the main tree of code on our servers, where we let the tree grow under supervision to find out if all is good, and eventually (after some months, or maybe earlier if we decide to uplift), it will come to you with automatical updates.

Pls don't use review function as it is reserved for developers and others who'll know they may use it.

Comment 73

3 years ago
(In reply to aleth [:aleth] from comment #71)
> (In reply to aleth [:aleth] from comment #70)
> > (In reply to Kent James (:rkent) from comment #69)
> > > Why was it reopened? Is that for possible uplifts? Yes it needs uplifting
> > > (per tracking and affected flags), but that is normally done in the FIXED
> > > state.
> > 
> > I (and you) failed to notice the author's request in the whiteboard ;)
> 
> Having said that, I think it would be far less confusing to do any ground-up
> reworkings in a separate followup bug. This one already has 70 comments.

+1

Patch author (Suyash) is currently different from assignee (Sebastian H. aka :aryx).
Sebastian helpfully offered a patch which almost did the trick, similar to the final patch here. Thank you Sebastian!

Iiuc Neil's comment 10 is mostly discussing the underlying design which was added by bug 170270, so he was asking Aryx to fix things which he never implemented. Aryx just tried to tweak the status quo back into remembering the last-used AB. Fixing the underlying design is already filed as bug 1153840 (how we add "All Address Books" entry to respective consumers of AB lists; what Suyash calls "ground0-up fix"). 

Minimal patch has landed so this bug is FIXED (by Suyash which makes him the new assignee).

In view of noticable user interest*, uplifting the patch into release versions is desirable.

Anything else, like my Comment 32, needs new bugs if we don't have them already.

* https://support.mozilla.org/en-US/questions/1068066 - 116 have this problem, 1165 views.
Assignee: aryx.bugmail → syshagarwal
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Whiteboard: [regression:TB38][Checkin proposal.patch, keep the bug open for a ground0-up fix by the assignee] → [regression:TB38][Check if followup bugs exist for Comment 32][internal redesign of "All Address books" entry per comment 10 in Bug 1153840]
Comment on attachment 8672268 [details] [diff] [review]
Minimal patch (revert to remembering last used AB; fails for "All ABs" entry) [checked in]

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky):
Attachment #8672268 - Flags: approval-comm-esr38?
Attachment #8672268 - Flags: approval-comm-beta?
Attachment #8672268 - Flags: approval-comm-aurora?
(Assignee)

Updated

3 years ago
Attachment #8672268 - Flags: feedback?(aryx.bugmail)
Comment on attachment 8672268 [details] [diff] [review]
Minimal patch (revert to remembering last used AB; fails for "All ABs" entry) [checked in]

https://hg.mozilla.org/releases/comm-beta/rev/d108efa34154

For comm-esr38, the normal process now is to go through beta first, then comm-esr38. That would put the first release of this into TB 38.6  Feel free to object, but you need to do that ASAP.
Attachment #8672268 - Flags: approval-comm-beta?
Attachment #8672268 - Flags: approval-comm-beta+
Attachment #8672268 - Flags: approval-comm-aurora?

Updated

3 years ago
status-thunderbird39: affected → wontfix
status-thunderbird40: affected → wontfix
status-thunderbird41: affected → wontfix
status-thunderbird43: --- → wontfix
status-thunderbird44: --- → fixed
status-thunderbird45: --- → fixed
I(In reply to Kent James (:rkent) from comment #75)
> Comment on attachment 8672268 [details] [diff] [review]
> Proposal
> 
> https://hg.mozilla.org/releases/comm-beta/rev/d108efa34154
> 
> For comm-esr38, the normal process now is to go through beta first, then
> comm-esr38. That would put the first release of this into TB 38.6  Feel free
> to object, but you need to do that ASAP.

Of all the tracked bugs, I'm very comfortable about taking this for esr despite not having been on beta - it's well tested, tiny patch, not in any critical data path.
Comment on attachment 8672268 [details] [diff] [review]
Minimal patch (revert to remembering last used AB; fails for "All ABs" entry) [checked in]

https://hg.mozilla.org/releases/comm-esr38/rev/b88229610b41
Attachment #8672268 - Flags: approval-comm-esr38? → approval-comm-esr38+
OK we'll pull this for TB 38.5
status-thunderbird_esr38: affected → fixed
tracking-thunderbird_esr38: + → 43+

Comment 79

3 years ago
Feedback.
Updated to Thunderbird 38.5
Using windows Vista
Confirmation - Whatever address book I select in the 'Contacts sidebar' is remembered the next time I open a new Write window. 
It does not fully work if I close and reopen Thunderbird. To this extent it is not fixed.

I cannot locate anywhere eg: Options > Composition > Addressing  or in a Write window or in the prefs.js file  where I can set the default. Perhaps this is something for the future.

If I were to access the 'Config Editor' - what entry would I need to search for in order to apply any modifications?

Test results on my Windows Vista OS:

If I select 'All Address Books' - it is never remembered when I exit thunderbird, instead it remembers 'Personal Address book'

If I select 'Collected Addresses' or 'Personal Address Book'- it is remembered when I exit thunderbird.

If I select a created address book called eg:'Business' - it is remembered when I exit thunderbird.

So basically, if anyone actually wanted to use the 'All Address books' option then they are scuppered.
If they want to use a real address book then they should be ok.

Please read the comment at this link. 
This person suddenly is stuck on 'collected addresses', but they want to use 'All Address Books'.
This occurs on both Apple iMac and Windows 8.1,
https://support.mozilla.org/en-US/questions/1101956

We appreciate the work to try to fix, but it is not correct yet.

Comment 80

3 years ago
Thank you for fixing this in 38.5
It now works as expected.

Comment 81

3 years ago
Yes, Thank for you fixing this problem.  
Now Thunderbird works just like it use to ... in Windows 7
Major emailing frustration --- alleviated!

Comment 82

3 years ago
Happy new year everyone !
Sorry I don't speak well English.
My understanding is that the 38.5 have solved the problem...???
The last used address book is it remembered when we exit thunderbird ?
Is it working well on Windows 10 ?
I still use 31.6 because I only need my Personal Address book
Thank you for your help !

Comment 83

3 years ago
I am on a Mac, using v.43 on the beta update channel.

Nothing has changed. When I quit and relaunch TB, the contacts bar reverts to "All Address Books."

What's up with that?
(In reply to Mitch in Oakland from comment #83)
> I am on a Mac, using v.43 on the beta update channel.
> 
> Nothing has changed. When I quit and relaunch TB, the contacts SIDEbar reverts
> to "All Address Books."
> 
> What's up with that?

At the  top of this bug report 
"status-thunderbird43: wontfix" 
"status-thunderbird44:	fixed"
"status-thunderbird_esr38: fixed"

So you can find the fix in 38.5.0, or 44.0a2 earlybird. But not 43.0b1

Comment 85

3 years ago
Its fixed on my end. running 10, when I reopen tb it opens in the last address book I used. Thanks guys.

Comment 86

3 years ago
Hi,

It's OK for me : When I reopen TB it opens in the last address book I used. 
Thanks.

TB 38.5.0
Win7/x86

Comment 87

3 years ago
Hi,

I've recently been chatting with Toad-Hall on your forums regarding the fact that, since this bug fix, Thunderbird does not save the Address Book selection if "All Address Books" is chosen. 

Toad-Hall suggested I post a comment here, regarding this.

Any of the other address book selections are in fact saved after exiting the Compose window, and also after exiting Thunderbird, but "All Address Books" is only saved after exiting the Compose window, NOT after exiting Thunderbird!

This means for people like myself, who want "All Address Books" selected all the time, Thunderbird no longer allows us to do that, whereas it used to do it by default.

I am using an iMac computer running OS X 10.9.5. My wife is experiencing the same issue on a Toshiba laptop running Windows 8.1.

Comment 88

3 years ago
(In reply to Anje from comment #79)
> If I select 'All Address Books' - it is never remembered when I exit
> thunderbird, instead it remembers 'Personal Address book'
> 
> If I select 'Collected Addresses' or 'Personal Address Book'- it is
> remembered when I exit thunderbird.

Probably best to open a new bug for this...

Comment 89

3 years ago
Opened new bug for the 'All Address Book' not being remembered issue.
https://bugzilla.mozilla.org/show_bug.cgi?id=1236553

Updated

3 years ago
Whiteboard: [regression:TB38][Check if followup bugs exist for Comment 32][internal redesign of "All Address books" entry per comment 10 in Bug 1153840] → [regression:TB38][followup bugs exist for comment 32 - see comment 89][internal redesign of "All Address books" entry per comment 10 in Bug 1153840]

Updated

3 years ago
Duplicate of this bug: 1178099

Updated

3 years ago
Depends on: 1236553

Updated

3 years ago
Blocks: 1213941

Updated

3 years ago
Blocks: 1308776

Updated

2 years ago
Blocks: 1343617

Updated

2 years ago
No longer blocks: 1343617

Comment 91

2 years ago
Status of this bug is currently shown as RESOLVED FIXED in Thunderbird 45.0.

I disagree that it is fixed.

I originally commented on this one in comment 87. The problem then was that "All Address Books" is only saved after exiting the Compose window, NOT after exiting Thunderbird!

That has not changed since I made that comment.

I am using an iMac computer running Thunderbird 45.7.1 under OS X 10.9.5. My wife is still experiencing the same issue on a Toshiba laptop running the latest update of Thunderbird on Windows 10.

Comment 92

2 years ago
Please open a new bug for the problem. We are now at TB54 so we should not mess up this bug that landed in TB45.

Updated

2 years ago
Attachment #8578616 - Attachment is obsolete: true

Comment 93

2 years ago
Comment on attachment 8672268 [details] [diff] [review]
Minimal patch (revert to remembering last used AB; fails for "All ABs" entry) [checked in]

This has landed, but unfortunately it won't remember "All Address Books" (bug 1236553), which will be quite annoying for users relying on this behaviour.
Attachment #8672268 - Attachment description: Proposal → Minimal patch (revert to remembering last used AB; fails for "All ABs" entry) [checked in]

Comment 94

2 years ago
(In reply to :aceman from comment #92)
> Please open a new bug for the problem. We are now at TB54 so we should not
> mess up this bug that landed in TB45.
Umm, I think he's right, please open a new bug for this follow-up.

Comment 95

2 years ago
(In reply to Jorg K (GMT+2) from comment #94)
> (In reply to :aceman from comment #92)
> > Please open a new bug for the problem. We are now at TB54 so we should not
> > mess up this bug that landed in TB45.
> Umm, I think he's right, please open a new bug for this follow-up.

Please do NOT open a new bug because per comment 89, and known to everyone including gazthewiz, the respective follow-up bug has already been filed:

Bug 1236553 - Contacts Sidebar does not remember 'All Address Books'

(In reply to gazthewiz from comment #91)
> Status of this bug is currently shown as RESOLVED FIXED in Thunderbird 45.0.
> 
> I disagree that it is fixed.

gazthewiz and others, thank you for sharing your user experience. You are totally right that the problem of this bug is *not completely fixed* as contacts side bar still fails to remember "All Address Books", which is annoying, and we apologize for the inconvenience. However, for reasons of bug management workflow, we cannot reopen this particular bug here, because the patch has already landed and there's no reason to back it out. Instead, we will handle any outstanding issues in separate bugs ("follow-up" bugs), which are tracked in the "Depends on" field of this bug. So please track the progress of your issue in bug 1236553. We are aware of the problem and we'll fix it when there's somebody with the required skill, will, and availability. Please keep in mind that most of us are volunteers and there are lots of bugs out there which require attention. Thank you for understanding.

The good news is that we're considering to further improve the contacts side bar user experience wrt remembering your favorite AB, along the lines of my comment 32 and Charles' comment 33:

Bug 1213941 - Contacts Side Bar: Implement pref to remember last selected or default Address Book per Account/Identity
No longer blocks: 1213941, 1177706, 1308776
Depends on: 1153840, 1213941
See Also: → bug 1308776
Whiteboard: [regression:TB38][followup bugs exist for comment 32 - see comment 89][internal redesign of "All Address books" entry per comment 10 in Bug 1153840] → [Not fixed for "All Address Books": See Bug 1236553.][Pls read comment 95 before commenting.][internal redesign of "All Address books" entry per comment 10 in Bug 1153840][regression:TB38]

Updated

2 years ago
Depends on: 1354799

Comment 96

2 years ago
(In reply to Thomas D. from comment #95)

> The good news is that we're considering to further improve the contacts side
> bar user experience wrt remembering your favorite AB, along the lines of my
> comment 32 and Charles' comment 33:
> 
> Bug 1213941 - Contacts Side Bar: Implement pref to remember last selected or
> default Address Book per Account/Identity

Bug 1354799 - Contacts sidebar should remember the last used address book when re-opening drafts, using x-mozilla-draft header

(In reply to Thomas D. from comment #32)
> d) For draft compositions, the [AB selected in contacts side bar at the time of saving/closing] should
> always be saved in the x-mozilla-draft header, and restored when
> reopening the draft. Showing another random or default AB does not make
> sense after user deliberately chose a particular AB in the contacts side bar
> of a particular draft.

Comment 97

2 years ago
(In reply to Thomas D. (currently busy elsewhere; needinfo?me) from comment #95)
> Please do NOT open a new bug because per comment 89, ...
Sorry, I got confused since you commented on a patch landed in 2015. My apologies.
You need to log in before you can comment on or make changes to this bug.