Window stops painting on OS X, after sleep

RESOLVED DUPLICATE of bug 1142957

Status

()

defect
RESOLVED DUPLICATE of bug 1142957
5 years ago
5 years ago

People

(Reporter: milan, Assigned: mchang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Got it twice with today, at random times.  Painting stops completely. I can create a new tab and I don't see it until I tab to a different window and come back.  I can destroy a tab, same thing.  I can click on the content that has a input field, start typing, nothing.  Need to restart to fix it.

I haven't tried if creating a new window without restarting firefox helps - I'll try that next time this happens.
There was definitely computer sleep involved (e.g., lid closed), but not every time.
Assignee: nobody → mchang
Status: NEW → ASSIGNED
Hmm that is odd. Can you try with disabling the gfx.vsync prefs to false in about:config?
Flags: needinfo?(milan)
Also, I only flipped on the vsync compositor yesterday. So if we stop painting completely, that might be something else. I'll run locally with just the compositor and see if I hit something.
I've been seeing this in the last day or two. Current Mac Nightly, 10.9, e10s off.
Workaround: Cmd-~ to a different window. This immediately fixes things for me.
Fix is in bug 1142957. Thanks for reporting though!
Woops, committed the patch in bug 1142957 with this bug number, even though they are dupes. 

https://hg.mozilla.org/integration/mozilla-inbound/rev/8545a7f27c8c
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1142957
Flags: needinfo?(milan)
You need to log in before you can comment on or make changes to this bug.