firefox -P profile opens the wrong profile when running multiple profiles

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
4 years ago
4 months ago

People

(Reporter: glandium, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #486172 +++

When running multiple profiles simultaneously firefox -P profile opens the wrong profile on Windows.

Reproducible: Always

Steps to Reproduce:
1. Open a profile: firefox -P profile1 -no-remote
2. Open another profile: firefox -P profile2 -no-remote
3. Open a window: firefox -P profile2
Actual Results:  
The first step opens the first window of profile1
The second step opens the first window of profile2
The third step opens a window of profile1

Expected Results:  
The first step opens the first window of profile1
The second step opens the first window of profile2
The third step should have opened a window of profile2

Comment 1

4 years ago
This is not intended to work. Windows remoting doesn't store profile names and I don't want to support the complexity for that.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Updated

4 months ago
Duplicate of this bug: 1485519
You need to log in before you can comment on or make changes to this bug.