The default bug view has changed. See this FAQ.

Images and fonts should optionally scale with DPI

RESOLVED DUPLICATE of bug 112018

Status

()

Core
Layout
--
enhancement
RESOLVED DUPLICATE of bug 112018
16 years ago
13 years ago

People

(Reporter: James Crowson, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
On very high resolution screens, it is necessary to enlarge fonts and images so 
they will still be a readable size.  I personally have a 170 pixels per inch 
display, and although I have set my DPI and enlarged my default font size, 
webpages that specify font sizes in pixels have unreadably small fonts.  Also, 
fixed-width tables and images are still too small.

IE6 has implemented a solution for this which works very well.  If a registry 
key is set, IE6 scales all px units so that objects on screen will appear the 
same size as on a 96 dpi display.  Thus on a 170 dpi display, a 250x250 image 
is scaled to (170/96)*250 = 443x443 pixels.  Font sizes are increased 
similarly, even (especially) when the size is specified in pixels.  So are 
fixed-width tables, and everything else specified in pixels too.  This has the 
effect of making objects a usable size while preserving correct layout.  I'd 
like to see this feature implemented in Mozilla as an optional switch.

Comment 1

16 years ago
similar: bug 102755
Duplicate of "Page Zoom"

*** This bug has been marked as a duplicate of 112018 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.