Drag and drop addresses from the contact pane will drop in the middle of existing address

RESOLVED DUPLICATE of bug 1267804
(NeedInfo from)

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 1267804
3 years ago
2 years ago

People

(Reporter: Matt, Unassigned, NeedInfo)

Tracking

Trunk
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Steps to reproduce:"

Open write window and insert an address. (how is not relevant)
Drag an address from the contact pane and drop over the existing address

Result: 
Dropped text is inserted at some insertion point set by the location in the middle of the existing text

Expected Result
Correct insertion of the address, either by adding a new entry / Entries or by inserting on the end of the existing text with a leading comma.

Bug 440376 - Drag and drop from "Contacts" pane to already populated address text field causes problems has been around since 2008.  but this is a different bug IMO

I suggest we either fix the behaviour or disable drag and drop as suggested by Wayne mery on Bug 440376
(Reporter)

Updated

3 years ago

Comment 1

2 years ago
Hello, I get the same bug in new version 45.0
But then I drag and drop on empty field "To" address is breaking in the middle.
This bug reproduced only if cursor focused on this field.

Comment 2

2 years ago
Created attachment 8748682 [details]
On drag with focus.png

Example drag address with focus on field "To" which cause the bug

Comment 3

2 years ago
Created attachment 8748683 [details]
On drop with focus.png

Incorrect insert after drag and drop address with focus on field "To"

Comment 4

2 years ago
Created attachment 8748686 [details]
On drag without focus.png

Drag address without focus on field "To"

Comment 5

2 years ago
Created attachment 8748687 [details]
On drop without focus.png

Correct insert after drag and drop without focus on field "To"

Comment 7

2 years ago
Matt do you agree this is a dupe? Can you confirm it is fixed in TB45.1?
Flags: needinfo?(unicorn.consulting)

Comment 8

2 years ago
For me it is fixed in TB45.1

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1267804
You need to log in before you can comment on or make changes to this bug.