Closed Bug 1142921 Opened 5 years ago Closed 4 years ago

[RTL][E.me Integration]Search keywords in Rokectbar for the first time, the texts are left-aligned in prompt message box.

Categories

(Firefox OS Graveyard :: Gaia::Search, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.2 affected, b2g-master affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: yulan.zhu, Unassigned)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

Attached image Prompt message.png
[1.Description]:
[RTL][v2.2&V3.0][E.me Integration]Search keywords in Rokectbar for the first time, the texts are left-aligned in prompt message box.
See attachment:Prompt message.png

[2.Testing Steps]: 
1.Set your phone language to Arabic and connect the network.
2.Type more than 3 characters in Rocketbar for the first time.

[3.Expected Result]: 
2.The text in prompt message should be right-aligned.

[4.Actual Result]: 
2.The texts are left-aligned in prompt message box.

[5.Reproduction build]: 
Flame 2.2 build(Affected):
Build ID               20150312002501
Gaia Revision          572d60e0a440ee4af50bc6b6adad8876eadbdb4d
Gaia Date              2015-03-12 01:29:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/244e6ba3c20e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150312.040315
Firmware Date          Thu Mar 12 04:03:26 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build(Affected):
Build ID               20150312160232
Gaia Revision          eabe35cf054d47087b37c1ca7db8143717fbd7f3
Gaia Date              2015-03-12 18:01:49
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/42afc7ef5ccb
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150312.194521
Firmware Date          Thu Mar 12 19:45:32 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,3/3

[7.TCID]: 
15683
QA Whiteboard: [rtl-impact]
Whiteboard: [systemsfe]
Component: Gaia::Everything.me → Gaia::Search
Priority: -- → P2
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15683/
Flags: in-moztrap+
According to the STR in comment 0, the problem is verified not happen in latest Flame 2.2&3.0, N5 2.2&3.0 build.
if anyone can repro it, reopen again.

See attachment:Verify1_Flame 2.2&3.0_N5 2.2&3.0_Pass.png
Reproducing rate:0/5

Device: Flame 2.2 (Unaffected)
Build ID               20150429002501
Gaia Revision          1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gaia Date              2015-04-28 19:36:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d38ff4717f39
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.035717
Firmware Date          Wed Apr 29 03:57:29 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (Unaffected)
Build ID               20150429010205
Gaia Revision          6e35b0948c42a4398b8a5916015de167121683a1
Gaia Date              2015-04-28 16:06:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1ad65cbeb2f4
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.043837
Firmware Date          Wed Apr 29 04:38:48 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (Unaffected)
Build ID               20150429002501
Gaia Revision          1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gaia Date              2015-04-28 19:36:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d38ff4717f39
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150429.040217
Firmware Date          Wed Apr 29 04:02:34 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (Unaffected)
Build ID               20150429010205
Gaia Revision          6e35b0948c42a4398b8a5916015de167121683a1
Gaia Date              2015-04-28 16:06:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1ad65cbeb2f4
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150429.044325
Firmware Date          Wed Apr 29 04:43:46 EDT 2015
Bootloader             HHZ12f
Status: NEW → RESOLVED
Closed: 4 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.