[RTL][Notifications]The time of message, calendar and bluetooth notification is right-aligned in Notifications view.

VERIFIED FIXED in Firefox OS v2.2

Status

P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yulan.zhu, Assigned: mikehenrty)

Tracking

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[RTL][v2.2&v3.0][Notifications]The time of the message, calendar and bluetooth notification is right-aligned in Notifications view.
See attachment:

[2.Testing Steps]: 
1.Set your phone language to Arabic and insert one SIM card in device.
2.Recieve a message,  new an event and recieve the notification, and recieve file via bluetooth from paired device.
3.Observe the time of the prompt message on Notifications.

[3.Expected Result]: 
3.The time should be left-aligned.

[4.Actual Result]: 
3.The time is right-aligned.

[5.Reproduction build]: 
Flame 2.2 build(Affected):
Build ID               20150312002501
Gaia Revision          572d60e0a440ee4af50bc6b6adad8876eadbdb4d
Gaia Date              2015-03-12 01:29:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/244e6ba3c20e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150312.040315
Firmware Date          Thu Mar 12 04:03:26 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build(Affected):
Build ID               20150312160232
Gaia Revision          eabe35cf054d47087b37c1ca7db8143717fbd7f3
Gaia Date              2015-03-12 18:01:49
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/42afc7ef5ccb
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150312.194521
Firmware Date          Thu Mar 12 19:45:32 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
15559
(Reporter)

Comment 1

4 years ago
Created attachment 8577159 [details]
Notifications.png
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact]
This is a Gaia::System issue.
blocking-b2g: --- → 2.2?
Component: Gaia::SMS → Gaia::System

Updated

4 years ago
Whiteboard: [systemsfe]
Yoink.
Assignee: nobody → mhenretty
blocking-b2g: 2.2? → 2.2+
Priority: -- → P2
Caused by bug 1134453.
Blocks: 1134453
Created attachment 8578356 [details] [review]
[gaia] mikehenrty:bug-1142925-notification-auto-dir > mozilla-b2g:master
Comment on attachment 8578356 [details] [review]
[gaia] mikehenrty:bug-1142925-notification-auto-dir > mozilla-b2g:master

The problem was that the dir="auto" on the notification title container was causing the flex-direction to reverse the ordering of the timestamp and title when discovering the LTR text inside the title. Since the workaround we added in bug 1134453 (for longstanding bug 922963) only had to do with actual title text, I put the dir="auto" there instead. I also added a comment on the css override we need for making sure the text aligns right in these cases.

Guillaume, you worked on bug 1134453, what do you think of this solution?
Attachment #8578356 - Flags: review?(gmarty)
Comment on attachment 8578356 [details] [review]
[gaia] mikehenrty:bug-1142925-notification-auto-dir > mozilla-b2g:master

Looks good to me. Other notifications type don't have the time so they're not affected.
Attachment #8578356 - Flags: review?(gmarty) → review+
Comment on attachment 8578356 [details] [review]
[gaia] mikehenrty:bug-1142925-notification-auto-dir > mozilla-b2g:master

Etienne, you reviewed bug 1134453. Can you do a super review here?
Attachment #8578356 - Flags: review?(etienne)
Comment on attachment 8578356 [details] [review]
[gaia] mikehenrty:bug-1142925-notification-auto-dir > mozilla-b2g:master

stamp
Attachment #8578356 - Flags: review?(etienne) → review+
master: https://github.com/mozilla-b2g/gaia/commit/73d838c74b771361bd36dce9c4e2d2ecf2a0dd2e
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-master: affected → fixed
Resolution: --- → FIXED
Comment on attachment 8578356 [details] [review]
[gaia] mikehenrty:bug-1142925-notification-auto-dir > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
bug 1134453 

[User impact] if declined:
Visuals in the utility tray won't follow spec in RTL.

[Testing completed]:
Manual verification, updated unit test.

[Risk to taking this patch] (and alternatives if risky):
CSS only change, low risk.

[String changes made]: none.
Attachment #8578356 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8578356 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/4982a4fe51285ee124d6beacd1204982b137f66a
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S8 (20mar)
Keywords: verifyme
(Reporter)

Comment 13

4 years ago
Created attachment 8581412 [details]
Verify1_Flame2.2_Pass.png

This issue has been verified successfully on latest Flame 2.2 & 3.0 build.
See attachments: Verify1_Flame2.2_Pass.png & Verify1_Flame3.0_Pass.png.
Reproduce rate:0/10

Flame 2.2 build:
Build ID               20150322002503
Gaia Revision          44c62060581fde8de1e12e94cf55e9673b401a47
Gaia Date              2015-03-20 19:05:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e6140a32902a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150322.043216
Firmware Date          Sun Mar 22 04:32:27 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150322160204
Gaia Revision          9b6f3024e4d0e62dd057231f4b14abe1782932ab
Gaia Date              2015-03-22 10:09:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e730012260a4
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150322.192413
Firmware Date          Sun Mar 22 19:24:22 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Comment 14

4 years ago
Created attachment 8581413 [details]
Verify1_Flame3.0_Pass.png
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
(Reporter)

Updated

4 years ago
Keywords: verifyme
Duplicate of this bug: 1142436
You need to log in before you can comment on or make changes to this bug.