If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Audio distorted when playing multiple BufferSources

RESOLVED DUPLICATE of bug 926838

Status

()

Core
Web Audio
RESOLVED DUPLICATE of bug 926838
3 years ago
3 years ago

People

(Reporter: KompjoeFriek, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec41+)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524
Firefox for Android

Steps to reproduce:

Visit: http://chromium.googlecode.com/svn/trunk/samples/audio/shiny-drum-machine.html
Press play to start the shiny drum machine.


Actual results:

Audio is heavily distorted.


Expected results:

Audio should be a nice drum pattern. (just like on the desktop version of FireFox)
(Reporter)

Updated

3 years ago
OS: Windows 7 → Android
Hardware: x86_64 → ARM
(Reporter)

Updated

3 years ago
Component: Untriaged → Audio/Video
Product: Firefox → Firefox for Android
Version: 34 Branch → Firefox 34

Updated

3 years ago
Component: Audio/Video → Web Audio
Product: Firefox for Android → Core
Version: Firefox 34 → unspecified
Can you test out Nightly and report back if that works better for you (http://nightly.mozilla.org) for Android
Flags: needinfo?(roel)
(Reporter)

Comment 2

3 years ago
Audio in Nightly for Android also sounds distorted.
Flags: needinfo?(roel)
Confirmed on nightly 39.0
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
This is because of the Convolver, duping this one against the bug where the work is being done. This has been delayed because of licensing issues, but we are getting those resolved so we will be able to move forward.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 926838
Martin - This seems like a games issue. Should we bump priority for getting bug 926838 addressed?
Flags: needinfo?(mbest)

Updated

3 years ago
Blocks: 710398
Flags: needinfo?(mbest)

Comment 6

3 years ago
Yeah we should likely get this addressed sooner than later.

Comment 7

3 years ago
Johnny, who should we be looking to for WebAudio work and optimizations?  I know Paul is on it but I also know we had some new resources coming online to help with this API?
Flags: needinfo?(jst)
baku and qDot have expressed interest in helping improve on our WebAudio implementation.
Flags: needinfo?(jst)
Martin, jst, this is blocked on licensing issues, the patches are actually up in the bug, and will need minimal rebasing before landing, I guess.
Also (to add to what padenot said), Gerv is actively working those licensing issues on a separate bug.

Currently padenot and baku are actively working on web audio. I talked with Anthony (k17e), and a couple of NZ folks who already know web audio (e.g. karlt) will likely be freeing up soon to help me, padenot and baku now that MSE/EME are getting ready to ship.   I should have a better idea of who from NZ in a couple of weeks.

If there is anyone else available in Q2 to help with web audio, please have them reach out to me directly.  We're happy to have the help.

FYI: Padenot has been marking web audio bugs with the keyword "perf" to call out the bugs that will improve our web audio performance. We're starting to attack those.  In addition, we'll be adding support for audio workers in Q2.
tracking-fennec: ? → 41+
You need to log in before you can comment on or make changes to this bug.