Perpetual assertion with Firefox Developer Tools Adapters makes debug Win builds unusuable

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: jimm, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
STR:

1) check out mc tip
2) install Firefox Developer Tools Adapters if they aren't already installed
3) try to run a debug build on windows

You get an endless stream of assertions on startup:

[3404] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file f:\Mozilla\mc\netwerk\base\nsIOService.cpp, line 680
[3404] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
[3404] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289

with the channel failure caused by a badly formatted uri:

nsACString_internal = {mData=0x06a4c428 "resource://node_modules/resource:/gre/modules/Preferences.jsm/package.json" mLength=...}
(Reporter)

Comment 1

3 years ago
reproducible in single process mode as well.
Flags: needinfo?(dcamp)

Comment 2

3 years ago
Panos, you know what's going on here?
Flags: needinfo?(dcamp)
I'll look into it tomorrow.
Assignee: nobody → past
Status: NEW → ASSIGNED
I can't reproduce it today on OS X. Can you verify that you still see this on the latest m-c tip with Valence 0.2.5 installed?

Building and testing on my Windows VM takes a while, but I'll investigate if you can still reproduce it.
Flags: needinfo?(jmathies)
(Reporter)

Comment 5

3 years ago
seems to have been fixed, I can't reproduce on tip.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jmathies)
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

3 years ago
Sorry, I had disabled that addon. Still able to reproduce -

[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:\Mozilla\mc\netwerk\base\nsIOService.cpp, line 680
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:\Mozilla\mc\netwerk\base\nsIOService.cpp, line 680
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:\Mozilla\mc\netwerk\base\nsIOService.cpp, line 680
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:\Mozilla\mc\netwerk\base\nsIOService.cpp, line 680
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:\Mozilla\mc\netwerk\base\nsIOService.cpp, line 680
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:\Mozilla\mc\netwerk\base\nsIOService.cpp, line 680
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:\Mozilla\mc\netwerk\base\nsIOService.cpp, line 680
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:\Mozilla\mc\netwerk\base\nsIOService.cpp, line 680
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
[1464] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x804B000A: file f:/Mozilla/mc/netwerk/protocol/res/nsResProtocolHandler.cpp, line 289
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Sadly I haven't found the time to look at this yet, and it's unlikely I'll be able to in the near future.
Assignee: past → nobody
I couldn't reproduce this against current tip, so it looks to me like it's gone (which is likely enough considering how much has changed in devtools since 11 months ago). Jim, are you still seeing this?
Component: General → Developer Tools
Flags: needinfo?(jmathies)
(Reporter)

Comment 9

2 years ago
Haven't seen this in a while.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Flags: needinfo?(jmathies)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.