Closed Bug 1142989 Opened 7 years ago Closed 7 years ago

[e10s] Re-enable some bookmarks related tests

Categories

(Firefox :: Bookmarks & History, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 39
Tracking Status
e10s + ---
firefox39 --- fixed

People

(Reporter: enndeakin, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached patch Enable testsSplinter Review
These eight tests seem to work fine.

 browser_475045.js
 browser_410196_paste_into_tags.js
 browser_history_sidebar_search.js
 browser_bookmarksProperties.js
 browser_555547.js
 browser_416459_cut.js
 browser_435851_copy_query.js
 browser_toolbarbutton_menu_context.js


Let's re-enable them.
Attachment #8577242 - Flags: review?(mano)
Comment on attachment 8577242 [details] [diff] [review]
Enable tests

Review of attachment 8577242 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/places/tests/browser/browser.ini
@@ -23,5 @@
>  [browser_library_open_leak.js]
>  [browser_library_panel_leak.js]
>  [browser_library_search.js]
>  [browser_history_sidebar_search.js]
> -skip-if = e10s && (os == 'linux' || os == 'mac') # Bug 1116457

bug 1116457 is still open and was disabled not much time ago, I'm not very confident about re-enabling it., unless you figured that another bug solved the issues we were hitting here.
(In reply to Marco Bonardo [::mak] from comment #2)
> Comment on attachment 8577242 [details] [diff] [review]
> Enable tests
> 
> Review of attachment 8577242 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: browser/components/places/tests/browser/browser.ini
> @@ -23,5 @@
> >  [browser_library_open_leak.js]
> >  [browser_library_panel_leak.js]
> >  [browser_library_search.js]
> >  [browser_history_sidebar_search.js]
> > -skip-if = e10s && (os == 'linux' || os == 'mac') # Bug 1116457
> 
> bug 1116457 is still open and was disabled not much time ago, I'm not very
> confident about re-enabling it., unless you figured that another bug solved
> the issues we were hitting here.

Ah, I meant to leave that one as is.
Comment on attachment 8577242 [details] [diff] [review]
Enable tests

Review of attachment 8577242 [details] [diff] [review]:
-----------------------------------------------------------------

ok, r=me if you leave that test alone.
Attachment #8577242 - Flags: review?(mano) → review+
Blocks: e10s-tests
tracking-e10s: --- → +
https://hg.mozilla.org/mozilla-central/rev/9b00b7748955
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 39
You need to log in before you can comment on or make changes to this bug.