HTML5 video mp4-file is no more played after update to vers 36.1, Vers. 35 was ok

RESOLVED WONTFIX

Status

()

Core
Audio/Video: Playback
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: bernhard.gaul, Unassigned)

Tracking

({testcase})

36 Branch
x86
Windows 7
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-opera], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8577312 [details]
Errormessage, because the MP4-File is not played

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

I'm a webmaster. I've following Code in the site
<video  controls autoplay>
  <source src='lokalergpxdemo.mp4' type='video/mp4'/>
</video> 

Bevor Update FF to Vers. 36.1, the video was played


Actual results:

in IE, Chrome and Opera the Video is played too.

In FF 36.1 there is coming an error-Message
"Kein Video mit unterstuetztem Format und MIME-Typ gefunden"
Look at the attached PNG-File.

With the Path above the video runs in all other browsers.


Expected results:

The Video should run like in Vers. 35
(Reporter)

Comment 1

3 years ago
In the meantime I ask with PHP for Firefox and use only for FF the Flash-Player.
Thank you for your works.
(Reporter)

Comment 2

3 years ago
look at my testsites:
the ogg and webm format is supportet

http://www.bernhard-gaul.de/tests/video-ogg-webm.html

the mp4-format is no more supported since the new update to vers. 36, vers. 35 was supportet

http://www.bernhard-gaul.de/tests/video-mp4.html

Why is the mp4 format no longer supportedt in Vers 36 ???

Thank you

Thank you

Comment 3

3 years ago
This defect is reproducible with the mentioned defect steps.
I created a html page with .mp4 video.
When the html file was loaded in Firefox it didn't played the video.
An error message is shown "No Video with supported format and MME type found."

Comment 4

3 years ago
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150422030206

(In reply to bernhard.gaul from comment #0)
> in IE, Chrome and Opera the Video is played too.

It plays in Opera 28, but not in IE11, which displays the error message, “Invalid Source”.
Status: UNCONFIRMED → NEW
Component: Untriaged → Video/Audio
Ever confirmed: true
Keywords: regression, regressionwindow-wanted
Product: Firefox → Core

Comment 5

3 years ago
(In reply to bernhard.gaul from comment #0)
> The Video should run like in Vers. 35

I just tested Firefox 35, 34, 33, 22, and 21, and none can play the video. Please test Firefox 35.0 in a brand new profile and report the results.
https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/35.0/win32/en-US/
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(bernhard.gaul)
Keywords: regression, regressionwindow-wanted → testcase
Whiteboard: [parity-opera]
Component: Audio/Video → Audio/Video: Playback
The file is mpeg4 part 2 which is not supported.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX

Updated

2 years ago
Flags: needinfo?(bernhard.gaul)
You need to log in before you can comment on or make changes to this bug.