Closed Bug 1143178 Opened 5 years ago Closed 5 years ago

https://www.creatroninc.com ssl_error_no_cypher_overlap

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mikeh, Unassigned)

References

Details

+++ This bug was initially created as a clone of Bug #1141580 +++

Running Firefox Developer Edition 38.0a2 (2015-03-06) "Mozilla Firefox for Ubuntu canonical - 1.0"
If someone can (tell me how to) verify that this site is using RC4, I'm happy to reach out to the owner.
Flags: needinfo?(davemgarrett)
I'll check since I work for them
With any luck, I'll hear back from them soon.
For diagnosing these types of server issues, I've been recommending the use of Qualys SSL Labs Server Test. There are other scans that can work, but this is easy to use and sufficiently thorough for what we need it for.

https://www.ssllabs.com/ssltest

Just load up the test, type/paste in a domain name, hit submit, and wait a while until it's done. You can paste the test results URL into the bug in question for others to see. (it is cached for a bit, but if it's stale it'll just re-run the tests)

https://www.ssllabs.com/ssltest/analyze.html?d=creatroninc.com

In this case we're concerned with cipher support, so you can scroll down to that section. For this domain:

TLS_ECDHE_RSA_WITH_RC4_128_SHA (0xc011)
TLS_RSA_WITH_RC4_128_SHA (0x5)
TLS_RSA_WITH_CAMELLIA_256_CBC_SHA (0x84)
TLS_RSA_WITH_CAMELLIA_128_CBC_SHA (0x41)

Camellia was only ever really supported by Mozilla, and support has long since been removed completely. The only other two ciphers available are RC4, so this site is effectively RC4-only.
Flags: needinfo?(davemgarrett)
OS: Linux → All
Hardware: x86_64 → All
> Server hostname 	173-254-94-85.unifiedlayer.com 
Yet another bluehost/hostmonster/unifiedlayer instance...
(In reply to Masatoshi Kimura [:emk] from comment #5)
> Yet another bluehost/hostmonster/unifiedlayer instance...

I think we should start filing bugs for host providers instead of just sites and see if someone can get into direct contact with them. Even if they're not set up to manage their clients' TLS configurations, they could at least contact all of their clients to provide instructions on how to deal with things.
Flags: needinfo?(VYV03354)
Blocks: 1143254
(In reply to Dave Garrett from comment #6)
> I think we should start filing bugs for host providers instead of just sites
> and see if someone can get into direct contact with them. Even if they're
> not set up to manage their clients' TLS configurations, they could at least
> contact all of their clients to provide instructions on how to deal with
> things.

Makes sense. Filed bug 1143254.
Flags: needinfo?(VYV03354)
I'm running regular FF at the moment and I can log in to my Dashboard on the Skyword site with it. I'm going to give Nightly a try in the morning it's pretty late right now. I only discovered that I could login using FF because the company's support group replied to my email wondering what version of FF I was using so I had to close Nightly (which has been acting a bit weird with not responding more than usual) and open FF to check. It's version 37.0.
Confused the bug number? The skyword issue is tracked by bug 1141580.
Yep. Thanks.
Fixed.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Confirmed working on my end. Thanks!
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.