Disable new perf tool tests on linux until all the Linux EC2 slaves get updated and the crashes are fixed

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
2 months ago

People

(Reporter: vporof, Assigned: vporof)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Bug 1139386 is currently blocking us from shipping the new perf tool into m-c. Since the problem is known and worked on, there's no reason to delay a merge because of current ongoing kernel updates. 

This bug is about temporarily disabling these tests until the crashes are sorted out, so that we can merge gum into fx-team and m-c.
(Assignee)

Comment 1

4 years ago
Created attachment 8577478 [details] [diff] [review]
v1
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Attachment #8577478 - Flags: review?(kvijayan)
Comment on attachment 8577478 [details] [diff] [review]
v1

Review of attachment 8577478 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/performance/test/browser.ini
@@ +1,2 @@
>  [DEFAULT]
> +skip-if = e10s || os == "linux" # Bug 1077464, Bug 1143188

Does this change only target Linux 32-bit or does it hit linux 64-bit as well?  If I understand correctly, the kernel bug is only present on 32-bit linux, right?
(Assignee)

Comment 3

4 years ago
Linux 32 bit only. AFAIK there's no way to target only that configuration with skip-if.
(Assignee)

Comment 4

4 years ago
Turns out we don't have to do this anymore
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
Comment on attachment 8577478 [details] [diff] [review]
v1

Review of attachment 8577478 [details] [diff] [review]:
-----------------------------------------------------------------

Cancelling review as this no longer seems necessary.
Attachment #8577478 - Flags: review?(kvijayan)

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.