Closed Bug 1143199 Opened 7 years ago Closed 7 years ago

[Private Browsing] Update Button String

Categories

(Firefox OS Graveyard :: Gaia::System::Browser Chrome, defect)

x86
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S8 (20mar)
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: epang, Assigned: kgrandon)

References

Details

(Keywords: late-l10n, Whiteboard: [systemsfe])

Attachments

(2 files)

Update the Private Browsing button's string on the start page to 'New private window'.
Comment on attachment 8577499 [details] [review]
[gaia] KevinGrandon:bug_1143199_pb_browser_label > mozilla-b2g:master

Mike - any chance you could give me a quick review stamp here?
Attachment #8577499 - Flags: review?(mhenretty)
Comment on attachment 8577499 [details] [review]
[gaia] KevinGrandon:bug_1143199_pb_browser_label > mozilla-b2g:master

Sorry, was on PTO last Friday. Would this be considered late l10n?
Attachment #8577499 - Flags: review?(mhenretty) → review+
(In reply to Michael Henretty [:mhenretty] from comment #3)
> Comment on attachment 8577499 [details] [review]
> [gaia] KevinGrandon:bug_1143199_pb_browser_label > mozilla-b2g:master
> 
> Sorry, was on PTO last Friday. Would this be considered late l10n?

Thanks for the review. I think so, though we do already have this string in the system app already. In any case I'll land in master and see about getting it uplifted.
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Component: Gaia::Browser → Gaia::System::Browser Chrome
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8577499 [details] [review]
[gaia] KevinGrandon:bug_1143199_pb_browser_label > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Polish for private browsing as it is a new feature.
[User impact] if declined: Slight UX papercut.
[Testing completed]: Manual testing.
[Risk to taking this patch] (and alternatives if risky): Low risk. This is only changing a single small string. The same string is used in another app, and we are updating this for consistency/polish.
[String changes made]: Yes.
Attachment #8577499 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8577499 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Attached image Verified_Flame_v2.2.png
This bug has been verified as pass on latest build of Flame v2.2 & master and Nexus 5 v2.2 & master by the STR in Comment 0. 

Results:
Private Browsing button's string on the start page of Browser is 'New private window'.

See attachment: Verified_Flame_v2.2.png
Reproduce rate: 0/10

Device: Flame v2.2(Verified)
Build ID               20150714162501
Gaia Revision          84d0c76370dcd3d25813b00de55194730884355b
Gaia Date              2015-07-09 13:09:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a5db6d9850f6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150714.200955
Firmware Date          Tue Jul 14 20:10:07 EDT 2015
Bootloader             L1TC000118D0

Device: Flame master(Verified)
Build ID               20150714160203
Gaia Revision          803d04e3829fd4fe9261211aa0ddca6b79d4e328
Gaia Date              2015-07-14 17:54:44
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d5025c151d17
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150714.193145
Firmware Date          Tue Jul 14 19:31:57 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus5 v2.2 (Verified)
Build ID               20150714162501
Gaia Revision          84d0c76370dcd3d25813b00de55194730884355b
Gaia Date              2015-07-09 13:09:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a5db6d9850f6
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150714.195038
Firmware Date          Tue Jul 14 19:50:54 EDT 2015
Bootloader             HHZ12f

Device: Nexus5 master (Verified)
Build ID               20150714160203
Gaia Revision          803d04e3829fd4fe9261211aa0ddca6b79d4e328
Gaia Date              2015-07-14 17:54:44
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d5025c151d17
Gecko Version          42.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150714.194243
Firmware Date          Tue Jul 14 19:43:01 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.