[Private Browsing] Update the private browsing start page

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: epang, Assigned: kgrandon)

Tracking

unspecified
2.2 S9 (3apr)
x86
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Update the starting page of private browser.

I've updated the spec on page 14.  (Previously it was a dialogue)

https://mozilla.box.com/s/fanxlaw7ilhm0walsod6hy4ps47v9eh3
(Assignee)

Comment 2

4 years ago
Eric - could you look at this when you get a chance? This is a screenshot of the implementation on a flame. I had trouble matching up the sizing with the PDF, so some of the sizing might be a bit off (I'm not sure if the font is the same from the spec to the device).

Let's just focus on the content of this page here (under rocketbar), and we can tweak the rocketbar UI in the other bugs. Let me know if anything is off, and how much you'd like me to adjust it by. Thanks!
Attachment #8578732 - Flags: ui-review?(epang)
(Assignee)

Updated

4 years ago
Depends on: 1144235
(Reporter)

Comment 3

4 years ago
Comment on attachment 8578732 [details]
Screenshot of implementation (flame)

Looks good to me :).  Thanks Kevin! R+
Attachment #8578732 - Flags: ui-review?(epang) → ui-review+
(Assignee)

Comment 4

4 years ago
The current Private Browsing experience is a pretty poor experience. This is a minor patch which significantly improves it. I wouldn't recommend shipping the current experience as-is, but since uplifting this is a much lower risk than disabling the feature, I suggest blocking on this.
blocking-b2g: --- → 2.2?
(Assignee)

Updated

4 years ago
Component: Gaia::Browser → Gaia::System::Browser Chrome
(Assignee)

Comment 5

4 years ago
Comment on attachment 8578728 [details] [review]
[gaia] KevinGrandon:bug_1143203_pb_splash_page > mozilla-b2g:master

Since this is only styling, I think we're good with the ui-review here. Thanks!
Attachment #8578728 - Flags: review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Major improvement.
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 7

4 years ago
Some problems with autolander today, retrying.
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

4 years ago
Comment on attachment 8578728 [details] [review]
[gaia] KevinGrandon:bug_1143203_pb_splash_page > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature implementation.
[User impact] if declined: Poor UX of new feature.
[Testing completed]: Manual testing (visual changes only).
[Risk to taking this patch] (and alternatives if risky): Low risk, only visual changes for private browsing.
[String changes made]: None (although a string was removed, if desired we can undo that for 2.2)
Attachment #8578728 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8578728 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is verified fixed in the latest Nightly Flame 3.0 build.

Actual Results: The new Private browsing start page looks like the template posted in comment 0

Environmental Variables:
Device: Flame 3.0
BuildID: 20150325083046
Gaia: aebfbd998041e960cea0468533c0b5041b504850
Gecko: db0409de517a
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Comment 13

4 years ago
Oops, I forgot about the dependency on bug 1144235. I've request uplift on bug 1144235 and that should fix the gaia build issues.
Flags: needinfo?(kgrandon)
This bug has been successfully verified on latest Nightly Flame v2.2.

Actual Results: The new Private browsing start page is same as the template in Comment 0.

See attachment: verified_v2.2(Privatebrowsing_start_page).png
Reproduce rate: 0/5.

Device: Flame 2.2 build(Pass)
Build ID               20150327162502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b358619def45
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.194944
Firmware Date          Fri Mar 27 19:49:53 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.