Closed Bug 1143206 Opened 7 years ago Closed 7 years ago

[Private Browsing] Sheets displaying incorrect icon/text

Categories

(Firefox OS Graveyard :: Gaia::System::Browser Chrome, defect)

x86
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 unaffected, b2g-v2.1S unaffected, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S8 (20mar)
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.1S --- unaffected
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: epang, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

Hi Kevin,

Francis and I tested this today but both saw different things.  Can you help check that the Private browsing (mask) icon shows up onto of the text? 

Also, can we reduce the font weight but one step?  It's looking a little heavy.

Thanks!
Attached image 2015-03-13-23-01-42.png
here's what I saw when testing
Component: Gaia::Browser → Gaia::System::Browser Chrome
Comment on attachment 8577805 [details] [review]
[gaia] KevinGrandon:bug_1143206_pb_identification_overlay > mozilla-b2g:master

Etienne or Alive - could either of you review this for me?

The problem is that the private browsing app window is initially set to an app:// origin, then changes to a http:// origin when the user navigates somewhere. It's causing a few headaches, so in the future I think we might want to consider using static HTML in the system instead of an iframe for the landing page. Let me know what you think, thanks!
Attachment #8577805 - Flags: review?(etienne)
Attachment #8577805 - Flags: review?(alive)
Comment on attachment 8577805 [details] [review]
[gaia] KevinGrandon:bug_1143206_pb_identification_overlay > mozilla-b2g:master

r=me
Attachment #8577805 - Flags: review?(alive) → review+
Attachment #8577805 - Flags: review?(etienne)
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8577805 [details] [review]
[gaia] KevinGrandon:bug_1143206_pb_identification_overlay > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature implementation.
[User impact] if declined: Poor UX when using edge gestures + private browsing.
[Testing completed]: Manual and unit testing.
[Risk to taking this patch] (and alternatives if risky): Low risk, small change to private browsing feature.
[String changes made]: None.
Attachment #8577805 - Flags: approval-gaia-v2.2?(bbajaj)
Comment on attachment 8577805 [details] [review]
[gaia] KevinGrandon:bug_1143206_pb_identification_overlay > mozilla-b2g:master

approving this low risk change given private browsing is new in 2.2
Attachment #8577805 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
(In reply to Eric Pang [:epang] from comment #0)
> Also, can we reduce the font weight but one step?  It's looking a little
> heavy.

Oops - the patch here missed that detail. I'm filing another follow-up bug for it and will block the meta bug.
You need to log in before you can comment on or make changes to this bug.