[Tab View/Task Manager] SSL Lock looks too small and text alignment needs to be updated

VERIFIED FIXED in Firefox OS v2.2

Status

VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: epang, Assigned: sfoster)

Tracking

({polish})

unspecified
2.2 S9 (3apr)
x86
Gonk (Firefox OS)
polish

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 8577498 [details]
2015-03-13-23-02-02.png

Hey Sam,

There's something odd going on with the ssl lock (I'm pretty sure it was fine before). This effects both the task manager and tab view (found when testing private browsing).

Can you check if the correct icons are being used? 
https://mozilla.box.com/s/3l26suxa00ci2bhktvk2wi1rscr3cf39

Also a few other changes needed:

1. The lock and icon should be centered in the space available.  Right now it's looking right aligned

2. The URL should be italicized

let me know if you have any questions, thanks!
Keywords: polish
(Assignee)

Comment 1

4 years ago
Eric, can you annotate the screenshot or point out the problem? I'm not clear what the issue is in the attachment #8577498 [details]
Flags: needinfo?(epang)
(Reporter)

Comment 2

4 years ago
Created attachment 8581638 [details]
taskmanager.jpg

Hey Sam,

Sorry I was in a rush when filing the bugs.  I've attached an image that goes into more detail (found a few out adjustments needed).

Let me know if you have any questions!
Thanks!
Flags: needinfo?(epang) → needinfo?(sfoster)
Created attachment 8583496 [details] [review]
[gaia] sfoster:task-manager-subtitle-tweak-bug-1143214 > mozilla-b2g:master
(Assignee)

Comment 4

4 years ago
Created attachment 8583497 [details]
task-manager-subtitle.png

Turns out the ssl lock icon asset has some padding around it and we were scaling it down. I got that fixed and I think the alignment, italic, colors etc. This shows task-manager, tab-view, RTL side-by-side
Flags: needinfo?(sfoster)
Attachment #8583497 - Flags: ui-review?(epang)
(Assignee)

Comment 5

4 years ago
Comment on attachment 8583496 [details] [review]
[gaia] sfoster:task-manager-subtitle-tweak-bug-1143214 > mozilla-b2g:master

Some CSS tweaks to the lock icon and subtitle for cards in task-manager & tab view
Attachment #8583496 - Flags: review?(etienne)
(Assignee)

Comment 6

4 years ago
Comment on attachment 8583496 [details] [review]
[gaia] sfoster:task-manager-subtitle-tweak-bug-1143214 > mozilla-b2g:master

Adding Kevin as Etienne is kinda on PTO apparently. 
I'm out on PTO myself until next week. Could I ask one of you to see this lands and nominate this for 2.2 if it gets r+ and ui-review+? I'm not sure if it will make the cut but I'm sure Eric would like me to try and its super-low risk?
Attachment #8583496 - Flags: review?(etienne) → review?(kgrandon)
Comment on attachment 8583496 [details] [review]
[gaia] sfoster:task-manager-subtitle-tweak-bug-1143214 > mozilla-b2g:master

stamp :)
Attachment #8583496 - Flags: review?(kgrandon) → review+
(Reporter)

Comment 8

4 years ago
Comment on attachment 8583497 [details]
task-manager-subtitle.png

Looks good, thanks Sam :)
Attachment #8583497 - Flags: ui-review?(epang) → ui-review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

4 years ago
Comment on attachment 8583496 [details] [review]
[gaia] sfoster:task-manager-subtitle-tweak-bug-1143214 > mozilla-b2g:master

[Approval Request Comment]
This is a polish/paper-cut bug with task manager. UI is functional without but its a v. low risk, CSS only patch we would like to get into v2.2 if possible

[Bug caused by] (feature/regressing bug #): Task Manager
[User impact] if declined: Lock icon is small, sub-title (URL) is not correctly aligned. Text color is low-contrast. 
[Testing completed]: Tested on device, UI reviewed
[Risk to taking this patch] (and alternatives if risky): V. low, CSS-only patch for polish issue
[String changes made]: None
Attachment #8583496 - Flags: approval-gaia-v2.2?
(Assignee)

Comment 11

4 years ago
Bhavana, is this on your radar?
Flags: needinfo?(bbajaj)
(In reply to Sam Foster [:sfoster] from comment #11)
> Bhavana, is this on your radar?

we need to stick to approving *blockers* alone at this time, so anything else will be out of my watch unless NI'ed. Given this came in right before FC and is super low risk, I am approving but will have to start minusing these requests from now on.
Flags: needinfo?(bbajaj)

Updated

4 years ago
Attachment #8583496 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S9 (3apr)
This bug has been verified as "pass" on the latest build of Flame v2.2&2.5&master and Aries KK v2.5&master.

STR:
1. View some websites in Browser/private browsing.
2. Enter Tab View/Task Manager.

Actual results: 
a. The sub-title/URL is italic and horizontally centered aligned. 
b. The color of the "Lock" icon and text is correctly. 
c. The "Lock" icon is not small and is suitable. 

See attachment: verified_Flame_master.png
Reproduce rate: 0/10


Device: Flame master_512mb (Pass)
Build ID               20151216150211
Gaia Revision          a84c2dbe672583914d04380cd61a56f1c60c3b8e
Gaia Date              2015-12-16 06:59:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0babaa3edcf908c393b68a3dc2d1c2a2450c31ed
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151216.185725
Firmware Date          Wed Dec 16 18:57:38 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK master (Pass)
Build ID               20151216115605
Gaia Revision          a84c2dbe672583914d04380cd61a56f1c60c3b8e
Gaia Date              2015-12-16 06:59:39
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/0babaa3edcf908c393b68a3dc2d1c2a2450c31ed
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151216.113143
Firmware Date          Wed Dec 16 11:31:51 UTC 2015
Bootloader             s1

Device: Flame 2.5_512mb (Pass)
Build ID               20151217001512
Gaia Revision          062e0fa48c1b5d5156f6911a5a4519128fac3231
Gaia Date              2015-12-11 15:06:09
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/fc571094879466cb3ae35bc3bb32a7832bbfcade
Gecko Version          44.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151216.232554
Firmware Date          Wed Dec 16 23:26:04 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20151217001840
Gaia Revision          062e0fa48c1b5d5156f6911a5a4519128fac3231
Gaia Date              2015-12-11 15:06:09
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/fc571094879466cb3ae35bc3bb32a7832bbfcade
Gecko Version          44.0
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151216.232744
Firmware Date          Wed Dec 16 23:27:52 UTC 2015
Bootloader             s1

Device: Flame 2.2_512mb (Pass) 
Build ID               20151216032502
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2120b3e6f680
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151216.072742
Firmware Date          Wed Dec 16 07:27:53 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
status-b2g-v2.5: --- → verified
status-b2g-master: fixed → verified
Created attachment 8699367 [details]
verified_Flame_master.png
You need to log in before you can comment on or make changes to this bug.