Scrolling on a Dailymotion video page is janky

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Mikel, Unassigned)

Tracking

Trunk
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150313030231

Steps to reproduce:

1) Open any DailyMotion video page.
2) Try to scroll the page via smooth scrolling or auto scrolling.
3) Observe the stutters and jank.

*Note: Observed the same behavior with and without the new HW vsync.


Actual results:

The scrolling is jerky.
The video content is jumping while scrolling the page.


Expected results:

The scrolling should be smooth.
The video content shouldn't jump while scrolling.
(Reporter)

Updated

3 years ago

Comment 1

3 years ago
Confirmed.
Only happens in Nightly.
The latest Firefox doesn't have this issue, only Nightly has it.

Also, it doesn't happen on Chrome or Internet Explorer!

It might be less noticeable if your PC is fast.
Please post your Graphic section from about:support.
Is it still reproducible if you set to "false" these 3 options in about:config?
-gfx.vsync.compositor
-gfx.vsync.hw-vsync.enabled
-gfx.vsync.refreshdriver
Flags: needinfo?(nissan4321)
Flags: needinfo?(nissan4321) → needinfo?(brandmairstefan)
Flags: needinfo?(nissan4321)
(Reporter)

Comment 3

3 years ago
Yes, even with these entries set to "false" I can see the stutter.

Graphics section from about:support:

Graphics
--------

Adapter Description: NVIDIA GeForce GTX 660 Ti
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM: 2048
Device ID: 0x1183
Direct2D Enabled: true
DirectWrite Enabled: true (6.3.9600.17415)
Driver Date: 2-5-2015
Driver Version: 9.18.13.4752
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 35561458
Vendor ID: 0x10de
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 660 Ti Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Flags: needinfo?(nissan4321)

Comment 4

3 years ago
Still happens
Flags: needinfo?(brandmairstefan)
Can you still reproduce the issue with clean new fresh profile without any addons and plugins?
Flags: needinfo?(nissan4321)
Flags: needinfo?(brandmairstefan)

Updated

3 years ago
Flags: needinfo?(brandmairstefan)
(Reporter)

Comment 6

3 years ago
Yes, and I have some new finding regarding this issue:
1) It happens *only* when the video is in the view port, i.e., scrolling at the bottom of the page is a lot smoother (or you can say, 100% smooth for the record).
2) It seems that when the video is in the view port (being at the top of page), scrolling the tab bar causes the video to be drawn completely blank.
the video restores upon a page scroll.

Hope this helps to identify the issue a bit better.
Flags: needinfo?(nissan4321)
I could reproduce on Nightly 40.0a1 3015-04-01 under Win 7 64-bit.
The Shockwave Flash plugin has crashed (not reproduced on another machine with AMD Radeon HD 5450).

Graphics
Adapter Description	Intel(R) HD Graphics
Adapter Drivers	igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
Adapter RAM	Unknown
Device ID	0x0152
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16440)
Driver Date	10-31-2013
Driver Version	10.18.10.3345
GPU #2 Active	false
GPU Accelerated Windows	3/3 Direct3D 11 (OMTC)
Subsys ID	00000000
Vendor ID	0x8086
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Status: UNCONFIRMED → NEW
Component: Untriaged → Plug-ins
Ever confirmed: true
Product: Firefox → Core
(Reporter)

Updated

2 years ago
Version: 39 Branch → Trunk

Comment 8

2 years ago
Can you still reproduce this? 
I'm not able to with nightly build, new profile, Intel HD 3000 graphics. 
(I also could try NVDIA quadro)
Flags: needinfo?(nissan4321)
(Reporter)

Comment 9

2 years ago
Unable to reproduce the issue with the latest Nightly.
It seems like the site isn't using flash player anymore, so the issue can be closed.
Flags: needinfo?(nissan4321)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.