Search activity doesn't respect "Show search suggestions" setting

RESOLVED WONTFIX

Status

()

Firefox for Android
Search Activity
RESOLVED WONTFIX
3 years ago
22 days ago

People

(Reporter: john.morahan, Unassigned)

Tracking

36 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8577634 [details]
suggestions.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150306140254

Steps to reproduce:

1. (menu) -> settings -> customise -> search -> disable "Show search suggestions"
2. Open the search activity from the widget
3. Enter some search terms


Actual results:

Suggestions from remote search engines are displayed


Expected results:

No suggestions are not displayed, or only suggestions from local search history are displayed

Comment 1

3 years ago
Thanks for filing. I don't think we considered that preference when creating the search activity, since we added that originally only for suggestions when typing in the urlbar.

antlam, what do you think we should do here? I feel like the search activity isn't very useful without search suggestions, but we may still want to respect this pref. Either that, or make it clear that the setting is only about suggestions in the urlbar.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(alam)
The Search Activity was not really designed to work with out suggestions so I'm leaning towards WONTFIX-ing this. I'd like this setting to remain pertaining to just general search. 

Since the user is already focused on searching with just one engine, I feel the value there is also rather small.

We could definitely make that clearer in the setting though. "Setting does not apply to Firefox Search."?
Flags: needinfo?(alam)
(Reporter)

Comment 3

2 years ago
I meant to link to this, but I couldn't find it again until just now:

http://research.microsoft.com/apps/pubs/default.aspx?id=119060

(in case the value of disabling suggestions even with only one search engine was unclear)

Comment 4

22 days ago
This is an ex-Search Activity now (bug 1221344).
Status: NEW → RESOLVED
Last Resolved: 22 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.