repeating events changed on ios app are not updated in Lightning

RESOLVED WORKSFORME

Status

Calendar
Provider: GData
P1
normal
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: dw.benini, Unassigned)

Tracking

({calendar-integration})

Lightning 3.3
x86_64
Windows 8.1
calendar-integration

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

I changed a repeating event in "Calendars" app (by Readdles, for iOS, which links to Google calendar) by moving an event "by hand" (function equal to "edit this occurrence")


Actual results:

Change is not reflected in Lightning (verified it works in Google Calendar).


Expected results:

Changes reflected in Lightning also
(Reporter)

Updated

3 years ago
Keywords: calendar-integration
OS: All → Windows 8.1
Hardware: All → x86_64

Comment 1

3 years ago
Hi, how do you connect Lightning with Google Calendar? Are you using the built-in CalDAV provider? Or are you using the Provider for Google Calendar extension? If yes, what version? Do you get any related error messages in Tools > Error Console?
Flags: needinfo?(dw.benini)
(Reporter)

Comment 2

3 years ago
I use Lightning with Thunderbird 31.5, the Google Provider for calendar version 1.0.2, Lightning version 3.3.3. Sorry if I wasn't complete in info.
In Error Console I have two messages that appear to have to do with the calendar.
The messages follow.

####################################################

Message 1:
[JavaScript Error: "[calGoogleCalendar] Modifying item Coro CI Lez CORO failed:2147746065: A request Error Occurred. Status Code: 400 Bad Request Body: {
 "error": {
  "errors": [
   {
    "domain": "calendar",
    "reason": "cannotConvertInstanceToRecurring",
    "message": "Cannot turn an instance of a recurring event into a recurring event itself."
   }
  ],
  "code": 400,
  "message": "Cannot turn an instance of a recurring event into a recurring event itself."
 }
}
"]
##########################################################

Message 2 (latest, but no date):
[JavaScript Warning: "[calCachedCalendar] Unable to perform playback action modify to the server, will try again next time (qvgn47cqgs3onje2ri45voekv8@google.com,A request Error Occurred. Status Code: 400 Bad Request Body: {
 "error": {
  "errors": [
   {
    "domain": "calendar",
    "reason": "cannotConvertInstanceToRecurring",
    "message": "Cannot turn an instance of a recurring event into a recurring event itself."
   }
  ],
  "code": 400,
  "message": "Cannot turn an instance of a recurring event into a recurring event itself."
 }
}
)"]
Flags: needinfo?(dw.benini)

Comment 3

3 years ago
Can you please check whether this still happens with the latest version of Google provider?
Component: Lightning Only → Provider: GData
Flags: needinfo?(dw.benini)
(Reporter)

Comment 4

3 years ago
Yes, just updated to 1.0.4.

- moved (by dragging) an event in iOS app
- event appears regularly in Google Calendar, along with the original recurring event (minus moved one)
- in Lightning, original event is broken: it has completely disappeared
Flags: needinfo?(dw.benini)
Priority: -- → P1
Created attachment 8650423 [details]
gdata-provider-1.0.5pre5.xpi

Can you try this xpi to see if it fixes it? If not, please enable debugging https://wiki.mozilla.org/Calendar:GDATA_Provider#Enabling_Debugging and let me know what JSON data is sent to the server just before the error message occurs.
Flags: needinfo?(dw.benini)
(Reporter)

Comment 6

2 years ago
Hello Philipp.
Installed xpi, seems to be working - changes reflected in Lightning as expected.
Flags: needinfo?(dw.benini)
(Reporter)

Comment 7

2 years ago
Hello Philipp.
Lightning is working as expected still, everything seems ok.
Thought I'd let you know :)
Ok, thanks for letting me know. Closing this bug WFM, not 100% sure which of the patches fixed it but as long as it works I am happy.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.