How to draw border-style: double border-width: 1px?

RESOLVED DUPLICATE of bug 1781

Status

()

Core
Layout: Block and Inline
RESOLVED DUPLICATE of bug 1781
17 years ago
15 years ago

People

(Reporter: Patrick Berry, Unassigned)

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.6+)
Gecko/20011207
BuildID:    2001120708

The page http://www.fire-ashcroft.org is using a 2-column ALA style layout.  The
main content is in a float:left div.  A div inside this div has a border:1px. 
The border should show on all 4 sides of the div, but only shows on the right
side of the div.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.fire-ashcroft.org
2. div in the float:left div do no render correctly

Actual Results:  div borders do not render correctly

Expected Results:  div borders should show on all sides of the div

The border show up correctly using IE 5 for Mac OS X.
I see the border on all four sides with linux build 2001-12-07-08
Never mind.  I see the problem... The site is using:

        .quote
        {
                border-color: silver;
                border-width: 1px;
                border-style: double;
        }

For border-style "double" correct rendering is:

  "The border is two solid lines. The sum of the two lines and the space between 
   them equals the value of 'border-width'."
    (from http://www.w3.org/TR/REC-CSS2/box.html#border-style-properties)

It's obviously impossible to actually draw a "double" 1px border... over to
layout to decide what to do with this.  Should we just fall back to "solid" for
1px "double" borders?
Assignee: jst → attinasi
Status: UNCONFIRMED → NEW
Component: DOM Style → Layout
Ever confirmed: true
QA Contact: ian → petersen
(Reporter)

Comment 3

17 years ago
Created attachment 61043 [details]
test case showing double border issue

While I don't know if the behavoir of mozilla will change, this test page shows
border-style:double with 1,2,and 3px border-width

Updated

17 years ago
Target Milestone: --- → Future
->Block & Inline
Assignee: attinasi → block-and-inline
Component: Layout → Layout: Block & Inline
Keywords: testcase
OS: MacOS X → All
QA Contact: petersen → ian
Hardware: Macintosh → All
Summary: css border not showing correctly in float-ed div → How to draw border-style: double border-width: 1px?

*** This bug has been marked as a duplicate of 1781 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.