expedia.com (and all local sites) sends desktop site to Firefox OS

RESOLVED WORKSFORME

Status

P5
normal
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: haseeb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-all][serversniff][contactready], URL)

(Reporter)

Description

4 years ago
Significant difference in source code:
Response sent to Firefox OS has Content-Length: 18707
Response sent to Firefox Android has Content-Length: 0

Firefox Android redirected to http://www.expedia.com.sg/MobileHotel, Firefox OS not redirected

Selected HTTP response headers:

Response for: 'Mozilla/5.0 (Mobile; rv:18.1) Gecko/18.1 Firefox/18.1'
Response Status: 200
content-length: 18707
content-type: text/html;charset=UTF-8

Response for: 'Mozilla/5.0 (Android; Mobile; rv:26.0) Gecko/26.0 Firefox/26.0'
Response Status: 302
content-length: 0
location: http://www.expedia.com.sg/MobileHotel
content-type: text/html;charset=UTF-8

Updated

4 years ago
See Also: → bug 1019185, bug 1019189

Comment 1

4 years ago
The same thing is happening on Expedia.com.

Basically the site receives on Firefox OS is a responsive Web site which is slightly different from the site at 
http://www.expedia.com.sg/MobileHotel or http://www.expedia.com/MobileHotel

To note that MobileHotel is working well with Gecko.

Two options:
* Live with it and we resolve this as a duplicate of Bug 1019189
* Make this bug a more generic bug for expedia properties on receiving MobileHotel.

Opinions? Hallvord, Abdul.
Flags: needinfo?(hsteen)
Flags: needinfo?(Abdulraufhaseeb)
I think the version Firefox on Android gets is more adapted to mobile. If you try to step through a booking (I tried flights) in Firefox OS you will eventually end up on pages that don't fit the screen - like the flights summary. I also tested briefly the Firefox on Android version on a Firefox OS Flame phone and it seemed to work just fine, including performance.
Flags: needinfo?(hsteen)
(That said, I don't think this is a .sg-specific issue, we should probably have one global bug for Expedia-sites)

Comment 4

3 years ago
Hallvord, agreed about expedia. and it's easy to refactor this one.
Summary: expedia.com.sg sends desktop site to Firefox OS → expedia.com sends desktop site to Firefox OS
Whiteboard: [country-sg][serversniff][contactready] → [country-all][serversniff][contactready]

Updated

3 years ago
Summary: expedia.com sends desktop site to Firefox OS → expedia.com (and all local sites) sends desktop site to Firefox OS
(Reporter)

Comment 5

3 years ago
I agree with hallvord
Flags: needinfo?(Abdulraufhaseeb)
Now responsive :)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Priority: -- → P5
Resolution: --- → WORKSFORME
(Hm..now I was testing pretty superficially, I see from comments the site was responsive on the main page and some others already a while ago. But Fx OS issues are no longer considered important.. I also assume that Expedia will have been rolling out more and more of their responsive redesign over time.)
You need to log in before you can comment on or make changes to this bug.