Closed Bug 1143462 Opened 7 years ago Closed 6 years ago

"Save picture as..." dialogbox does not accept keyboard input

Categories

(Firefox :: Keyboard Navigation, defect)

36 Branch
x86_64
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 465511

People

(Reporter: rudolf.lechleitner, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

Open any web-page with an image.
Rightclick the picture.
Select "Save picture as..." to save the image.
Optional: use the mouse to select a save-folder.
Press Enter to save the image.


Actual results:

Nothing.

1) Keyboard input in the OperatingSystem's Save-As bialogbox is not accepted (in my case Windows 8.1). Even Alt+S does not trigger the "Save" button. Also TAB cannot be used to switch the focus between different controls within the dialogbox. There is no visible focus.

2) Alt+Space opens the SystemMenu of the dialogbox, so it appears to be active in some way.

3) Clicking into a field (e.g. filename) puts the focus into this field, but TAB cannot be used to move the focus into another field (again: no function).


Expected results:

Picture should be saved (and the dialogbox should be closed).
It should be possible to switch the focus between different controls of the dialogbox.
Works for me in Firefox 36 on Fedora 21 so might be Windows platform specific.
Hmm, very strange: had this only once today and seems now to work again.
Yesterday the problem occured with every of the 209(!) images on:
http://eventpiks.at/galerie/piwigo/picture.php?/106621/category/830

Yesterday system-keys like TAB and ENTER did not work. Only typing a filename worked (if the name-field was focused with the mouse).

So, even if currently not reproducible, potential causes of the issue should be examined.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Built from https://hg.mozilla.org/releases/mozilla-release/rev/29182ac68a26

Works for me. I'll also add that this has always worked for me, for as long as I've used Firefox. Please test if the issue occurs in the latest version with a brand new profile.
https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines#How_to_report_a_bug
Component: Untriaged → Keyboard Navigation
See Also: → 1130714
I've had no issue getting it to work on windows 7 on firefox 48 dev.
>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
Doesn't work for me. I confirm the bug. I'll also add that this has never worked for me, for as long
as I've used Firefox. Sometimes it requires many pressings of Enter, and sometimes I must click "Save"
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 465511
You need to log in before you can comment on or make changes to this bug.