Corrupted downloads when temp space low

VERIFIED DUPLICATE of bug 65770

Status

Core Graveyard
File Handling
--
major
VERIFIED DUPLICATE of bug 65770
17 years ago
2 years ago

People

(Reporter: Callum Lerwick, Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    2001101201

I'm running Linux with two partitions, a root partition thats rather low on
space (~50mb free...) and a FAT32 filesystem with gigs of space on /Cdos that
holds my windows setup, and also my mp3s and such.

I was downloading a large number of mp3s from a web site, easily 10 files in
progress at a time, on a fast (Cable) connection. After I started listening to
them, I noticed most of the files ended up corrupted, as if sections of the song
got chopped out in the middle.

I notice the current versions of Mozilla are downloading files into temp space
somewhere (/tmp? The browser cache?) until the file is complete, THEN moves to
where I specified. (The parition that HAS the space for the files) I really HATE
this behavior, the main reason being with streamable file types like mp3, you
can no longer start listening to the file while it downloads.

Anyway, the saga of file saving has been done to death.(Bug 55690) Its obvious
my root was filling up, corrupting the temporary files. The real issue here is
mozilla did not detect the situation and give an error. It just silently saved
corrupted downloads.

I have not tested what happens if you download a single file large enough to
fill temp space.
I really want to rant on about the larger issues with mozilla's downloading, and
how I want things done, but this isn't quite the appropriate forum...

Reproducible: Always
Steps to Reproduce:
1. Find a page with several large files
2. Download at least two (Can it happen with one?) at a time, with a total size
larger than free space on the partition /tmp (or whatever it is mozilla uses) is on.



Actual Results:  Files are corrupted.

Expected Results:  Given an error, "Not enough temp space" or somesuch. Though
really, this is yet another edge to the N-blade sword discussed in bug 55690.

Comment 1

17 years ago
Better error handling is bug 27609
Resolving as dup of bug 65770

Related bugs you may want to know about:
bug 59808, bug 69938

*** This bug has been marked as a duplicate of 65770 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
*** Bug 124710 has been marked as a duplicate of this bug. ***
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.