Open in Tumblr button opens Play Store instead of App

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
a year ago

People

(Reporter: todd.bloom, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
Unspecified
Android

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-all] , URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.89 Safari/537.36
Firefox for Android

Steps to reproduce:

1. Open a blog post on a Tumblr log (____.tumblr.com/post/....)
2. Click on the 'open in Tumblr' button at the top of the page.


Actual results:

Was taken to the Play Store, even with the app installed (note this happens in Chrome with tabs merged with windows too).


Expected results:

Get a window to choose which app to open with or open directly in the Tumblr app.
(Reporter)

Updated

3 years ago
Component: Untriaged → General
OS: Mac OS X → Android
Product: Firefox → Firefox for Android
Hardware: x86 → Unspecified
Version: 36 Branch → Firefox 38

Comment 1

3 years ago
Aaron, is this an evangelism bug or something we can do on our end? It's been bugging me forever and I was finally coming to file a bug when I found it'd already been done.
(Reporter)

Comment 2

3 years ago
Just wanted to follow up on this. I still see it happening with the latest Firefox for Android on Moto X 2014 and Android 5.1.

Comment 3

3 years ago
made a screenshot on android http://imgur.com/LBncdJQ.png
They are using Chrome webapp tabs. For example going to http://welcometobusinesstown.tumblr.com/ and inspecting the anchor element for open shows http://www.tumblr.com/open/app?referrer=mobile_banner&app_args=blog%3FblogName%3Dwelcometobusinesstown%26page%3Dblog

bug 1212648 is for Chrome style webapps. For now it would be best if they supported http://stackoverflow.com/questions/11773958/open-android-application-from-a-web-page for Firefox for Android.
Status: UNCONFIRMED → NEW
Component: General → Mobile
Depends on: 1212648
Ever confirmed: true
Product: Firefox for Android → Tech Evangelism
Version: Firefox 38 → Trunk

Comment 5

3 years ago
The markup for the open

```html
<a 
  href="http://www.tumblr.com/open/app?referrer=mobile_banner&amp;app_args=blog%3FblogName%3Dwelcometobusinesstown%26page%3Dblog" 
  target="_blank" 
  id="btn_open_in_app" 
  class="chrome blue">
  <span class="label" data-translation="open">Open</span>
</a>
```

This link creates the following response from the server (with Firefox Android or Chrome Android):

```
→ http GET "http://www.tumblr.com/open/app?referrer=mobile_banner&app_args=blog%3FblogName%3Dwelcometobusinesstown%26page%3Dblog" 'User-Agent:Mozilla/5.0 (Android 5.0; Mobile; rv:45.0) Gecko/45.0 Firefox/45.0'

HTTP/1.1 302 Moved Temporarily
Connection: close
Content-Type: text/html
Date: Wed, 25 Nov 2015 02:22:16 GMT
Location: http://www.tumblr.com/download/android?log=0&intent=blog?blogName=welcometobusinesstown&page=blog
P3P: CP="Tumblr's privacy policy is available here: https://www.tumblr.com/policy/en/privacy"
Server: nginx
Set-Cookie: tmgioct=56551b57f354570748720660; expires=Sat, 22-Nov-2025 02:22:15 GMT; Max-Age=315360000; path=/; httponly
Transfer-Encoding: chunked
X-Frame-Options: deny
X-UA-Compatible: IE=Edge,chrome=1
```




btw testing with Firefox OS user agent (so no Android) I received:


```
HTTP/1.1 302 Moved Temporarily
Connection: close
Content-Type: text/html
Date: Wed, 25 Nov 2015 02:16:31 GMT
Location: tumblr://x-callback-url/blog?blogName=welcometobusinesstown&page=blog#_=_
P3P: CP="Tumblr's privacy policy is available here: https://www.tumblr.com/policy/en/privacy"
Server: nginx
Set-Cookie: tmgioct=565519ffc790c00119750150; expires=Sat, 22-Nov-2025 02:16:31 GMT; Max-Age=315360000; path=/; httponly
Transfer-Encoding: chunked
X-Frame-Options: deny
X-UA-Compatible: IE=Edge,chrome=1
```

So it seems they expect "tumblr://" to be significant in that case.

Updated

3 years ago
Whiteboard: [country-all]

Updated

2 years ago
See Also: → bug 1284398

Comment 6

2 years ago
I have the app installed. 

Going to the page, at the top there is a [open] button. (To note that there is also a [Install App] button.)
When you select the button [open], it creates an additional tab. 
at http://app.appsflyer.com/com.tumblr

which is in fact a GET request to 
http://app.appsflyer.com/com.tumblr?pid=tumblr_internal&c=mobile_banner

the server replies with 302 and 
Location: market://details?id=com.tumblr&referrer=af_tranid%3DApHvUKH3bw3PbP8FIwo2vg%26pid%3Dtumblr_internal%26c%3Dmobile_banner

which is indeed opening the Google Play Store.



On Chrome Android, when I ask for Open it sends me a "Complete Action using" with the list of browsers.
I'm choosing Chrome. And it goes directly to… the Play Store too. 

So basically I have no differences in between the two, except that chrome is not opening an additional tab.

When you choose open in the play store, it has lost in the meantime the address of the tumblr you wanted to open.

Closing as INVALID?

It's not a very satisfying user experience, but I guess Tumblr is aware of it.


The controls are inserted through an iframe.

```
<iframe src="about:blank" scrolling="no" name="controls" class="tmblr-iframe tmblr-iframe--controls iframe-controls--phone-mobile" width="0" height="0" frameborder="0"></iframe>
```

and inside the iframe

```
<div class="iframe-controls-container iframe-controls-container--mobile iframe-controls-container--handheld">
    <div class="buttons-container">
        <div class="t-logo-container">
            <a class="t-logo" href="https://www.tumblr.com" target="_blank">
                <svg class="svg-logo" width="29px" height="39px" viewBox="0 0 29 39" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
                    <!-- … -->
                </svg>
            </a>
        </div> 
        <a data-js-open-in-app="" 
           class="tx-button blue desktop-hidden" 
           href="http://www.tumblr.com/open/app?referrer=mobile_banner&amp;app_args=blog%3FblogName%3Dorphanblack%26page%3Dblog">
            <span>Open</span>
        </a> 
        <a data-js-install-app="" 
           class="tx-button white desktop-hidden" 
           href="https://go.onelink.me/893408789?pid=tumblr_blog_network&amp;c=tumblr_blog_network&amp;af_sub3=orphanblack">
            <span>Install the App</span>
        </a> 
        <a class="tumblr-button tx-button tumblr-blue" target="_top" href="https://www.tumblr.com/?referring_blog=orphanblack">
            <span class="logo">Tumblr</span>
        </a>
    </div>
</div>
```

with Firefox Android

HTTP/1.1 302 Found
Age: 0
Connection: keep-alive
Content-Type: text/html
Date: Fri, 02 Sep 2016 01:44:01 GMT
Location: http://app.appsflyer.com/com.tumblr?pid=tumblr_internal&c=mobile_banner
P3P: CP="Tumblr's privacy policy is available here: https://www.tumblr.com/policy/en/privacy"
Server: ATS
Set-Cookie: tmgioct=57c8d961b452610183845860; expires=Mon, 31-Aug-2026 01:44:01 GMT; Max-Age=315360000; path=/; domain=.tumblr.com; httponly
Transfer-Encoding: chunked
Via: http/1.1 r14.ycpi.nyc.yahoo.net (ApacheTrafficServer [cMsSf ]), http/1.1 r10.ycpi.tp2.yahoo.net (ApacheTrafficServer [cMsSf ])
X-Frame-Options: deny
X-UA-Compatible: IE=Edge,chrome=1


with Chrome Android, we received the same markup and the same HTTP response.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID

Comment 7

2 years ago
I met the same problem when I changed my phone from meizu note2 to 360 N4A. 

The Browser was the same one: UC, and I installed tumblr app from the play store.

On meizu note2, I can open tumblr app from UC, by clicking "Open the APP" button.

But on N4A, it jumps to the interface that ask me to choice an app to open, such as Play store, and other appstores.

The tumblr app may follow URL such as "tumblr://", so I think maybe there's something wrong with the tumblr server responsed URL likes "http://www.tumblr.com/open/app?referrer=mobile_banner&amp;app_args=blog%3FblogName%3Dwelcometobusinesstown%26page%3Dblog"

Unfortunately the meizu note2 was lost, so I can't find the things happen on it.

Comment 8

2 years ago
Things interesting.

I changed UC browser mode from android to iphone, now the "Open the APP" button works.

Comment 9

2 years ago
It's not a bug of Mozilla, it's about all browsers in Android. Look for Chrome bug page: https://bugs.chromium.org/p/chromium/issues/detail?id=461288&can=2&start=0&num=100&q=&colspec=ID%20Pri%20M%20Stars%20ReleaseBlock%20Component%20Status%20Owner%20Summary%20OS%20Modified&groupby=&sort=
I recently change my phone to Android to iPhone (S7 Edge), and now I can't use "Open in App" button. I think the problem isn't about browsers, it's about the bug on Tumblr's mobile page (or app)
The 6th comment of this chromium issue has an interesting comment.

> This is a known issue in the document mode; Issue 432562.
> Overriding a URL doesn't work often when opening 
> a new document activity, and so an Intent doesn't start.
> I confirmed that the problem didn't happen in the tab mode.
https://bugs.chromium.org/p/chromium/issues/detail?id=461288#c6

This other bug also explains some conditions for it.
  Apps not launched when "merge tabs and apps" is enabled. 
  https://bugs.chromium.org/p/chromium/issues/detail?id=434546

The original issue on Chromium has been closed, claiming that it was fixed in M44.
Though subsequent comments say that it is still happening in Chrome.
Comment hidden (spam)
You need to log in before you can comment on or make changes to this bug.