Closed Bug 1143528 Opened 5 years ago Closed 5 years ago

[Flame][NFC] Can't enable/disable NFC in Settings.

Categories

(Firefox OS Graveyard :: NFC, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master unaffected)

VERIFIED FIXED
2.2 S8 (20mar)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- unaffected

People

(Reporter: wangxin, Assigned: tzimmermann)

References

Details

Attachments

(3 files)

[1.Description]:
[Flame][v2.2][NFC] The NFC item turns grey and cannot be enabled in Settings
Found Time: 20:57.
See log: "logcat_2057.txt"
See video: "2057.mp4"

[2.Testing Steps]: 
1. Launch "Settings".
2. Try to Enable/Disable NFC.

[3.Expected Result]: 
2. NFC should be enabled/disabled.

[4.Actual Result]: 
2. NFC can't be enabled/disabled.

[5.Reproduction build]: 

Flame 2.2 (Affected)
Build ID               20150315162500
Gaia Revision          a6b2d3f8478ec250beb49950fecbb8a16465ff6f
Gaia Date              2015-03-15 14:33:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/18619f8f6c5c
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150315.195030
Firmware Date          Sun Mar 15 19:50:42 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0(Unaffected)
Build ID               20150315160203
Gaia Revision          d4177902b04b8fedcb7df9a30ae6e9677e03d2d4
Gaia Date              2015-03-13 15:58:35
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/af68c9c0e903
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150315.192711
Firmware Date          Sun Mar 15 19:27:22 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached video Bug video: 2057.mp4
Hi Dimi,

Could you please help to check this issue? Thank you.
blocking-b2g: --- → 2.2?
QA Whiteboard: [COM=NFC]
Flags: needinfo?(dlee)
Hi Thomas
I think this issue is related to 
https://github.com/mozilla-b2g/device-flame/pull/84 
pull request in Bug 1109592, the pull request is merged to kk branch not master branch

So nfcd is disable for flame-kk 2.2, could you help check it ? thanks
Flags: needinfo?(dlee) → needinfo?(tzimmermann)
AFAICT all patches and pull requests of bug 1109592 went into m-c and the master branches. V2.2 should not be affected.

I'm building v2.2 right now. Maybe I'll find something.
Flags: needinfo?(tzimmermann)
Oh, sorry! Yeah looks like the kitkat branch. Let's fix this.
Assignee: nobody → tzimmermann
Status: NEW → ASSIGNED
The problem is that both, 'master' [1] and v2.2 [2] of flame-kk refer to the kitkat branch of device_flame. We'll need a separate branch for 2.2.

Michael, can we introduce a branch for v2.2 on Kitkat for the Flame (e.g., 'v2.2-kitkat')?

[1] https://github.com/mozilla-b2g/b2g-manifest/blob/master/flame-kk.xml#L12
[2] https://github.com/mozilla-b2g/b2g-manifest/blob/v2.2/flame-kk.xml#L153
Flags: needinfo?(mwu)
Or maybe use a separate repo 'device-flame-kk'?
I think you can just hard code it to the commit before yours for now. Adding new repos is a pain.
Flags: needinfo?(mwu)
Attached file Github pull request
Attachment #8578511 - Flags: review?(mwu)
blocking-b2g: 2.2? → 2.2+
Attachment #8578511 - Flags: review?(mwu) → review+
Blocks: 1090799
Thank you!

I'd run it on try, but there seems to be no flame platform for try.
Keywords: checkin-needed
v2.2: https://github.com/mozilla-b2g/b2g-manifest/commit/84e6a4808c9c07549bb4075f4eec0d58c2443bf6
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S8 (20mar)
Verified on
Gaia-Rev        6a58c433c53c25e96e067a9b38bf1cc17307d5b2
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/22b4d45fe055
Build-ID        20150318162504
Version         37.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150318.195950
FW-Date         Wed Mar 18 20:00:01 EDT 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
See Also: → 1153721
You need to log in before you can comment on or make changes to this bug.