If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[gui] replace the bisection wizard with a header panel

RESOLVED WORKSFORME

Status

Testing
mozregression
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: parkouss, Assigned: parkouss)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
First implementation was to use a wizard for defining bisection options. We want to use instead a header panel to have a one window application.
(Assignee)

Comment 1

3 years ago
Created attachment 8577927 [details] [review]
Gui panel header to replace wizard
Attachment #8577927 - Flags: review?(wlachance)
(Assignee)

Updated

3 years ago
Blocks: 1143597
(Assignee)

Comment 2

3 years ago
Hm, I'm wondering how we will handle the editors for each bisection option in this panel (bug 1143597). We have quite a lot options like profile, preferences, etc which will requires specific editor. I wonder how we can display all this in the header panel.

The wizard is maybe a good solution finally because it seems easy to display all this information on multiple sorted pages, with a logical way of filling the forms, and defining options step by step.

Will, what do you think ? I would vote for the wizard, I think it will be less difficult to display editors. If you agree, let's forget about this bug and this PR, else let's discuss that :).
Flags: needinfo?(wlachance)
(Assignee)

Comment 3

3 years ago
Comment on attachment 8577927 [details] [review]
Gui panel header to replace wizard

Removing review flag until this is clarified.
Attachment #8577927 - Flags: review?(wlachance)
I'd very much caution against using a wizard here, as I think it would be awkward and confusing. I would try to keep the number of options in the header to an absolute minimum at first. People can always fall back to using the command-line version if they have specialized needs. For a first pass, I'd just like to make it easier for new contributors to Mozilla to make basic bisections. At some later point, I would guess we could add some kind of button that would open up an "advanced" dialog that lets them configure mozregression in more esoteric ways.
Flags: needinfo?(wlachance)
(Assignee)

Comment 5

3 years ago
Comment on attachment 8577927 [details] [review]
Gui panel header to replace wizard

Hm, the more I think about it, the more I think that the wizard is the right way for doing this. I think it exists exactly for the kind of needs we are facing, and so it would be a good choice for future extension and clarity (again, from my point of view).

That being said, I already wrote that code. You can look at it to see if that suit your needs.
Attachment #8577927 - Flags: review?(wlachance)
Comment on attachment 8577927 [details] [review]
Gui panel header to replace wizard

Hey Julien, I think maybe the best strategy for now is for you to pursue a vision of the GUI that you think best. :) It's a bit hard for me to evaluate stuff when so much has left to be done and I have to admit I haven't been able to really think this problem through 100%. Since the GUI doesn't effect anything else in mozregression, I'd say go ahead and push this.
Attachment #8577927 - Flags: review?(wlachance)
(Assignee)

Comment 7

3 years ago
Ok, so I'm closing this bug for now. We may reopen something similar later if we feel that we need it.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.